Content Management and Capture

 View Only

Default ICN was not installed properly while CP4BA FileNet ACCE get installed on ROSA (Non-prod, starter install)

  • 1.  Default ICN was not installed properly while CP4BA FileNet ACCE get installed on ROSA (Non-prod, starter install)

    Posted 14 days ago
      |   view attached

    Team, 

    I am facing one installation issue at CP4BA -> FNCM -> ICN ansible YAML level. Refer attached PPT file of full details. Any suggestion how to troubleshoot this quickly.

    - I installed CP4BA(22.0.2)->FNCM 5.5.10 on ROSA. It's a Non-Prod and Starter deployment.
    - All components, like ACCE, GraphQL, CMIS and CBRDashboards are working fine.
    - In access-info, Navigator end-point and login credential also get generated but when I am trying to open navigator end-point error comes as "Error 404 - Not Found".
    - I found below error in "FNCM" operator -> content deployment YAML file (refer screen shot in PPT attached). My laptop is connected with ROSA env with OC CLI (having all access) also but not able to find folder "ansible" in "/opt" folder. Stuck !!!
    ------------
    navigator:
          lastTransitionTime: '2024-05-17T08:31:10Z'
          message: |-
            The task includes an option with an undefined variable. The error was: list object has no element 0
            The error appears to be in '/opt/ansible/roles/Navigator/tasks/icn-iam-registration.yaml': line 75, column 3, but may be elsewhere in the file depending on the exact syntax problem.
            The offending line appears to be:        - set_fact: ^ here
          navigatorDeployment: Failed
          navigatorService: Failed
          navigatorStorage: NotInstalled
          navigatorZenIntegration: NotInstalled
          reason: Navigator pre-deployment failed! Pls check Ansible log for details. "
    --------


    ------------------------------
    Pranav Kumar
    ------------------------------

    Attachment(s)

    pptx
    ICN_ansible_error.pptx   967 KB 1 version