App Connect

 View Only
  • 1.  App connect(Saas) : Unauthorized while testing event-driven flows

    Posted 26 days ago

    Hello IBM Team

    Whenever I try to do unit test on APP Connect designer (running on IBM Cloud), always ends up with authorization error. And this started just couple of weeks back. I am using basic authentication and logged into App connect instance but not able to test the running flow. This works perfectly fine when hitting api from Watson orchestrate. Can you help in identifying the issue on saas instance ? And it exists even in production server.



    ------------------------------
    Preethi Ram
    ------------------------------


  • 2.  RE: App connect(Saas) : Unauthorized while testing event-driven flows

    Posted 25 days ago

    Hello,

    Could you please confirm a couple of questions relating to the scenario

    • You state that you are using App Connect on IBM Cloud but the screen shot looks to show the App Connect Enterprise as a Service offering that is hosted on AWS, could you please confirm?
    • Are you using API Connect alongside App Connect to provide API management here or are you just using App Connect?
    • If you provide username and password is the API working correctly? Is the issue that you are prompted each time rather than the credentials being automatically populated into the test?


    ------------------------------
    Martin Ross
    IBM
    ------------------------------



  • 3.  RE: App connect(Saas) : Unauthorized while testing event-driven flows

    Posted 25 days ago

    Update - I can see the following behaviour in App Connect Enterprise as a Service currently if you could confirm if this is what you are experiencing. If I create a new API flow and start the flow without unified authoring enabled (the API is not managed by API Connect), then when I navigate to the test tab the username and password do not appear to be passed on the API call correctly. However, if I invoke the API separately using curl with the username and password provided on the panel then the API executes and responds successfully.

    Could you confirm that this is what you are observing and whether the API is working correctly if you invoke it separately using curl or equivalent tool?



    ------------------------------
    Martin Ross
    IBM
    ------------------------------



  • 4.  RE: App connect(Saas) : Unauthorized while testing event-driven flows

    Posted 25 days ago

    Yes Martin, that's what exactly issu I am facing now. API doesn't work if I try from test tab but works fine when I trigger from Watson 



    ------------------------------
    Preethi Ram
    ------------------------------



  • 5.  RE: App connect(Saas) : Unauthorized while testing event-driven flows

    Posted 18 days ago

    Hello Martin,

    Is there any solution from your end ?

    Thanks

    Preethi



    ------------------------------
    Preethi Ram
    ------------------------------



  • 6.  RE: App connect(Saas) : Unauthorized while testing event-driven flows

    Posted 8 days ago

    Hello Preethi

    Team have delivered a fix and I have just verified that this is working for me - could you please check?



    ------------------------------
    Martin Ross
    IBM
    ------------------------------



  • 7.  RE: App connect(Saas) : Unauthorized while testing event-driven flows

    Posted 8 days ago

    Yes Martin, now could able to do testing successfully. Thanks a lot for your help!



    ------------------------------
    Preethi Ram
    ------------------------------



  • 8.  RE: App connect(Saas) : Unauthorized while testing event-driven flows

    Posted 25 days ago

    Hello Martin,

    Thanks for quick check. Below are my responses:

    Yes I am using app connect enterprise as a service hosted on AWS.

    And I am not using API connect. It's just app connect 

    Even after providing username and password, I could see prompt popping up multiple times on screen and then it gives me 401 unauthorized. But I could able to test the same flow when it is not running with  "try now" without any issues. Also could able to trigger running API from Watson using basic authentication without any issue. But I don't understand why I couldn't able to test running API on App Connect.



    ------------------------------
    Preethi Ram
    ------------------------------