IBM Security Join our 16,000+ members as we work together to overcome the toughest challenges of cybersecurity. Join the Community
Dear Community members ,Hope you all are doing well.I have already raised a ticket with support but was wondering if anyone have faced this before.I was testing installing abuseIPDB on integration server https://exchange.xforce.ibmcloud.com/hub/extension/68bc8d72ddae131e848ceb4803862287The app was installed successfully and I can see it when using pip freeze.during that , resilient-circuits was upgraded automatically to the latest version.after that , whenever I run resilient-circuits , it always throws the attached error.please let me know how to troubleshoot that.
Hi Mohamad,It looks like the resilient package was not upgraded along with resilient-circuits. Can you do a 'pip freeze' to confirm if 'resilient' has a different version compared to 'resilient-circuits'? If so run 'pip install --upgrade resilient' to get the correct version. Good luck,Mark
Hi mark , please check current pip freeze output below.is it possible to downgrade to the older version instead as I want to keep the lab in track with production.if yes , how can i do that.Thank you===========================pip freeze output : beautifulsoup4==4.11.1cachetools==2.1.0certifi==2020.12.5cffi==1.15.1chardet==4.0.0charset-normalizer==2.0.12circuits==3.2.1cryptography==40.0.2decorator==5.1.1Deprecated==1.2.13filelock==3.4.1idna==2.10importlib-metadata==3.7.3Jinja2==3.0.3jwcrypto==1.4.2keyring==23.4.1MarkupSafe==2.0.1py==1.11.0pycparser==2.21PySocks==1.7.1pytz==2022.2.1pywin32==300pywin32-ctypes==0.2.0rc-email==1.0.4requests==2.27.1requests-mock==1.8.0requests-toolbelt==1.0.0resilient==48.2.4321resilient-circuits==48.2.4321resilient-lib==48.2.4321retry2==0.9.4simplejson==3.17.6six==1.16.0soupsieve==2.3.2.post1stompest==2.3.0typing-extensions==22.214.171.124urllib3==1.26.4watchdog==2.1.9wrapt==1.14.1zipp==3.4.
Hi Mohamad,It is possible to downgrade. This logic has been around for nearly 2 years, so I'm surprised you're experiencing an error.To downgrade, you can run a command like this: pip install resilient==46.0.3461 resilient-lib==46.0.3461 resilient-circuits==46.0.3461To see all the possible versions available, using a non-existent version like 99 will display all versions:
% pip install resilient-circuits==99
ERROR: Could not find a version that satisfies the requirement resilient-circuits==99 (from versions: 29.0.0, 29.0.1, 29.1.0, 30.0.84, 30.0.85, 30.0.86, 30.0.89, 30.0.111, 31.0.0, 32.0.0, 32.0.126, 32.0.140, 32.0.186, 33.0.189, 33.0.192, 34.0.194, 34.0.195, 35.0.0.dev0, 35.0.203, 36.2.209.dev0, 37.0.211.dev0, 37.0.214, 37.2.215, 38.0.71rc0, 38.0.73rc0, 38.0.74.dev0, 38.0.75.dev0, 38.0.76, 39.0.77.dev0, 39.0.226, 39.0.227, 39.0.228.dev0, 40.0.1rc0, 40.0.100, 40.1.1880, 40.2.1939, 41.0.1976, 41.1.2013, 42.0.2101, 42.1.2111, 42.1.2116, 42.2.2190, 42.3.2330, 43.0.2419, 43.0.2433, 43.1.2656, 44.0.2810, 44.1.2953, 45.0.3150, 45.1.3279, 46.0.3461, 47.0.3691, 47.1.3780, 48.0.4034, 48.1.4243, 48.2.4321)
Dear Mark , Thank you for your help.Issue was resolved after downgrading to v43.