IBM Security Z Security

 View Only
  • 1.  CKNSERVE missing DD

    Posted Wed July 14, 2021 12:20 PM
    I am posting this query again as I had no replies to the original post from last year.

    When issuing a RACF command within zSecure using self-connect mode, we are seeing the following message in the CKNSERVE stc:


    IEC130I          DD STATEMENT MISSING

    and the following in the zSecure output file:

    IKJ56241I UTILITY DATA SET NOT ALLOCATED+
    IKJ56241I SPECIFIED UNIT IS UNDEFINED

    The message does not specify which DD statement it is referring to. 

    Has anyone come across this before?

    Thanks.

    ------------------------------
    Anji Stephens
    ------------------------------


  • 2.  RE: CKNSERVE missing DD

    Posted Thu July 15, 2021 09:27 AM

    Hm, if nobody answers, it probably means that nobody has come across this before :-)

    But seriously, CKNSERVE and CKX (the command executor) try to allocate a temporary dataset. It is attempted using the default (probably blank) esoteric unitname. For most customers that seems to work fine. It's unclear why that fails in your environment, maybe ACS routines?

    Probably the best way to continue is to open a case with the support team.



    ------------------------------
    Guus Bonnes
    ------------------------------



  • 3.  RE: CKNSERVE missing DD

    Posted Thu July 15, 2021 10:29 AM
    Thank you Guus, I will do that.

    Regards,

    ------------------------------
    Anji Stephens
    ------------------------------