UrbanCode

 View Only
  • 1.  Error while upgrading from v.6.2.7.15 to v7.0.2.0 or from v.6.2.7.15 to v7.1.0.0

    Posted Tue August 30, 2022 03:25 PM
    I am getting below error while upgrading IBM UrbanCode Deploy from v.6.2.7.15 to v7.0.2.0 or from v.6.2.7.15 to v7.1.0.0:

    [echo] Found database upgrades, cancelling currently running processes
    [upgrade] Adding upgrade file for processing: /home/mdespatch/7.0.2.0/ibm-ucd-install/database/deploy/always/all/always_sql.xml
    [upgrade] Processing change set release 0.8
    [upgrade] Found 0.8 current version: 0
    [upgrade] Applying 0.8 change: 1
    java.lang.Exception: Error trying to cancel currently running processes
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    at org.codehaus.groovy.reflection.CachedConstructor.invoke(CachedConstructor.java:83)
    at org.codehaus.groovy.runtime.callsite.ConstructorSite$ConstructorSiteNoUnwrapNoCoerce.callConstructor(ConstructorSite.java:105)
    at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallConstructor(CallSiteArray.java:59)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callConstructor(AbstractCallSite.java:238)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callConstructor(AbstractCallSite.java:258)
    at UCDeployInstaller.markProcessesCancelled(UCDeployInstaller.groovy:791)
    at UCDeployInstaller.preContainerFileInstall(UCDeployInstaller.groovy:623)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:98)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:325)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:1225)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:1034)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:822)
    at UCDeployInstaller.invokeMethod(UCDeployInstaller.groovy)
    at groovy.lang.GroovyObject$invokeMethod.call(Unknown Source)
    at ContainerInstaller.callSubInstallerMethod(ContainerInstaller.groovy:1745)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:98)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:325)
    at org.codehaus.groovy.runtime.metaclass.ClosureMetaClass.invokeMethod(ClosureMetaClass.java:352)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:1034)
    at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.callCurrent(PogoMetaClassSite.java:68)
    at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallCurrent(CallSiteArray.java:51)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:157)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:185)
    at ContainerInstaller$_installServer_closure7.doCall(ContainerInstaller.groovy:556)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:98)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:325)
    at org.codehaus.groovy.runtime.metaclass.ClosureMetaClass.invokeMethod(ClosureMetaClass.java:264)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:1034)
    at groovy.lang.Closure.call(Closure.java:418)
    at groovy.lang.Closure.call(Closure.java:434)
    at org.codehaus.groovy.runtime.DefaultGroovyMethods.each(DefaultGroovyMethods.java:2125)
    at org.codehaus.groovy.runtime.DefaultGroovyMethods.each(DefaultGroovyMethods.java:2110)
    at org.codehaus.groovy.runtime.DefaultGroovyMethods.each(DefaultGroovyMethods.java:2151)
    at org.codehaus.groovy.runtime.dgm$163.invoke(Unknown Source)
    at org.codehaus.groovy.runtime.callsite.PojoMetaMethodSite$PojoMetaMethodSiteNoUnwrapNoCoerce.invoke(PojoMetaMethodSite.java:274)
    at org.codehaus.groovy.runtime.callsite.PojoMetaMethodSite.call(PojoMetaMethodSite.java:56)
    at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:47)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:116)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:128)
    at ContainerInstaller.installServer(ContainerInstaller.groovy:556)
    at ContainerInstaller.install(ContainerInstaller.groovy:284)
    at ContainerInstaller$install$0.call(Unknown Source)
    at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:47)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:116)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:120)
    at embedded_script_in__home_mdespatch_7_dot_0_dot_2_dot_0_ibm_ucd_install_install_dot_with_dot_groovy_dot_xml.run(embedded_script_in__home_mdespatch_7_dot_0_dot_2_dot_0_ibm_ucd_install_install_dot_with_dot_groovy_dot_xml:6)
    at org.codehaus.groovy.ant.Groovy.parseAndRunScript(Groovy.java:500)
    at org.codehaus.groovy.ant.Groovy.execGroovy(Groovy.java:447)
    at org.codehaus.groovy.ant.Groovy.execute(Groovy.java:305)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
    at sun.reflect.GeneratedMethodAccessor5.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.Task.perform(Task.java:348)
    at org.apache.tools.ant.Target.execute(Target.java:357)
    at org.apache.tools.ant.Target.performTasks(Target.java:385)
    at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
    at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
    at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
    at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
    at org.apache.tools.ant.Main.runBuild(Main.java:758)
    at org.apache.tools.ant.Main.startAnt(Main.java:217)
    at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
    at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
    Caused by: : java.lang.NoClassDefFoundError: groovy/lang/Binding
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:116)
    at groovy.util.AntBuilder.performTask(AntBuilder.java:338)
    at groovy.util.AntBuilder.nodeCompleted(AntBuilder.java:283)
    at groovy.util.BuilderSupport.doInvokeMethod(BuilderSupport.java:154)
    at groovy.util.AntBuilder.doInvokeMethod(AntBuilder.java:218)
    at groovy.util.BuilderSupport.invokeMethod(BuilderSupport.java:67)
    at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.call(PogoMetaClassSite.java:47)
    at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:47)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:116)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:136)
    at UCDeployInstaller$_markProcessesCancelled_closure7.doCall(UCDeployInstaller.groovy:779)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:98)
    at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:325)
    at org.codehaus.groovy.runtime.metaclass.ClosureMetaClass.invokeMethod(ClosureMetaClass.java:264)
    at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:1034)
    at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.call(PogoMetaClassSite.java:41)
    at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:47)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:116)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:120)
    at UCDeployInstaller.runWithStartedDatabase(UCDeployInstaller.groovy:3089)
    at UCDeployInstaller$runWithStartedDatabase.callCurrent(Unknown Source)
    at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallCurrent(CallSiteArray.java:51)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:157)
    at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:169)
    at UCDeployInstaller.markProcessesCancelled(UCDeployInstaller.groovy:757)
    ... 71 more
    Caused by: java.lang.NoClassDefFoundError: groovy/lang/Binding
    at com.urbancode.cm.db.updater.GroovyDbUpdaterAction.apply(GroovyDbUpdaterAction.java:60)
    at com.urbancode.cm.db.updater.DbUpgradeTask.executeMultiVersionUpgrade(DbUpgradeTask.java:254)
    at com.urbancode.cm.db.updater.DbUpgradeTask.execute(DbUpgradeTask.java:81)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
    at sun.reflect.GeneratedMethodAccessor5.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    ... 99 more
    Caused by: java.lang.ClassNotFoundException: groovy.lang.Binding
    at org.apache.tools.ant.AntClassLoader.findClassInComponents(AntClassLoader.java:1400)
    at org.apache.tools.ant.AntClassLoader.findClass(AntClassLoader.java:1341)
    at org.apache.tools.ant.AntClassLoader.loadClass(AntClassLoader.java:1088)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:351)
    ... 107 more
    [echo] Install Failed. (press return to exit installer)

    Can someone please help?

    ------------------------------
    Mahesh PARKAR
    ------------------------------


  • 2.  RE: Error while upgrading from v.6.2.7.15 to v7.0.2.0 or from v.6.2.7.15 to v7.1.0.0

    Community Leadership
    Posted Thu September 01, 2022 05:41 PM
    Hi Mahesh, Our team is looking into this and will get back to you soon. Thanks for reaching out to us in the community.

    ------------------------------
    Divya Koppolu
    ------------------------------



  • 3.  RE: Error while upgrading from v.6.2.7.15 to v7.0.2.0 or from v.6.2.7.15 to v7.1.0.0

    User Group Leader
    Posted Fri September 02, 2022 10:09 AM
    Have you opened a support case?

    ------------------------------
    Osman Burucu
    Product Manager UrbanCode Family
    IBM
    Vienna
    00431211454746
    ------------------------------



  • 4.  RE: Error while upgrading from v.6.2.7.15 to v7.0.2.0 or from v.6.2.7.15 to v7.1.0.0

    Rational Test- Active Member
    Posted Fri September 02, 2022 10:31 AM
    Hi Mahesh,

    It looks like an issue that IBM Support can help you with.  Please submit a ticket. 
    https://www.ibm.com/mysupport/s/?language=en_US

    ------------------------------
    Laurel Dickson-Bull
    IBM
    ------------------------------



  • 5.  RE: Error while upgrading from v.6.2.7.15 to v7.0.2.0 or from v.6.2.7.15 to v7.1.0.0

    Posted Fri September 02, 2022 12:40 PM
    I was able to resolve it after adding groovy-all-2.4.15.jar in server/lib directory of my current installation.

    ------------------------------
    Mahesh PARKAR
    ------------------------------