Informix

Expand all | Collapse all

Seems InformixHQ doesn't like me

  • 1.  Seems InformixHQ doesn't like me

    Posted Wed March 10, 2021 04:05 PM

    I'm having difficulties getting IDS 14.10 Innovator-C installed on my raspberry pi. I was using my raspberry pi as a learning device to get InformixHQ installed at work.  Unfortunately I got no where fast on the raspberry pi so am  plowed ahead a worked on a ubuntu server.

     

    I checked I'm on the 32-bit raspberry pi os.

    uname -m

    armv7l

     

    All the post online said to use the ARM 32-bit version. So I downloaded ibm.ids.14.10.UC5.ARMV7.tar.

     

    I've tried running as informx and root.  I get same error and haven't found anything on the parameter using the -d32 when searching online.

     

     

    pi@raspberrypi:/tmp/ifxinstall $ sudo su - informix

    informix@raspberrypi:~ $ cd /tmp/ifxinstall/

    informix@raspberrypi:/tmp/ifxinstall $ ./ids_install

    Preparing to install

    Extracting the installation resources from the installer archive...

    Configuring the installer for this system's environment...

     

    Launching installer...

     

    Unrecognized option: -d32

    Error: Could not create the Java Virtual Machine.

    Error: A fatal exception has occurred. Program will exit.

     

     

    I found that option in the ids_install file, but know idea what that used for.

    grep d32 ids_install

    INSTALLER_OPTIONAL_ARGS="-d32"

     

     

    Any one have any suggestions. 

     

    John Adamski



  • 2.  RE: Seems InformixHQ doesn't like me

    Posted Wed March 10, 2021 05:21 PM
    Should you only be after HQ, pick it from any Linux (or other platform) installation you might have anywhere. It's a couple of .jar files plus sample property files that aren't platform specific at all.

    Else this is going to be an installer debug adventure on your pi.

    ------------------------------
    Andreas Legner
    ------------------------------



  • 3.  RE: Seems InformixHQ doesn't like me

    Posted 26 days ago

    I believe I finally figured out what was causing my install problem on my raspberry pi.

     

    It seems the current default java installed with the raspberryOS is openjdk-11 and the installer doesn't work with that version.  So you need to download openjdk-8 and then make it the default. You could probably switch back and use the jrv installed by Informix if need v8.

     

    So I did these steps:

     

    sudo apt-get update                          - make sure you have the latest list of apps

    sudo apt-get install openjdk-8-jdk           - get version 8

     

    java -version                                - verify it installed correctly

     

    sudo update-alternatives --config java       - use this cmd to switch the default – select v8 as default

     

    john