Informix

nested-group-icon.png

DB2

Expand all | Collapse all

IDS 14.10 - RSS with Windows Server

  • 1.  IDS 14.10 - RSS with Windows Server

    Posted Tue October 20, 2020 10:28 AM
    Hi,

    im trying to create a RSS instance with ids 14.10 following this guide:

    https://www.ibm.com/support/knowledgecenter/SSGU8G_14.1.0/com.ibm.admin.doc/ids_admin_1000.htm

    With 12.10 this steps are working fine, but with 14.10 i'm not able to bring the rss instance online.
    It fails with following messages:

    onmode -d RSS xxxx

    RSS Server did not successfully start. onmode: Please check the message log for errors.

    onstat -m

    IBM Informix Dynamic Server Version 14.10.FC3WE -- Fast Recovery -- Up 04:20:39 -- 9072384 Kbytes Message Log File: C:\Informix\xxxx.log 09/03/20 08:29:14 Maximum server connections 0 09/03/20 08:29:14 Checkpoint Statistics - Avg. Txn Block Time 0.000, # Txns blocked 0, Plog used 0, Llog used 0 09/03/20 08:29:16 Physical Restore of rootdbs, softlinedbs, jbpmdbs, llogdbs, plogdbs, sblobdbs Completed. 09/03/20 08:29:16 Checkpoint Completed: duration was 0 seconds. 09/03/20 08:29:16 Thu Sep 3 - loguniq 14535, logpos 0xf534018, timestamp: 0xf90105f Interval: 429036 09/03/20 08:29:16 Maximum server connections 0 09/03/20 11:05:32 DR: new type = RSS 09/03/20 11:05:53 System Error: Wait on network event fai led 09/03/20 11:05:53 Socket: 468, Mask: 16, Error: 10060 09/03/20 11:06:33 DR: Trying to connect to server, xxxx. If the specified server is not in Online mode, bring it to Online mode. 09/03/20 11:06:33 Data replication type and state information reset. To start DR, use the 'onmode -d' command and wait for the pair to be operational, before shutting down the database server 09/03/20 11:06:37 Defragmenter cleaner thread now running 09/03/20 11:06:37 Defragmenter cleaner thread cleaned:0 partitions 09/03/20 11:13:39 WARNING!!! Not building 'sysha' database because 'sysmaster' database is missing.

    ------------------------------
    Josef Albert
    ------------------------------


  • 2.  RE: IDS 14.10 - RSS with Windows Server

    Posted Tue October 20, 2020 10:43 AM
    Josef:

    Is the sqlhosts file properly configured on the RSS host? Have you defined the primary server in setnet32 (this being a Windows system)?

    Art

    Art S. Kagel, President and Principal Consultant
    ASK Database Management


    Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference.  Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves.








  • 3.  RE: IDS 14.10 - RSS with Windows Server

    Posted 30 days ago
    Hi Art,

    yes, i used the same steps as i used before with 12.10 instances:


    ------------------------------
    Josef Albert
    ------------------------------



  • 4.  RE: IDS 14.10 - RSS with Windows Server

    Posted 30 days ago
    Anything "RSS" isn't even your problem, you obviously got a much more fundamental problem to solve:

    09/03/20 11:13:39 WARNING!!! Not building 'sysha' database because 'sysmaster' database is missing.

    Now you're getting this error obviously on the newly restored RSS which is confusing as no database would be 'built' there anyway.

    -> how's the primary doing?  Does it have a sysmaster database? If not, is there any mention of 'buildsmi' in its messages log, and maybe an error output file detailing a reason?

    Which exact 14.10 are we talking about?

    ------------------------------
    Andreas Legner
    ------------------------------



  • 5.  RE: IDS 14.10 - RSS with Windows Server

    Posted 26 days ago
    Hi,

    Regarding last message it seems that instance has not been initialized building 'sysha' database because 'sysmaster' database is missing.

    SP


    ------------------------------
    Sergio Peres
    AIRC
    Coimbra
    ------------------------------



  • 6.  RE: IDS 14.10 - RSS with Windows Server

    Posted 24 days ago
    Hi,

    i receive this message when i try to finalize the rss with "onmode -d RSS primarysrv".
    The primary is doing fine, no problems.

    Also the RSS is doing fine when i try to take him online with "onmode -m" after the restore with "ontape -p".
    But when i try "onmode -d RSS primarysry" i receive the errors.

    ------------------------------
    Josef Albert
    ------------------------------



  • 7.  RE: IDS 14.10 - RSS with Windows Server

    Posted 24 days ago
    Josef:

    After the restore completes, you MUST NOT run onmode -m before running onmode -d RSS primarysrv!

    The onmode -m completes fast recovery putting the node into stand-alone mode. There is no way to go from standalone mode to an RSS secondary against a running primary because bringing the server to stand-alone mode will process logical log records that are different from the ones on the primary, essentially breaking replication!

    The method is:
    1. restore the secondary from an archive taken from the primary
    2. if the logical log that was current on the primary at the time the archive was taken is still available on the primary (it has not been overwritten). You can check what log was current at that time with onstat -g arc if you are restoring the latest archive.
      If that log is no longer available, then go to 3, else go to 4
    3. restore logical logs from the primary's log backups up to or beyond the log that was current on the primary when the archive was taken.
    4. run: onmode -d RSS primarysrv. Done

    Art

    Art S. Kagel, President and Principal Consultant
    ASK Database Management


    Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference.  Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves.








  • 8.  RE: IDS 14.10 - RSS with Windows Server

    Posted 24 days ago
    Edited by Josef Albert 24 days ago

    Hi Art,

    After the restore completes, you MUST NOT run onmode -m before running onmode -d RSS primarysrv!

    I know, i did it just to check the archive and the server. (sysdatabases)

    The method is:
    1. restore the secondary from an archive taken from the primary
    2. if the logical log that was current on the primary at the time the archive was taken is still available on the primary (it has not been overwritten). You can check what log was current at that time with onstat -g arc if you are restoring the latest archive.
      If that log is no longer available, then go to 3, else go to 4
    3. restore logical logs from the primary's log backups up to or beyond the log that was current on the primary when the archive was taken.
    4. run: onmode -d RSS primarysrv. Done
    This is exactly what i do.

    Oh, forgot, I assume that you have already run the: onmode -d add RSS <secondary_server> on the primary? If not do.

    Yes, i do.

    ------------------------------
    Josef Albert
    ------------------------------



  • 9.  RE: IDS 14.10 - RSS with Windows Server

    Posted 24 days ago
    Oh, forgot, I assume that you have already run the: onmode -d add RSS <secondary_server> on the primary? If not do.

    Art

    Art S. Kagel, President and Principal Consultant
    ASK Database Management


    Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference.  Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves.










  • 10.  RE: IDS 14.10 - RSS with Windows Server

    Posted 24 days ago
    Edited by Josef Albert 23 days ago
    Yes, i do.

    Can i've a problme with 2 different os?
    Primary is 2012 R2, RSS 2019.

    ------------------------------
    Josef Albert
    ------------------------------



  • 11.  RE: IDS 14.10 - RSS with Windows Server

    Posted 22 days ago

    Your error is:

    System Error: Wait on network event fai led 09/03/20 11:05:53 Socket: 468, Mask: 16, Error: 10060

    which OS version is used on that instance?

    Is the OS version listed as supported in the machine notes for that Informix version?

    ------------------------------
    David Williams
    ------------------------------



  • 12.  RE: IDS 14.10 - RSS with Windows Server

    Posted 21 days ago
    Hi,

    IDS: 14.10 FC3
    Primary: Win Srv 2012 R2
    RSS: Win 2019

    I don't find a reference about supported os in the machine notes.

    But here i can see that you need Win 2016 or higher for 14.10:
    https://www.ibm.com/support/pages/node/320749

    I'll migrate the primary to 2019 and after this i try to activate the rss again.

    ------------------------------
    Josef Albert
    ------------------------------



  • 13.  RE: IDS 14.10 - RSS with Windows Server

    Posted 2 days ago
    Edited by Josef Albert yesterday
    Hi,

    i finaly found the issue.
    It has nothing to do with the OS or something else.

    It's just a stupid informix bug.

    If there is no new line or space after the last line in the sqlhosts file the last char of the last line gets duplicated.

    With this sqlhosts settings informix tries to connect to slrz-t-db01:150000, not 15000.
    Because 150000 is too high it seems that informix uses 150000-65536-65536=18929 instead of throwing an error....

    Wireshark brought me in the right direction because dbaccess didn't try to connect to port 15000, instead it uses port 18929.

    You can see the bug in this example.

    Without a new line or space at the end:

    With a new line or a space at the end:


    Many days and many hair wasted, but it's working now.

    ------------------------------
    Josef Albert
    ------------------------------



  • 14.  RE: IDS 14.10 - RSS with Windows Server

    Posted 2 days ago

    Could be a Window'ism – I have seen system32/etc/..../services fail if there is not a blank line at the end

     

    Cheers

    Paul

     






  • 15.  RE: IDS 14.10 - RSS with Windows Server

    Posted 2 days ago

    Paul:

    I agree with you.  With IDS on Windows I have found it is best to have a carriage return line feed (CR LF) at the end of the sqlhosts and services files.



    ------------------------------
    Best regards,
    Martin Graney
    Queues Enforth Development, Inc.
    Stoneham, MA 02148
    ------------------------------



  • 16.  RE: IDS 14.10 - RSS with Windows Server

    Posted 2 days ago
    The windows gotcha I remember was the services file had to  be in numerical order - lots of head meet wall finding that one

    Cheers
    Paul

    Paul Watson
    Oninit LLC
    +1-913-387-7529
    www.oninit.com
    Oninit®️ is a registered trademark of Oninit LLC





  • 17.  RE: IDS 14.10 - RSS with Windows Server

    Posted yesterday
    The services file is not used when i type the port number directly (e.g. 15000 in my example) in the sqlhosts.
    So in this specific case it couldn't be a services file issue.

    Or am i being wrong here?

    ------------------------------
    Josef Albert
    ------------------------------



  • 18.  RE: IDS 14.10 - RSS with Windows Server

    Posted yesterday
    You are correct, the services file should only be accessed when you use a service name not when you use a port number.

    ------------------------------
    Art S. Kagel, President and Principal Consultant
    ASK Database Management Corp.
    www.askdbmgt.com
    ------------------------------



  • 19.  RE: IDS 14.10 - RSS with Windows Server

    Posted yesterday

    Nope, if you use the port number then you don't need  have an entry in /etc/services.  If you don't have  root access then it is your only choice

     

    Cheers

    Paul