Planning Analytics

 View Only
Expand all | Collapse all

2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

  • 1.  2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

    Posted Fri November 11, 2022 04:24 AM

    HI,

    We are looking to upgrade our Planning Analytics server to the latest version 2.0.9.15 from 2.0.9.11 and have notice some significant issues in transfer data from a cube to cube transfer in both versions 2.0.9.13 and 2.0.9.15.

    We have 70 lines of data from One cube which normally takes seconds but when we upgrade to the new version it is significantly slower

    I have isolated the issue to being :

    1) Have a rule in a element attribute cube that uses the ATTRS function

    2) Have cube dependencies run on start up. 

    I have found if I don't run cube dependencies on start-up and run the process it runs fine. 

    When I activate cube dependencies it slows the TI down significantly. 

    I have opened a case with IBM but has anyone else experienced this problem?

    Regards
    Herman


     



    ------------------------------
    Herman Moller
    ------------------------------

    #PlanningAnalyticswithWatson


  • 2.  RE: 2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

    Posted Fri November 11, 2022 09:18 AM
    I have isolated the code even more now.

    If you have this line in your startup chore or TI Process that's add Dependencies

    AddCubeDependency('S_Consolidated','}ElementAttributes_Account');

    Once this is run, the }ElementAttribute cube as the second part then run the TI will go really slow.



    ------------------------------
    Herman Moller
    ------------------------------



  • 3.  RE: 2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

    IBM Champion
    Posted Fri November 11, 2022 09:24 AM
    Hi Herman, could be linked to the issue Scott found:

    PH50635: Alias processing is very slow if there are rules in the }ElementAttributes_dimName cube



    ------------------------------
    George Tonkin
    Business Partner
    MCI Consultants
    Johannesburg
    ------------------------------



  • 4.  RE: 2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

    Posted Mon November 14, 2022 02:04 PM
    I don't know why the Cube Dependency is affecting the TI run times, but try updating the ATTRS function to A DB function in the Rule if possible. The DB function generally performs better than ATTR functions in rules. The only caveat is if you are referencing an alias with ATTRS. ATTRS will return the element principle name if the alias is blank in the }ElementAttributes_ cube, but DB will return a blank value if it's not populated. Just something to keep in mind.

    ------------------------------
    Tyler King
    ------------------------------



  • 5.  RE: 2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

    Posted Tue November 15, 2022 05:18 AM
    Hi Tyler,

    Thanks for the suggest it was actually one of the first things I tried but it still to have the same issue. ATTRS and DB referencing the }ElementAttribute cube made the TI run much slower.

    ------------------------------
    Herman Moller
    ------------------------------



  • 6.  RE: 2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

    Posted Tue January 17, 2023 06:08 AM
    IBM Support have come back to us. They have a fix - 2.0.9.15 IF2 which resolves the issue. We are currently testing the fix pack now.

    ------------------------------
    Herman Moller
    ------------------------------



  • 7.  RE: 2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

    Posted Thu January 26, 2023 05:11 AM
    Morning, Unfortunately we have found even through performance has improved in some areas this is still performances issue in comparison to previous versions of Planning Analytics.

    ------------------------------
    Herman Moller
    ------------------------------



  • 8.  RE: 2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

    Posted Fri January 27, 2023 06:10 AM
    Hi Herman,

    Happy New Year!  Hope all is well with you? (baring the obvious issues highlighted here!)

     As a cube dependacy is being built AddCubeDependency('S_Consolidated','}ElementAttributes_Account');

    I'm assuming there is a rule in S_Consolidated that makes reference to the Account Attributes?
    Is it the exact ruled attribute that is referenced by the the rules in S_Consolidated?
    Or is it just the fact that are any ruled attributes in the cube that cause the issue, i.e. the rule sheet only references value based attributes?

    Just trying to understand the detail so we can avoid the issue with any of customers.

    Cheers,

    ------------------------------
    Steven Rowe
    ------------------------------



  • 9.  RE: 2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

    Posted Wed February 01, 2023 07:09 AM
    Hi, 

    This is with relating to 2.0.9.15 IF2

    The good news is Cube Dependancy has been fixed but there seems to a be another problem which is with support at the moment. 

    I have found the new issue, after some more investigation, around using DIMIX in a rule formula and a process picking up the rule calculation value

     Problem Summary

    a) Have a alias rule on the }ElementAttribute Cube
    b) Have a DIMIX rule on in a calculation
    c) Retrieve that calculation in a process with a CellgetN

    If those three things are in play then the process runs really slowly.

    If you dont use DIMIX in your rule calculation or dont have a alias rule on your }ElementAttribute Cube then the process works fine as normal in 2.0.9.11  



    ------------------------------
    Herman Moller
    ------------------------------



  • 10.  RE: 2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

    Posted Mon February 06, 2023 07:11 PM
    Hi Herman,

    I have found that the issues you described are very interesting. I may not have a solution for you, but I wonder if you could convert the alias rule to a TI process. If the aliases are fairly static or they are updated when a dimension-update process runs, you may be able to use a TI process instead. 

    Thanks,
    Kong

    ------------------------------
    Kong Intrasinghathong
    Master Consultant
    QueBIT Consulting

    Analyze. Plan. Achieve.
    https://quebit.com
    ------------------------------



  • 11.  RE: 2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

    Posted Tue February 07, 2023 03:30 AM
    Hello Kong,

    Thanks for the suggestion and good way to solve the problem. 

    I meant to update to the ticket to add a step.

    A) Add Cube Dependancy
    B) Have a alias rule on the }ElementAttribute Cube

    C) Have a DIMIX rule on in a calculation
    D) Retrieve that calculation in a process with a CellgetN

    Then the process runs really slowly.

    In the past the issue was the sending of data in my TI Process Cellputn - That has now been fixed in 2.0.9.15 IF2 but now it seems the issue in cube dependancy is in the Cellgetn.


    ------------------------------
    Herman Moller
    ------------------------------



  • 12.  RE: 2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly

    Posted Thu February 09, 2023 09:51 AM

    Hello, 

    IBM Development have come back :

    "The status of the APAR is now opened (just updated yesterday), indicating that development has accepted this as a defect.  Next step would be to await a fix. "



    ------------------------------
    Herman Moller
    ------------------------------



  • 13.  RE: 2.0.9.15 issue : ATTRS rules in }ElementAttribute cube causes a TI to load data slowly