Cognos Controller

 View Only
Expand all | Collapse all

CA 11.2.1 integration with Cognos Controller 10.4.1 IF12 problem – error in the script pdf.viewer.js

  • 1.  CA 11.2.1 integration with Cognos Controller 10.4.1 IF12 problem – error in the script pdf.viewer.js

    Posted Wed December 15, 2021 04:25 AM

    Simple report made in w CA 11.2.1 and Run as PDF – works O.K.

    IBM Cognos Controller Standard Report (using controller.zip - "Standard Reports" Framework Manager model package that is imported into CA 11.2.1) – works, but "Script Error" message appears when you open the report. Then, when PDF is selected as the preview format, the PDF viewer displays a blank report.

    Any advice to solve the problem appreciated 😊

    CA_11_2_Simple_report_PDF

    CCR_10_4_1_CA_11_2_Standard_report_PDF_ERROR_1

    CCR_10_4_1_CA_11_2_Standard_report_PDF_ERROR_2


    ------------------------------
    Adam Kucharski
    ------------------------------


  • 2.  RE: CA 11.2.1 integration with Cognos Controller 10.4.1 IF12 problem – error in the script pdf.viewer.js

    Posted Thu February 17, 2022 04:29 PM
    Currently, there is no built-in connector for IBM Cognos Controller. I haven't found any third-party connector that could support it. You could try the approaches for Cognos TM1 or search for custom connectors. NordVpn

    ------------------------------
    Deepak Sharma
    ------------------------------



  • 3.  RE: CA 11.2.1 integration with Cognos Controller 10.4.1 IF12 problem – error in the script pdf.viewer.js

    Posted Fri February 18, 2022 04:08 AM
    Hi Adam,

    ~~~~~~~~~~~~~~~~
    (1) Script error
    ~~~~~~~~~~~~~~~~
    I have seen that "An error has occurred in the script on this page" error many times before.

    There are several known causes. See here for all the ones that I know about: https://www.ibm.com/support/pages/troubleshooting-script-error-error-has-occurred-script-page-when-trying-run-standard-report

    In my experience, it's most likely caused/fixed by this: https://www.ibm.com/support/pages/error-reportdispatcherentry-undefined-when-running-standard-reports
    - Therefore the fix is normally to modify the Internet Explorer setting 'Check for newer versions of stored pages' from the default ('Automatically') to 'Every time I visit the webpage'

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    (2) PDF not displaying (grey / white / blank)
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Again, I've seen this sort of thing before. Again there are several known causes.
    - See here: for one potential cause: https://www.ibm.com/support/pages/changing-standard-report-output-pdf-causes-whiteblank-screen-if-closed-adobe-reader-screen-earlier 

    Typically the cause/solution is related to the Adobe Reader client settings.
    - You can try changing whether the PDF file renders inside the little Cognos Viewer page (which can often cause problems) or if it renders inside Adobe Reader client. In other words, change from displaying in 'web' viewer or display in local client (normally better)
    - This is configured inside Adobe Reader. Different versions of Adobe Reader hide that setting in different places (it's a pain!)

    As a workaround, you can configure Controller to display it in its own PDF renderer (by enabling "useInternalPdfViewer"). See here: https://www.ibm.com/support/pages/how-enable-local-pdf-rendering-when-running-standard-reports-enabling-pdfviewer-using-parameter-useinternalpdfviewer

    Good luck!
    -Richard.

    ------------------------------
    Richard Collins
    ------------------------------