WebSphere Application Server & Liberty

Expand all | Collapse all

Websphere is configured with Eclipse 2021-03

  • 1.  Websphere is configured with Eclipse 2021-03

    Posted Thu April 29, 2021 09:13 AM
    I'm trying to setup WAS9.0 in Eclipse 2021-03 and getting exceptions as below. I also updated eclipse.ini file to IBM Java location as

    -vm C:/IBM/WebSphere/AppServer/java/8.0/bin/javaw.exe

    Still I'm getting error as:
    Secure servers are only supported with IBM JRE 6.0, 7.0 or 8.0. Use the IBM JRE from the product installation image



    ------------------------------
    sharat mandava
    ------------------------------


  • 2.  RE: Websphere is configured with Eclipse 2021-03

    Posted Fri April 30, 2021 05:19 AM
    Hi, there is no need to setup eclipse with the embedded WebSphere JRE.  If you downloaded the WebSphere development tools from the marketplace, then added a server, it should be enough.  If this did not work, please detail the steps you took.

    Brian

    ------------------------------
    Brian S Paskin
    Sr. WebSphere, Liberty and MQ Architecture
    Cloud Automation
    IBM Expert Labs
    ------------------------------



  • 3.  RE: Websphere is configured with Eclipse 2021-03

    Posted Fri April 30, 2021 08:51 AM
      |   view attached

    Hi Brian, Thanks for your reply. Yes, I tried this one also and didn't work through. Please find the document as attached to I follow the steps. 

    Thanks & Regards,

    Sharat Mandava



    ------------------------------
    sharat mandava
    ------------------------------

    Attachment(s)



  • 4.  RE: Websphere is configured with Eclipse 2021-03

    Posted Fri April 30, 2021 09:20 AM
    Hi Sharat,

    Did you update your Eclipse IDE from an older level to 2021-03?  Or, you were starting from scratch?

    WDT for WAS v9.x [1] doesn't support Eclipse IDE later than 2020-06 at the moment.

    If you are working with Liberty, Liberty Developer Tools [2] does support Eclipse IDE 2020-09 or later.  It will prereq Java 11 given the change in the Java prereq level in Eclipse IDE starting with the 2020-09 release.

    Thank you.


    [1] https://marketplace.eclipse.org/content/ibm-websphere-application-server-v9x-developer-tools
    [2] https://marketplace.eclipse.org/content/ibm-liberty-developer-tools

    ------------------------------
    Yee-Kang Chang
    IBM Canada
    ------------------------------



  • 5.  RE: Websphere is configured with Eclipse 2021-03

    Posted Fri April 30, 2021 09:18 AM
    Eclipse 2021-03 does not support running on Java SE 8. As a result the WebSphere Developer Tools for WebSphere traditional only works on Eclipse versions up to (and including) 2020-06.

    ------------------------------
    Alasdair Nottingham
    ------------------------------



  • 6.  RE: Websphere is configured with Eclipse 2021-03

    Posted Fri April 30, 2021 09:49 AM
    Earlier I tried with Eclipse 2019-06 & 2020-06 both versions and had same issue as earlier attachment. So, now I' m tried with 2021-03. Please, suggest me which is the best IDE to support WAS 9. Other than Eclipse, Is there any RAD version supports WAS9 by any chance?

    Thanks & Regards,
    Sharat Mandava

    ------------------------------
    sharat mandava
    ------------------------------



  • 7.  RE: Websphere is configured with Eclipse 2021-03

    Posted Tue May 04, 2021 12:58 PM

    Now, I'm trying with 2020-06 and giving same error as attached earlier document. Still I can't configure WAS9 with this eclipse version. Please, let me know for next steps.

    Thanks & Regards
    Sharat Mandava

    ------------------------------
    sharat mandava
    ------------------------------



  • 8.  RE: Websphere is configured with Eclipse 2021-03

    Posted Tue May 04, 2021 03:34 PM
    Edited by Yee-Kang Chang Tue May 04, 2021 03:35 PM
    Can you reinstall WDT for WAS v9.x with a clean 2020-06?

    There was an issue with the update sites.  WDT for WAS v9.x does support and should work with 2020-06.

    RAD 9.6.x, which should be the latest release, supports WAS v9.

    Thank you.

    ------------------------------
    Yee-Kang Chang
    IBM Canada
    ------------------------------



  • 9.  RE: Websphere is configured with Eclipse 2021-03

    Posted Tue May 04, 2021 05:39 PM
    Yes, I uninstalled WDT from 2020-06 and re-installed from Eclipse marketplace and tried it, Still I'm getting same exception. 

    Thanks

    ------------------------------
    sharat mandava
    ------------------------------



  • 10.  RE: Websphere is configured with Eclipse 2021-03

    Posted Wed May 05, 2021 06:04 AM
    It works for us so we need to look into it further.  Our team will reach out to you directly about this, Sharat.

    ------------------------------
    Yee-Kang Chang
    IBM Canada
    ------------------------------



  • 11.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 06, 2021 01:40 PM
    How soon your team could contact me? Please, send me meeting invitation or call me for the following details.

    sharatmandava@hotmail.com
    +1-313-320-5226

    Thanks

    ------------------------------
    sharat mandava
    ------------------------------



  • 12.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 06, 2021 02:03 PM
    Edited by Yee-Kang Chang Thu May 06, 2021 02:03 PM
    We did reach out via the community platform.  Looks like that might not have gotten through.

    You will hear from us soon.  Thank you.

    ------------------------------
    Yee-Kang Chang
    IBM Canada
    ------------------------------



  • 13.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 06, 2021 02:37 PM
    Hi,

    I did send a private reply but I am thinking it didn't get through. Thank you for your email contact details, I have emailed you  my reply. I will be working with you trying to get this resolved as fast as we can.

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 14.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 06, 2021 08:08 PM
      |   view attached
    Hello Philip,
    Thanks reaching out to me. Yes, I uninstalled all WebSphere related plugins from eclipse and installed only WebSphere 9.0 from the following WDT plugin

    http://public.dhe.ibm.com/ibmdl/export/pub/software/websphere/wasdev/updates/wdt/2020-03_comp/

    Also, find all WDT full names as attached doc. This time I'm able to select profile and during server start getting same exception as earlier. I have attached all screens in the document as attached.

    Thanks & Regards

    ------------------------------
    sharat mandava
    ------------------------------

    Attachment(s)



  • 15.  RE: Websphere is configured with Eclipse 2021-03

    Posted Fri May 07, 2021 04:31 AM
    Thank you for trying that out, it does look like you have the right version installed. I will try and reproduce that locally following your steps and see what I can find out...

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 16.  RE: Websphere is configured with Eclipse 2021-03

    Posted Fri May 07, 2021 09:26 AM
    Hi Sharat,

    I tried following the steps that you listed but it still works for me. However my system is using Java 8 as the system VM, which I believe is the VM eclipse picks up when it starts. As an experiment I tried telling eclipse to use Java 11 and I then got a warning similar to the one you originally mentioned. So could you try either changing your system VM to a Java 8 one or add this to your eclipse.ini file

    -vm
    <PATH_TO_JAVA8_BIN_DIR> 

    E.g. for me on windows it was 

    -vm
    C:\JDKs\JDK11\bin

    Note that -vm and the actual path must be on separate lines and that the -vm flag must be before any -vmargs in the eclipse.ini and after things like -product and --launcher args (see https://wiki.eclipse.org/Eclipse.ini for more info)

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 17.  RE: Websphere is configured with Eclipse 2021-03

    Posted Fri May 07, 2021 01:54 PM
    Hi Philip,

    Yes, I do have both Java 8 & Java 11 in my system. But, currently using Java 8 and set as JAVA_HOME.
    Also, as you mentioned I'm using currently in eclipse.ini file as

    -vm
    C:\Java\JDK8-64\bin\javaw.exe
    -vmargs
    -Dosgi.requiredJavaVersion=1.8
    -Xms40m
    -Xmx512m 

    Still there is an issue with WAS9 configuration.

    Thanks & Regards

    ------------------------------
    sharat mandava
    ------------------------------



  • 18.  RE: Websphere is configured with Eclipse 2021-03

    Posted Mon May 10, 2021 10:15 AM
    Hi,

    Thanks for trying that, I had hoped that would do the trick :(

    While digging more I also found out that if you have a JRE directory under your eclipse directory it will use that JRE in preference to the one specified in eclipse.ini, could you tell me if you have a JRE there (eclipse/jre). If so could you (re)move that directory. 

    If you don't, and for some reason if it can't find the java you specified in the eclipse.ini it will then search your path (it doesn't look at JAVA_HOME environment variable), so could you ensure that the Java 8 appears first (or that only java 8) in your path?


    ------------------------------
    Philip Nickoll
    ------------------------------



  • 19.  RE: Websphere is configured with Eclipse 2021-03

    Posted Wed May 12, 2021 10:12 AM
    Edited by sharat mandava Wed May 12, 2021 10:14 AM
    Hi Philip,

    I don't see any JRE directory in eclipse location as below.






    ------------------------------
    sharat mandava
    ------------------------------



  • 20.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 13, 2021 09:35 AM
    Hi Sharat,

    Thanks for checking that,

    Would you be able to run this little java app in your eclipse? I am wondering if our parsing of the Java version is wrong somehow so would like to know what you get when you run the following.

    public class Props {
       public static void main (String [] args) {
          System.out.println(System.getProperty("java.version"));
          System.out.println(System.getProperty("java.vendor"));
       }
    }

    Thanks in advance, I appreciate your help in providing this diagnostic information.

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 21.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 13, 2021 10:34 AM
    Output

    Picked up _JAVA_OPTIONS: -Duser.home=C:\Users\k1sbm01
    1.8.0_281
    Oracle Corporation

    ------------------------------
    sharat mandava
    ------------------------------



  • 22.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 13, 2021 12:16 PM
    Thanks Sharat,

    Can you try using an IBM JRE, since using a secure server I believe you have to use an IBM JRE, could you point at the one that shipped with WebSphere Application Server instead of the Oracle one?

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 23.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 13, 2021 12:32 PM
    As part of original issue when I started this discussion, it was configured like that and I changed to Java8 after couple of discussions. I'm not sure, how this will impact? Anyway, I'll try it again and let you know.

    original message as :

    In eclipse.ini
    -vm C:/IBM/WebSphere/AppServer/java/8.0/bin/javaw.exe

    Still I'm getting error as:
    Secure servers are only supported with IBM JRE 6.0, 7.0 or 8.0. Use the IBM JRE from the product installation image

    ------------------------------
    sharat mandava
    ------------------------------



  • 24.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 13, 2021 01:02 PM
    Thanks Sharat,

    Also please ensure it appears as

    -vm
    C:/IBM/WebSphere/AppServer/java/8.0/bin/javaw.exe

    in eclipse.ini (over two lines instead of all on one line as I think it will use the first one it finds in the o/s path if specified on one line)

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 25.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 13, 2021 01:03 PM
    You can also run that little app snippet from before to confirm which JRE it's picking up.

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 26.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 13, 2021 01:14 PM
    Also Eclipse 2021-03 requires Java 11 (and won't start up without it), so I suspect from the original post Eclipse was not picking up the Java 8 JVM (maybe due to the -vm being on one line or multiple -vm options in the ini file (I believe 2021-03 by default specifies a -vm flag already that points to a JRE 11).

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 27.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 13, 2021 01:39 PM
    Hello Philip,

    Yes, that's right and I have learned as part of initial discussion already. Currently I'm using 2020-06 eclipse version and which requires Java 8 and used IBM JRE in eclipse.ini file and also set JAVA_HOME as IBM JRE location.
    Still I'm unable to configure this.

    Current Output after setup IBM JRE for the above snippet

    1.8.0_261
    IBM Corporation






    ------------------------------
    sharat mandava
    ------------------------------



  • 28.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 13, 2021 01:49 PM
    Thanks for that, from that last config was it exactly the same error as per the screenshot in your last doc? There are various very slightly different messages that get displayed depending on which check notices the problem so could you grab another screenshot? I can then check to see which check(s) are failing (the previous screenshot implied it was not an IBM JRE so I suspect the message you see maybe ever so slightly different on that attempt)​

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 29.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 13, 2021 03:52 PM
      |   view attached
    Hello Philip,
    Again I tried from scratch and captured all screens in a order. Please, check the document as attached and let me know for next steps.

    Thanks

    ------------------------------
    sharat mandava
    ------------------------------

    Attachment(s)



  • 30.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 13, 2021 05:04 PM
    Sharat,

    Thank you very much for the diagnostic information again, it is very helpful. It looks like we have got past the first problem but there is another issue, that on the surface looks Java version related as well. I will dig into this....

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 31.  RE: Websphere is configured with Eclipse 2021-03

    Posted Thu May 13, 2021 05:59 PM
    Edited by Philip Nickoll Thu May 13, 2021 07:27 PM
    Hi Sharat,

    Firstly I think your Java levels in eclipse are right and that's all configured correctly, so we don't see the Java level warnings now.

    Would it be possible to attach the screenshot for the section in your doc that says:

    After installed successfully Eclipse restarted. Then I captured all WDT full names as follows:

    Unfortunately the font is a little small and I am unable to read it and zooming in it goes blurry. However, it looks to me like I am seeing some entries that say have v20210415_1349 in the name, which is the wrong version (that is new new Java 11 version which we shipped for Liberty Developer Tools and that, for a couple of days, the WebSphere v9 tools was accidently pointing at - and is a possible explanation into how you got those plugins). When I install WebSphere v9 tools all my IBM jars show the version 20200826_1754. I also see the missing panels that you don't see and can proceeded without the Java level warnings. Somehow, and I don't know how (yet), it looks like you have ended up with a mixed version of IBM tools.

    I also installed from

    http://public.dhe.ibm.com/ibmdl/export/pub/software/websphere/wasdev/updates/wdt/2020-03_comp/ and I checked the assets there appear to be the right versions so the update site appears to be correct.

    You mentioned that you uninstalled WebSphere Plugins, I wonder if there are other IBM plugins (Liberty ones?) that were still installed (they share some plugins with WebSphere Application Server).

    I think it might be easier and cleaner to go from a fresh eclipse install though rather than uninstalling the plugins though as I fear your eclipse plugins directory is a little mixed up.



    ------------------------------
    Philip Nickoll
    ------------------------------



  • 32.  RE: Websphere is configured with Eclipse 2021-03

    Posted Fri May 14, 2021 11:48 AM
    Hi Philip,

    After re-installed eclipse 2020-06 and configured IBM JRE location in eclipse.ini file and used WDT plugin http://public.dhe.ibm.com/ibmdl/export/pub/software/websphere/wasdev/updates/wdt/2020-03_comp/ to install WAS 9.0
    Finally I'm able to configure WAS9 with the right plugin this time.

    Thanks for your inputs...

    ------------------------------
    sharat mandava
    ------------------------------



  • 33.  RE: Websphere is configured with Eclipse 2021-03

    Posted 21 days ago

    Hi Sharat,

    Any luck with the new Eclipse 2021-06?

    Or do we still have to live with the older version of Eclipse?



    ------------------------------
    Amgad Hanafy
    ------------------------------



  • 34.  RE: Websphere is configured with Eclipse 2021-03

    Posted 21 days ago
    If you are asking with regards to using WAS 9.0 that Sharat was using before then you will need to use Eclipse 2020-06.

    ------------------------------
    Philip Nickoll
    ------------------------------