WebSphere Application Server & Liberty

Expand all | Collapse all

Websphere is configured with Eclipse 2021-03

  • 1.  Websphere is configured with Eclipse 2021-03

    Posted 11 days ago
    I'm trying to setup WAS9.0 in Eclipse 2021-03 and getting exceptions as below. I also updated eclipse.ini file to IBM Java location as

    -vm C:/IBM/WebSphere/AppServer/java/8.0/bin/javaw.exe

    Still I'm getting error as:
    Secure servers are only supported with IBM JRE 6.0, 7.0 or 8.0. Use the IBM JRE from the product installation image



    ------------------------------
    sharat mandava
    ------------------------------


  • 2.  RE: Websphere is configured with Eclipse 2021-03

    Posted 10 days ago
    Hi, there is no need to setup eclipse with the embedded WebSphere JRE.  If you downloaded the WebSphere development tools from the marketplace, then added a server, it should be enough.  If this did not work, please detail the steps you took.

    Brian

    ------------------------------
    Brian S Paskin
    Sr. WebSphere, Liberty and MQ Architecture
    Cloud Automation
    IBM Expert Labs
    ------------------------------



  • 3.  RE: Websphere is configured with Eclipse 2021-03

    Posted 10 days ago
      |   view attached

    Hi Brian, Thanks for your reply. Yes, I tried this one also and didn't work through. Please find the document as attached to I follow the steps. 

    Thanks & Regards,

    Sharat Mandava



    ------------------------------
    sharat mandava
    ------------------------------

    Attachment(s)



  • 4.  RE: Websphere is configured with Eclipse 2021-03

    Posted 10 days ago
    Hi Sharat,

    Did you update your Eclipse IDE from an older level to 2021-03?  Or, you were starting from scratch?

    WDT for WAS v9.x [1] doesn't support Eclipse IDE later than 2020-06 at the moment.

    If you are working with Liberty, Liberty Developer Tools [2] does support Eclipse IDE 2020-09 or later.  It will prereq Java 11 given the change in the Java prereq level in Eclipse IDE starting with the 2020-09 release.

    Thank you.


    [1] https://marketplace.eclipse.org/content/ibm-websphere-application-server-v9x-developer-tools
    [2] https://marketplace.eclipse.org/content/ibm-liberty-developer-tools

    ------------------------------
    Yee-Kang Chang
    IBM Canada
    ------------------------------



  • 5.  RE: Websphere is configured with Eclipse 2021-03

    Posted 10 days ago
    Eclipse 2021-03 does not support running on Java SE 8. As a result the WebSphere Developer Tools for WebSphere traditional only works on Eclipse versions up to (and including) 2020-06.

    ------------------------------
    Alasdair Nottingham
    ------------------------------



  • 6.  RE: Websphere is configured with Eclipse 2021-03

    Posted 10 days ago
    Earlier I tried with Eclipse 2019-06 & 2020-06 both versions and had same issue as earlier attachment. So, now I' m tried with 2021-03. Please, suggest me which is the best IDE to support WAS 9. Other than Eclipse, Is there any RAD version supports WAS9 by any chance?

    Thanks & Regards,
    Sharat Mandava

    ------------------------------
    sharat mandava
    ------------------------------



  • 7.  RE: Websphere is configured with Eclipse 2021-03

    Posted 6 days ago

    Now, I'm trying with 2020-06 and giving same error as attached earlier document. Still I can't configure WAS9 with this eclipse version. Please, let me know for next steps.

    Thanks & Regards
    Sharat Mandava

    ------------------------------
    sharat mandava
    ------------------------------



  • 8.  RE: Websphere is configured with Eclipse 2021-03

    Posted 6 days ago
    Edited by Yee-Kang Chang 6 days ago
    Can you reinstall WDT for WAS v9.x with a clean 2020-06?

    There was an issue with the update sites.  WDT for WAS v9.x does support and should work with 2020-06.

    RAD 9.6.x, which should be the latest release, supports WAS v9.

    Thank you.

    ------------------------------
    Yee-Kang Chang
    IBM Canada
    ------------------------------



  • 9.  RE: Websphere is configured with Eclipse 2021-03

    Posted 6 days ago
    Yes, I uninstalled WDT from 2020-06 and re-installed from Eclipse marketplace and tried it, Still I'm getting same exception. 

    Thanks

    ------------------------------
    sharat mandava
    ------------------------------



  • 10.  RE: Websphere is configured with Eclipse 2021-03

    Posted 5 days ago
    It works for us so we need to look into it further.  Our team will reach out to you directly about this, Sharat.

    ------------------------------
    Yee-Kang Chang
    IBM Canada
    ------------------------------



  • 11.  RE: Websphere is configured with Eclipse 2021-03

    Posted 4 days ago
    How soon your team could contact me? Please, send me meeting invitation or call me for the following details.

    sharatmandava@hotmail.com
    +1-313-320-5226

    Thanks

    ------------------------------
    sharat mandava
    ------------------------------



  • 12.  RE: Websphere is configured with Eclipse 2021-03

    Posted 4 days ago
    Edited by Yee-Kang Chang 4 days ago
    We did reach out via the community platform.  Looks like that might not have gotten through.

    You will hear from us soon.  Thank you.

    ------------------------------
    Yee-Kang Chang
    IBM Canada
    ------------------------------



  • 13.  RE: Websphere is configured with Eclipse 2021-03

    Posted 4 days ago
    Hi,

    I did send a private reply but I am thinking it didn't get through. Thank you for your email contact details, I have emailed you  my reply. I will be working with you trying to get this resolved as fast as we can.

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 14.  RE: Websphere is configured with Eclipse 2021-03

    Posted 4 days ago
      |   view attached
    Hello Philip,
    Thanks reaching out to me. Yes, I uninstalled all WebSphere related plugins from eclipse and installed only WebSphere 9.0 from the following WDT plugin

    http://public.dhe.ibm.com/ibmdl/export/pub/software/websphere/wasdev/updates/wdt/2020-03_comp/

    Also, find all WDT full names as attached doc. This time I'm able to select profile and during server start getting same exception as earlier. I have attached all screens in the document as attached.

    Thanks & Regards

    ------------------------------
    sharat mandava
    ------------------------------

    Attachment(s)



  • 15.  RE: Websphere is configured with Eclipse 2021-03

    Posted 3 days ago
    Thank you for trying that out, it does look like you have the right version installed. I will try and reproduce that locally following your steps and see what I can find out...

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 16.  RE: Websphere is configured with Eclipse 2021-03

    Posted 3 days ago
    Hi Sharat,

    I tried following the steps that you listed but it still works for me. However my system is using Java 8 as the system VM, which I believe is the VM eclipse picks up when it starts. As an experiment I tried telling eclipse to use Java 11 and I then got a warning similar to the one you originally mentioned. So could you try either changing your system VM to a Java 8 one or add this to your eclipse.ini file

    -vm
    <PATH_TO_JAVA8_BIN_DIR> 

    E.g. for me on windows it was 

    -vm
    C:\JDKs\JDK11\bin

    Note that -vm and the actual path must be on separate lines and that the -vm flag must be before any -vmargs in the eclipse.ini and after things like -product and --launcher args (see https://wiki.eclipse.org/Eclipse.ini for more info)

    ------------------------------
    Philip Nickoll
    ------------------------------



  • 17.  RE: Websphere is configured with Eclipse 2021-03

    Posted 3 days ago
    Hi Philip,

    Yes, I do have both Java 8 & Java 11 in my system. But, currently using Java 8 and set as JAVA_HOME.
    Also, as you mentioned I'm using currently in eclipse.ini file as

    -vm
    C:\Java\JDK8-64\bin\javaw.exe
    -vmargs
    -Dosgi.requiredJavaVersion=1.8
    -Xms40m
    -Xmx512m 

    Still there is an issue with WAS9 configuration.

    Thanks & Regards

    ------------------------------
    sharat mandava
    ------------------------------



  • 18.  RE: Websphere is configured with Eclipse 2021-03

    Posted 10 hours ago
    Hi,

    Thanks for trying that, I had hoped that would do the trick :(

    While digging more I also found out that if you have a JRE directory under your eclipse directory it will use that JRE in preference to the one specified in eclipse.ini, could you tell me if you have a JRE there (eclipse/jre). If so could you (re)move that directory. 

    If you don't, and for some reason if it can't find the java you specified in the eclipse.ini it will then search your path (it doesn't look at JAVA_HOME environment variable), so could you ensure that the Java 8 appears first (or that only java 8) in your path?


    ------------------------------
    Philip Nickoll
    ------------------------------