B2B Integration

Expand all | Collapse all

Unrestricted Policy File

  • 1.  Unrestricted Policy File

    Posted Thu December 05, 2019 08:13 PM
    Hi, 
    I am trying to install v6.0.2, but it failed at the installation. I believe the reason for the failure is related to Unrestricted Policy File. Please let me know where I can find the file for v6.0.2. I have downloaded (unrestrictedpolicyfiles.zip) from IBM ,  but still received the below error. 

    com.sterlingcommerce.woodstock.install.module_loader.ServiceInstallException: InstallSI.ModuleLoader()->Failed while loading package: E:\SI\B2Bi\middleware\b_platform_afc_60170101.jarcom.sterlingcommerce.woodstock.install.module_loader.ServiceInstallException: InstallSI.ModuleLoader()->Failed while loading package: E:\SI\B2Bi\middleware\b_platform_afc_60170101.jar at com.sterlingcommerce.woodstock.install.InstallSI.MiddlewareModuleLoader(InstallSI.java:1929) at com.sterlingcommerce.woodstock.install.InstallSI.PerformInstall(InstallSI.java:997) at com.sterlingcommerce.woodstock.install.InstallSI.main(InstallSI.java:140) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:90) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55) at java.lang.reflect.Method.invoke(Method.java:508) at com.sterlingcommerce.woodstock.install.InstallSIBootstrapper.instanciateAndRun(InstallSIBootstrapper.java:376) at com.sterlingcommerce.woodstock.install.InstallSIBootstrapper.instanciateAndRun(InstallSIBootstrapper.java:380) at com.sterlingcommerce.woodstock.install.InstallSIBootstrapper.doIt(InstallSIBootstrapper.java:192) at com.sterlingcommerce.woodstock.install.InstallSIBootstrapper.main(InstallSIBootstrapper.java:80)Caused by: java.lang.Exception: java.lang.reflect.InvocationTargetException


    When I searched for error, it pointed out the Policy file. 

    It will be very helpful for me, if anyone shared the policy file for B2Bi v6.0.2


    Thanks
    Kiran

    ------------------------------
    Kiran Veluvolu
    ------------------------------


  • 2.  RE: Unrestricted Policy File

    Posted Fri December 06, 2019 02:22 AM

    Hi Kiran,

    I hope you are using the right IBM JDK version? Could you please confirm the java version.

    Regards,

    Girish



    ------------------------------
    Girish Venkatesh
    ------------------------------



  • 3.  RE: Unrestricted Policy File

    Posted Fri January 10, 2020 09:03 AM

    there is a chance that this is actually only a follow up issue from some other failures.
    Have you checked the complete install log in IIM data location?

    Which JDK do you use ?

    regards,
    Guido



    ------------------------------
    Guido Bahlmann [Syncsort]
    ------------------------------