IBM i Global

 View Only
Expand all | Collapse all

IWS service creation via QSHELL (specifically setting the 'Secure transport required' property)

  • 1.  IWS service creation via QSHELL (specifically setting the 'Secure transport required' property)

    Posted Tue November 22, 2022 09:12 AM
    Hello
    firstly, apologies if this is not correct place to post this query - i am still trying to find my way around the support forum

    I have created a number of API endpoints using the Web Administration for i tools. All of my services use authentication and secure transport. The problem arises when i attempt to use QSHELL to deploy any of these services to another web server via script - the services are created, but i can not find a way to ensure that SSL is true for the new service, it always defaults to false.

    I am using getWebServiceProperties.sh script to retrieve the properties of the service i want to replicate, which shows that SSL is true. However after using installWebService.sh to create the same service on a different webserver (or even just creating a renamed version of the service on the same webserver), and specifying the correct *pcml file location which contains the underlying properties which include SSL=true, the new service is always created with SSL=false: (i have removed the User ID from below screenshot).



    when i view the properties of the original service in qshell, i can see that SSL is definitely true:

    However, any new service i create via installWebService.sh, and specifying the pcml location, will always be created with SSL=false. I have trawled through the IWS documentation (https://public.dhe.ibm.com/systems/support/i/iws/systems_i_software_iws_pdf_WebServicesServer_new.pdf) and cannot find any other parameter on the installWebService.sh that would enable me to specifically set SSL on the new web service. I've also been unable to find any way of changing the SSL property on a service via the setWebServiceProperties.sh command. This is obviously not ideal as while i can use QSHELL to script the creation of all other aspects of these web services, if i cannot set SSL to true, it means i will need to manually amend the security properties of each new service via 'Manage deployed services' section of Web Administration for i page.

    I can't believe that there is no way to set the SSL property of a web service set to true via a command - any help would be greatly appreciated!!

    Thanks, Neil

    ------------------------------
    neil duncan
    ------------------------------


  • 2.  RE: IWS service creation via QSHELL (specifically setting the 'Secure transport required' property)

    Posted Wed November 23, 2022 05:24 PM
    Edited by Nadir K Amra Wed November 23, 2022 05:27 PM
    Hi Neil,

    I think you need to update your IWS PTF.   The latest IWS PTFs[1].  I just tried it and it propagated.  One thing to note is that when you use the installwebservice.sh script you should pass in the -propertiesfile AND -markupLanguage parameters.  For example:

    installwebservice.sh -server TEST -propertiesfile /tmp/QIWSSAMPLEhttpsOnly.properties
                 -markuplanguage /tmp/QIWSSAMPLEhttpsOnly.xml

    Note that I tried this using the properties file and xml file returned by getconfigurationfile.sh.

    You may also need web admin GUI PTFs as well.   Latest are:
    SI81724 V7R5M0
    SI81725 V7R4M0
    SI81726 V7R3M0


    [1]  https://www.ibm.com/support/pages/node/1138612

    ------------------------------
    Nadir K Amra
    ------------------------------



  • 3.  RE: IWS service creation via QSHELL (specifically setting the 'Secure transport required' property)

    Posted Wed November 23, 2022 05:30 PM
    Forgot to mention that in near future, setWebServiceProperties.sh c will be updated so that you can use a property file to change properties of a service.

    ------------------------------
    Nadir K Amra
    ------------------------------



  • 4.  RE: IWS service creation via QSHELL (specifically setting the 'Secure transport required' property)

    Posted Fri November 25, 2022 06:47 AM
    Hi Nadir thanks for the suggestions, i did think we must be missing something! - we are going to update the PTF's next week, hopefully this will resolve the issue, 

    Neil

    ------------------------------
    neil duncan
    ------------------------------