AIX

 View Only
  • 1.  AIX Support for NFS 4.1

    Posted Mon August 16, 2021 12:48 PM
    Does AIX support NFS 4.1? This is from a client perspective.
    I'm connecting to an NFS server which requires NFS 4.1.
    When attempting to connect from AIX I receive a generic error "vmount: invalid argument" which I suspect is due to a mismatch in NFS version.
    I am able to connect via a Linux host using NFS 4.1 so I'm certain the NFS server is up and properly configured and reachable.

    Thanks!

    ------------------------------
    Dan Jones
    ------------------------------


  • 2.  RE: AIX Support for NFS 4.1

    InnerCircle
    Posted Mon August 16, 2021 04:59 PM
    Edited by Matt Geisler Wed September 01, 2021 02:52 PM
    Should be supported -> https://www.ibm.com/support/pages/does-aix-support-nfsv41

    instructions on how to configure client bottom half of page... -> https://www.ibm.com/support/pages/ibm-aix-how-setup-nfsv4-mount-clinet-and-server

    ------------------------------
    Matt
    ------------------------------



  • 3.  RE: AIX Support for NFS 4.1

    Posted Mon August 16, 2021 05:16 PM
    That's encouraging.
    Is there a way to determine the version of the client that's currently installed?
    I'm running 7200-03-02-1846.

    Also, I couldn't find a way to specify to use 4.1 versus 4. The vers option takes an integer and there is no minorversion option like on Linux.

    ------------------------------
    Dan Jones
    ------------------------------