AIX

Expand all | Collapse all

php upgrade

  • 1.  php upgrade

    Posted Wed January 20, 2021 09:08 AM
    Hello,

    I am trying to upgrade php version from 5.6.19 to 5.6.23.

    But I am facing the following issue
    [root:/tmp/php5:] rpm -Uvh *
    error: Failed dependencies:
           /opt/freeware/bin/perl is needed by automake-1.15.1-1.pp
    [root:/home/root:] rpm -qi perl
    package perl is not installed
    [root:/home/root:] which perl
    /usr/bin/perl

    In case of need ==>
    it is AIX 7.1
    [root:/home/root:] lslpp -L rpm.rte                                
     Fileset                      Level  State  Type  Description (Uninstaller)
     ----------------------------------------------------------------------------
     rpm.rte                  4.13.0.10    C     F    RPM Package Manager

    I am not very familiar with AIX, any help it would be much appreciated.
    Thank you in advance

    ------------------------------
    Lampros Chrysovergis
    ------------------------------


  • 2.  RE: php upgrade

    Posted Wed January 20, 2021 09:09 AM
    Please use AIX open source group for open source packages related issue and queries.
    Here is the link 
    https://community.ibm.com/community/user/power/communities/community-home/digestviewer?communitykey=10c1d831-47ee-4d92-a138-b03f7896f7c9&tab=digestviewer

    ------------------------------
    SANKET RATHI
    ------------------------------



  • 3.  RE: php upgrade

    Posted Wed January 20, 2021 09:14 AM
    From where did you obtained php rpm ?
    Looks like you do not have perl rpm but perl shipped by AIX.
    You may want to install perl rpm from same source from where you are getting php.

    ------------------------------
    SANKET RATHI
    ------------------------------



  • 4.  RE: php upgrade

    Posted Thu January 21, 2021 04:47 AM
    It's the typical error. Not your one, but the system's.
    It looks for Perl RPM but you have Perl LPP.
    You May try to find the PHP that looks for LPP or install the Perl RPM.

    ------------------------------
    Dmitry Mironov
    ------------------------------



  • 5.  RE: php upgrade

    Posted Fri January 22, 2021 08:27 AM
    Hello Dimitri, Sanket,

    I will contact with OS admin and try to work together.
    I hope it is that simple :)

    I really appreciated your fast replies,
    regards,
    Lampros

    ------------------------------
    Lampros Chrysovergis
    ------------------------------



  • 6.  RE: php upgrade

    Posted Thu January 28, 2021 09:58 AM
    Hello Dimitri, Sanket

    Now perl is installed and PHP was upgraded to 5.6.32 as well.

    root:/tmp/php5:] rpm -qi perl
    Name : perl
    Epoch : 1
    Version : 5.30.3
    Release : 1
    Architecture: ppc
    Install Date: Wed Jan 27 16:29:56 2021
    Group : Development/Languages
    Size : 110837513
    License : Artistic
    Signature : (none)
    Source RPM : perl-5.30.3-1.src.rpm
    Build Date : Tue Jul 28 21:00:49 2020
    Build Host : pokndd10.pok.stglabs.ibm.com
    Relocations : /opt/freeware
    URL : http://www.perl.com
    Summary : The Perl programming language.
    Description :

    root:/opt/freeware/sbin:] rpm -qf php-fpm
    php_64-fpm-5.6.32-1.ppc

    root:/opt/freeware/sbin:] rpm -aq | grep php
    php_64-fpm-5.6.32-1.ppc
    php_64-common-5.6.32-1.ppc
    php_64-cli-5.6.32-1.ppc
    root:/opt/freeware/sbin:] rpm -qf /opt/freeware/lib/libldap.a
    openldap-2.4.44-0.1.ppc
    root:/opt/freeware/sbin:] rpm -qa | grep -i -e ldap | sort
    openldap-2.4.44-0.1.ppc
    root:/opt/freeware/sbin:] rpm -q --whatrequires openldap
    php_64-fpm-5.6.32-1.ppc
    php_64-cli-5.6.32-1.ppc
    curl-7.72.0-1.ppc

    But still I have following error when I start PHP

    root:/opt/freeware/sbin:] php-fpm start
    Could not load program php-fpm:
    Dependent module /opt/IBM/ldap/V6.3/lib/libldap.a(libldap-2.4.so.2) could not be loaded.
    File /opt/IBM/ldap/V6.3/lib/libldap.a is not an
    archive or the file could not be read properly.
    System error: Exec format error

    Can you help How to resolve this?

    Regards
    Alwin

    ------------------------------
    Alwin Alex
    ------------------------------



  • 7.  RE: php upgrade

    Posted Thu January 28, 2021 09:58 AM
    Hello Dimitri, Sanket

    Now perl is installed and PHP was upgraded to 5.6.32 as well.

    root:/tmp/php5:] rpm -qi perl
    Name : perl
    Epoch : 1
    Version : 5.30.3
    Release : 1
    Architecture: ppc
    Install Date: Wed Jan 27 16:29:56 2021
    Group : Development/Languages
    Size : 110837513
    License : Artistic
    Signature : (none)
    Source RPM : perl-5.30.3-1.src.rpm
    Build Date : Tue Jul 28 21:00:49 2020
    Build Host : pokndd10.pok.stglabs.ibm.com
    Relocations : /opt/freeware
    URL : http://www.perl.com
    Summary : The Perl programming language.
    Description :

    root:/opt/freeware/sbin:] rpm -qf php-fpm
    php_64-fpm-5.6.32-1.ppc

    root:/opt/freeware/sbin:] rpm -aq | grep php
    php_64-fpm-5.6.32-1.ppc
    php_64-common-5.6.32-1.ppc
    php_64-cli-5.6.32-1.ppc
    root:/opt/freeware/sbin:] rpm -qf /opt/freeware/lib/libldap.a
    openldap-2.4.44-0.1.ppc
    root:/opt/freeware/sbin:] rpm -qa | grep -i -e ldap | sort
    openldap-2.4.44-0.1.ppc
    root:/opt/freeware/sbin:] rpm -q --whatrequires openldap
    php_64-fpm-5.6.32-1.ppc
    php_64-cli-5.6.32-1.ppc
    curl-7.72.0-1.ppc

    But still I have following error when I start PHP

    root:/opt/freeware/sbin:] php-fpm start
    Could not load program php-fpm:
    Dependent module /opt/IBM/ldap/V6.3/lib/libldap.a(libldap-2.4.so.2) could not be loaded.
    File /opt/IBM/ldap/V6.3/lib/libldap.a is not an
    archive or the file could not be read properly.
    System error: Exec format error

    Could you help to resolve the issue?

    Regards
    Alwin

    ------------------------------
    Alwin Alex
    ------------------------------



  • 8.  RE: php upgrade

    Posted Thu January 28, 2021 10:01 AM

    If you have not already done so, please resubmit your post to the Open Source topic space in the Power communty.

    https://community.ibm.com/community/user/power/communities/community-home?CommunityKey=10c1d831-47ee-4d92-a138-b03f7896f7c9



    ------------------------------
    Carl Burnett
    DE, Cognitive Systems Software Development
    IBM
    ------------------------------