Maximo

 View Only
  • 1.  Error using web service end point

    Posted Wed January 26, 2022 04:19 AM
    Edited by Manikanda Prabhu Alexander Wed January 26, 2022 04:19 AM
    Hi All

    Has anyone come across the below issue? I am trying to send an outbound message to an external system using webservice endpoint. It works fine in SoapUI but getting the below error in Maximo. I tried using both publish channel and invocation channel to trigger the message from Maximo. Please note that the external system will not send a response but the message gets processed when it was sent using SoapUI. Will that cause this error in Maximo?

    org.apache.axis2.AxisFault: The input stream for an incoming message is null. at psdi.iface.router.WebServiceHandler.invoke(WebServiceHandler.java:259)

    Thanks.

    ------------------------------
    Manikanda Prabhu Alexander
    ------------------------------


  • 2.  RE: Error using web service end point

    Posted Thu January 27, 2022 09:28 AM
    Edited by Steven Shull Thu January 27, 2022 09:37 AM
    Change the MEP property on the end point (Integration->End Points) to sendrobust. By default it's sendreceive which expects a response. If the system will not send a response, sendrobust should be utilized. 

    We document the allowed values here: https://www.ibm.com/docs/en/mam/7.6.1.2?topic=properties-web-service-handler-jax-ws

    ------------------------------
    Steven Shull
    ------------------------------



  • 3.  RE: Error using web service end point

    Posted Fri January 28, 2022 05:57 AM
    Hi Steve

    Thanks for the reply. It worked fine with 'sendrobust' except that I had to add a new system property to make it work as per the link below.

    https://www.ibm.com/support/pages/error-input-stream-incoming-message-null 

    Now I don't get any error message when the message is sent from Maximo but the message has still not been processed in the external system. This was the case without sendrobust change.

    Web Plugin has thrown exception. Exception Message = Object reference not set to an instance of an object.

    Do you think there is an issue with Maximo end point configuration considering the messages through SoapUI works fine? The logs from the external system have not been very helpful in troubleshooting.


    ------------------------------
    Manikanda Prabhu Alexander
    ------------------------------



  • 4.  RE: Error using web service end point

    Posted Fri January 28, 2022 09:01 AM
    I've never utilized these settings as every system I've sent to has provided a response. Is there a test endpoint you know of publicly that I can try to hit? That might be easier.

    I'd be careful following a technote based on Maximo 7.5. I'd open a support case to see the supported way to make this work. Looking at how we're handling sendrobust when utilizing JAXWS we're processing it the same as sendreceive  so that explains why it didn't work. I'm not familiar enough to understand if there's a reason why we can't support it in JAXWS. fireandforget does utilize different logic so would probably work but might not capture errors which would be a problem for most integrations. Support would be better able to answer or reach out to the team who would know the answer.

    ------------------------------
    Steven Shull
    ------------------------------



  • 5.  RE: Error using web service end point

    Posted Mon January 31, 2022 11:37 AM
    Hi

    I was able to make it work using HTTP handler instead of web service handler. The only change I did was to use SOAPAction header in HTTP handler whereas in Webservice handler there is a parameter to add SOAPAction. Not sure what made the difference, but it worked. Thanks for your inputs.

    ------------------------------
    Manikanda Prabhu Alexander
    ------------------------------