Db2 for z/OS - The AI Database

nested-group-icon.png

DB2

Expand all | Collapse all

.Net core 3.1 license-help-using-ibmdatadb2core-in-net-with-db2

  • 1.  .Net core 3.1 license-help-using-ibmdatadb2core-in-net-with-db2

    Posted 17 days ago
    Getting below error while connecting mainframe Db2 using .net core application. using latest nuget ibm.data.db2.core 3.1.0.200.
    Included the license db2consv_ee.lic into clidriver\license, still see this issue. any suggestion?

    DB2Exception: ERROR [42968] [IBM] SQL1598N An attempt to connect to the database server failed because of a licensing problem. SQLSTATE=42968

    ------------------------------
    Dhirendra Patil
    ------------------------------


  • 2.  RE: .Net core 3.1 license-help-using-ibmdatadb2core-in-net-with-db2

    Posted 14 days ago
    You might talk to your dba's about running the db2connectactivate command.

    https://www.ibm.com/support/knowledgecenter/SSEPGG_11.1.0/com.ibm.db2.luw.licensing.doc/doc/r0057377.html

    ------------------------------
    Nancy Boydstun
    ------------------------------



  • 3.  RE: .Net core 3.1 license-help-using-ibmdatadb2core-in-net-with-db2

    Posted 14 days ago

    This is really outside my expertise (I work on the z/OS side of the question), but there are several references to having an incorrect version of the license file.  Such as


    https://www.ibm.com/support/pages/sql1598n-error-connecting-mainframe-db2-ibm-data-server-driver-even-though-db2-connect-license-file-exists-license-directory-install-path




    ------------------------------
    JAMES CAMPBELL
    ------------------------------



  • 4.  RE: .Net core 3.1 license-help-using-ibmdatadb2core-in-net-with-db2

    Posted 13 days ago
    ​If you are trying to connect to Db2 z/OS on the mainframe, you are using the wrong license. You need to use db2consv_zs.lic.

    Documentation on the different license files can be found here:

    https://www.ibm.com/support/knowledgecenter/SSEPGG_11.1.0/com.ibm.db2.luw.qb.server.doc/doc/r0006748.html



    ------------------------------
    Will Smith
    ------------------------------



  • 5.  RE: .Net core 3.1 license-help-using-ibmdatadb2core-in-net-with-db2

    Posted 13 days ago
    hi 

    the 3.1.200  .Net core drivers are db2connect v11.5 , so a license for v11.5 is needed. 
    This can be applied by adding the license file in the project code, or by install the license on Db2 Z/os using db2connectactivate


    https://www.ibm.com/support/pages/sql1598n-error-connecting-mainframe-db2-ibm-data-server-driver-even-though-db2-connect-license-file-exists-license-directory-install-path

    ------------------------------
    Thomas Holm Sennels
    ------------------------------