Hi,
Anyone having already RHEL9 Golden image created for PowerVC?
I created my image VM ; VM itself works perfectly as such...But then when I create an Image out of that and try to deploy the image; the new VM always ends up in Emergency shell.
Most probably some issue with Multipath and / or LVM conf..
Tried already:
- set filtering on /etc/lvm/lvm.conf; but that seems to be deprecated on RHEL9
- Increased
SCSI INQUIRY timeout in kernel config via grubby
- Increased dev_loss_tmo value in multipath conf
>> no help
Console log below:
[ OK ] Finished Create Static Device Nodes in /dev.
Starting Rule-based Manage…for Device Events and Files...
[ 12.625258] synth uevent: /devices/vio: failed to send uevent
[ 12.625276] vio vio: uevent: failed to send synthetic uevent
[ 12.629013] synth uevent: /devices/vio/4000: failed to send uevent
[ 12.629023] vio 4000: uevent: failed to send synthetic uevent
[ 12.629073] synth uevent: /devices/vio/4001: failed to send uevent
[ 12.629079] vio 4001: uevent: failed to send synthetic uevent
[ 12.629112] synth uevent: /devices/vio/4002: failed to send uevent
[ 12.629118] vio 4002: uevent: failed to send synthetic uevent
[ 12.629148] synth uevent: /devices/vio/4004: failed to send uevent
[ 12.629154] vio 4004: uevent: failed to send synthetic uevent
[ OK ] Finished Coldplug All udev Devices.
Starting Wait for udev To …plete Device Initialization...
[ OK ] Started Rule-based Manager for Device Events and Files.
[ OK ] Finished Monitoring of LVM… dmeventd or progress polling.
Starting Load Kernel Module configfs...
Starting Load Kernel Module fuse...
[ OK ] Finished Load Kernel Module configfs.
[ OK ] Finished Load Kernel Module fuse.
[ 12.928513] pseries_rng: Registering IBM pSeries RNG driver
[ OK ] Finished Wait for udev To Complete Device Initialization.
Starting Device-Mapper Multipath Device Controller...
[ OK ] Started Device-Mapper Multipath Device Controller.
[ OK ] Reached target Preparation for Local File Systems.
Mounting /boot...
[ 13.748344] XFS (dm-2): Mounting V5 Filesystem
[ 14.085278] XFS (dm-2): Ending clean mount
[ OK ] Mounted /boot.
[ TIME ] Timed out waiting for device /dev/mapper/vgRoot-lvHome.
[DEPEND] Dependency failed for /home.
[DEPEND] Dependency failed for Local File Systems.
[DEPEND] Dependency failed for Mark… need to relabel after reboot.
[ TIME ] Timed out waiting for device /dev/mapper/vgRoot-lvVarTmp.
[DEPEND] Dependency failed for /var/tmp.
[ TIME ] Timed out waiting for device …/mapper/vgRoot-lvVarLogAudit.
[DEPEND] Dependency failed for /var/log/audit.
[ TIME ] Timed out waiting for device /dev/mapper/vgRoot-lvVar.
[DEPEND] Dependency failed for /var.
[DEPEND] Dependency failed for Reco… System Boot/Shutdown in UTMP.
[DEPEND] Dependency failed for Record Runlevel Change in UTMP.
[DEPEND] Dependency failed for /var/log.
[DEPEND] Dependency failed for Flus…Journal to Persistent Storage.
[DEPEND] Dependency failed for RPC Pipe File System.
[DEPEND] Dependency failed for rpc_pipefs.target.
[DEPEND] Dependency failed for RPC …ice for NFS client and server.
[DEPEND] Dependency failed for Load/Save Random Seed.
[ TIME ] Timed out waiting for device /dev/mapper/vgRoot-lvTmp.
[DEPEND] Dependency failed for /tmp.
[ TIME ] Timed out waiting for device /dev/mapper/vgRoot-lvSrv.
[DEPEND] Dependency failed for /srv.
[ TIME ] Timed out waiting for device /dev/mapper/vgRoot-lvOpt.
[DEPEND] Dependency failed for /opt.
[ OK ] Stopped Forward Password R…uests to Wall Directory Watch.
[ OK ] Reached target Timer Units.
[ OK ] Reached target NFS client services.
[ OK ] Reached target Login Prompts.
[ OK ] Reached target Cloud-init target.
[ OK ] Reached target Cloud-config availability.
[ OK ] Reached target Preparation for Network.
[ OK ] Reached target Network.
[ OK ] Reached target Network is Online.
[ OK ] Reached target Preparation for Remote File Systems.
[ OK ] Reached target Remote File Systems.
Starting Notify NFS peers of a restart...
[ OK ] Reached target User and Group Name Lookups.
[ OK ] Reached target Socket Units.
[ OK ] Started Emergency Shell.
[ OK ] Reached target Emergency Mode.
Starting Tell Plymouth To Write Out Runtime Data...
Starting Set Up Additional Binary Formats...
Starting Create Volatile Files and Directories...
Mounting Arbitrary Executable File Formats File System...
[ OK ] Started Notify NFS peers of a restart.
[ OK ] Finished Tell Plymouth To Write Out Runtime Data.
[ OK ] Mounted Arbitrary Executable File Formats File System.
[ OK ] Finished Set Up Additional Binary Formats.
[ OK ] Finished Create Volatile Files and Directories.
Starting Security Auditing Service...
Starting RPC Bind...
Starting Rebuild Journal Catalog...
[FAILED] Failed to start Security Auditing Service.
See 'systemctl status auditd.service' for details.
[ OK ] Finished Rebuild Journal Catalog.
[ OK ] Started RPC Bind.
Starting Update is Completed...
[ OK ] Finished Update is Completed.
You are in emergency mode. After logging in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" or "exit"
to boot into default mode.
Give root password for maintenance
(or press Control-D to continue):
------------------------------
Tommi Sihvo, Lead Service Architect
Tietoevry, Compute Services
email
tommi.sihvo@tietoevry.com mobile +358 (0)40 5180 Finland
------------------------------
#PowerVC