WebSphere Application Server & Liberty

  • 1.  JAX RS issue in websphere 8.5.5.11/FileNet 5.2.1.5 -ICN 2.0.3

    IBM Select
    Posted 15 days ago
    Hi All,
    I have cpe and icn deployed on WebSphere, when i load login page of cpe or ICN for both  i am getting 500- null pointer exception popup. in the logs "SRVE0060E: an exception was thrown by one of the service method of the servlet JAX RS servlet in application navigator" java.lang.nullpointerException with 500 code

    cpe Health& ping pages are loading.

    Thanks in advance
    Ram

    ------------------------------
    Ramu T
    ------------------------------


  • 2.  RE: JAX RS issue in websphere 8.5.5.11/FileNet 5.2.1.5 -ICN 2.0.3

    Posted 13 days ago
    Hi Ramu,

    Can you post the full stack trace including any caused-by clauses? Also, is this something new (like after an upgrade or something?) or has this alway been occurring? Any other information that you can provide would be helpful.  

    Thanks,
    Andy

    ------------------------------
    Andy McCright
    ------------------------------



  • 3.  RE: JAX RS issue in websphere 8.5.5.11/FileNet 5.2.1.5 -ICN 2.0.3

    IBM Select
    Posted 9 days ago
    Edited by Ramu T 9 days ago
    Hi Andy,

    earlier it was working, 3-4 teams are working on same websphere. In the middle it happened. please find the below screens sequence 1,2,3 &4.
    Thanks in advance.


    ------------------------------
    Ramu T
    ------------------------------



  • 4.  RE: JAX RS issue in websphere 8.5.5.11/FileNet 5.2.1.5 -ICN 2.0.3

    Posted 8 days ago
    This looks like https://www.ibm.com/support/pages/apar/PI27070

    The issue is that somewhere on your application classpath, you must have a JAX-RS implementation (like Jersey, RESTEasy, CXF, etc.). If you want to use that implementation, then you will need the referenced fix.  If you want to use the built-in Wink implementation, then I would recommend removing the one packaged with the application.

    HTH,
    Andy

    ------------------------------
    Andy McCright
    ------------------------------



  • 5.  RE: JAX RS issue in websphere 8.5.5.11/FileNet 5.2.1.5 -ICN 2.0.3

    IBM Select
    Posted 8 days ago
    Edited by Ramu T 5 days ago
    Thanks very much.
    we did not use any JAXRS implementations explicitly, using default websphere configs. but this happened in Dev only, PROD is working fine with same installation and configurations. how to find JAXRS 3rd party is running/configures/which version, so that i can compare PROD and Dev.
    I tried "com.ibm.websphere.jaxrs.server.DisableIBMJAXRSEngine" but no use.
    applications working fine(backend) using api's and all health pages only issue is login/gui page is giving 500/not loading.

    may i know how to use default Wink and path/how to remove the one packaged with the application. any wink JVM property/config?
    *navigator/jaxrs/logon  is coming when i hit in browser for PROD but not for DEV.
    ------------------------------
    Ramu T
    ------------------------------