IBM Security SOAR

Release of v42.0.2101 IBM Security SOAR Python Libraries to PyPi

By Shane Curtin posted Wed August 25, 2021 10:27 AM

  
We have released v42.0.2101 of our Python Libraries for IBM Security SOAR:

resilient

  • Added support for HTTP_PROXY, HTTPS_PROXY and NO_PROXY environmental variables. See the App Host Deployment Guide for details.
  • Add new 'User-Agent: soar-app-1.0' header for API calls to SOAR platform.
  • Bug fixes.

resilient-circuits

  • Added support for HTTP_PROXY, HTTPS_PROXY and NO_PROXY environmental variables. See the App Host Deployment Guide for details.
  • Enhancement to selftest to also check connection back to SOAR platform.
  • Added 'selftest_timeout' to app.config file. It sets the value in seconds for selftest to wait for a response from the SOAR platform.
  • Bug fixes.

resilient-sdk

  • codegen now generates a template for App's to be developed to run in a Python >= 3.6 environment.
  • Bug fixes.
  • Support for collecting incident types in codegen and extract. See the command line parameters -i and --incidenttype.

resilient-lib

  • Added support for HTTP_PROXY, HTTPS_PROXY and NO_PROXY environmental variables. See the App Host Deployment Guide for details.
  • Fix to OAuth2 to avoid infinite loop in some circumstances.

A Note on resilient-sdk changes:

  • We have made a change whereby codegen now only produces a template that is Python 3.6 compliant, however if you find yourself in the situation that does not allow you to use Python 3.6 and wish to still develop Apps for a Python 2.7 environment - in the App's setup.py file that is generated, remove the line:
  • python_requires='>=3.6'
  • and given your App has no other code dependencies on Python 3.6 it will still continue to work in a Python 2.7 environment
0 comments
15 views

Permalink