Hello Roberto:
In my work place we went thru the same migration scenario and we're now running on Microfocus.
You're correct that in DB2 LUW, the -904 has been transformed into different specific messages. There's still a chance to get SQL0904N on Db2 LUW. This could happen if you use NICKNAMEs mapped to DB2 for zOS tables.
Whenever any of these tables fall into a -904 (resource not available) condition on the DB2 for zOS side, this would generate an SQL0904N error message on the DB2 LUW nickname.
Hope this helps.
Ciao
Luis Enrique Valdez