View Only
  • 1.  AIX open source

    Posted Wed May 29, 2024 09:21 AM


    am trying to update libgcc getting the error as "libgcc <= 9.1.0 conflicts with libgcc8-8.3.0-7.ppc", I have tried to update libgcc8-8.3.0-7.ppc and

    libgcc10-10.3.0-6.aix7.1.ppc.rpm for both am getting the same error.

    I have libgcc versions of below there is no 9.1.0 in that still it conflicts 

    # rpm -qa|grep -i libgcc

    # ls -l|grep -i libgcc
    -rw-r--r--    1 pailan   tsadmin       14679 May 08 01:35 libgcc-10-2.aix7.1.ppc.rpm
    -rw-r--r--    1 pailan   tsadmin      806948 May 08 01:49 libgcc10-10.3.0-6.aix7.1.ppc.rpm
    -rw-r--r--    1 patrol   tcsgener     961782 May 29 02:39 libgcc6-6.3.0-2.aix7.1.ppc.rpm
    -rw-r--r--    1 patrol   tcsgener    1012538 May 29 03:13 libgcc7-7.2.0-2.aix7.1.ppc.rpm
    -rw-r--r--    1 patrol   tcsgener     999361 May 28 21:56 libgcc8-8.3.0-7.aix7.1.ppc.rpm

    # rpm -Uvh libgcc8-8.3.0-7.aix7.1.ppc.rpm
    error: Failed dependencies:
            libgcc <= 9.1.0 conflicts with libgcc8-8.3.0-7.ppc
    apdvadc11:/Devfmserver # rpm -Uvh libgcc10-10.3.0-6.aix7.1.ppc.rpm
    error: Failed dependencies:
            libgcc <= 9.1.0 conflicts with libgcc10-10.3.0-6.ppc

    Pls suggest 


  • 2.  RE: AIX open source

    Posted Wed May 29, 2024 11:46 AM

    GDC Group,

    Have you tried using dnf (alternative to yum) instead of rpm?

    From my experience, dnf/yum handle prereq/conflicts better than rpm. Normally, when installed, dnf looks in the AIX Toolbox repository for the RPM packages, which saves you having to manually download the RPMS.

    To update: dnf update <package name>

    To install: dnf install <package name>

    For your example above, you might try: dnf install libgcc10

    Abraham Alvarez