Power

 View Only
  • 1.  AIX fixed level can run on P10 E1080

    Posted 30 days ago

    Currently, I use AIX 7100-05-05-1939 because we are in process to procure E1080 so our application team do not want to upgrade AIX because they do not want to test their application many time so they want me to get new server first. So I want to make sure fixed level 1939 can run in Power8 compatibility mode on E1080 or not? I got this URL but I want to make sure it still valid and I can run E1080 with fixed level 1939.

    PowerPoint Presentation (ibm.com)



    ------------------------------
    kritsada ruayruengrung
    ------------------------------


  • 2.  RE: AIX fixed level can run on P10 E1080

    Posted 28 days ago

    Hi Kritsada

    Yes you will be fine, we had similar scenario running AIX7.1 TL5 on POWER10 in P8 Compatibility mode.

    POWER8 - I believe the minimum supported level is actually AIX7.1 TL3.

    Regards

    Luke



    ------------------------------
    Luke February
    ------------------------------



  • 3.  RE: AIX fixed level can run on P10 E1080

    IBM Champion
    Posted 27 days ago

    In one week AIX 7.1 will be out of service for one year, as per Search results - Product lifecycle - IBM Support

    The link at the bottom says:

    Power10 AIX support


    AIX 7.1 TL5 SP3
    IBM Power10 systems supports AIX 7.1 only in Power8 compatibility mode.

    AIX 7.2 TL6 SP2
    IBM Power10 systems supports AIX 7.2 only in Power9 compatibility mode.

    AIX 7.3 
    IBM Power systems extends the scalability of AIX 7.3, supporting a maximum of 240 cores 
    (1920 hardware threads) in a single Power10 LPAR.

    VIOS 3.1.3
    All levels of VIOS 3.1.3 are supported. Lower VIOS levels may be supported based on the 
    update level. See: System to PowerVM Virtual I/O Server maps.

    https://www.ibm.com/downloads/cas/6YOG7OMV



    ------------------------------
    Robert Berendt IBMChampion
    ------------------------------



  • 4.  RE: AIX fixed level can run on P10 E1080

    Posted 27 days ago

    Thanks so much. And are there anything else should I aware? sample C/C++ runtime or compiler. If our vendor compile their core with XL C/C++ v11 then C/C++ runtime should not newer?



    ------------------------------
    kritsada ruayruengrung
    ------------------------------



  • 5.  RE: AIX fixed level can run on P10 E1080

    IBM Champion
    Posted 27 days ago

    I am not an AIX expert.  I have never developed one line of code to run on AIX.  I have consultants help me set up AIX on Power systems.  Anything I posted above I learned today simply just by having faith in IBM and searching them.  I have never visited those links prior to today.  We are running AIX 7300-02-01-2346 on one lpar on a Power 9 and on one lpar on a Power 10.  The only application is IBM Storage Protect.

    We are one of those shops which typically upgrade to the latest version of OS.  Sometimes within a month of so of it becoming G/A.  Every quarter we put on patches or upgrades.  Running an out of service version sounds to me like fingernails on a chalkboard.  If you're too young to remember chalkboards watch the movie "Jaws" for that sound.



    ------------------------------
    Robert Berendt IBMChampion
    ------------------------------



  • 6.  RE: AIX fixed level can run on P10 E1080

    Posted 27 days ago
    Edited by Luke February 27 days ago

    Remember your current version of C++ on AIX7.1 will still work as that is linked to the OS not the P10 Hardware. As soon as you perform a migration installation/upgrade of your OS to AIX7.2 or 7.3 you will most-likely need to update your C++ Version as well. 

    Running old or unsupported AIX Operating systems on Newer IBM Power hardware is not uncommon practice. Sometimes the business is still running a critical system/application which is only certified on that old unsupported version of the OS example AIX 7.1...or the business is in the process of replacing that older Application with something newer that's certified on AIX7.2/7.3.

    Whilst your Application on AIX7.1 will still work 100% on IBM POWER 10 hardware, its recommended to upgrade the OS at your earliest convenience to a supported/newer version.

    Regards

    ------------------------------
    Luke February
    ------------------------------