AIX Open Source

 View Only
  • 1.  AIX 7.1: httpd-2.4.51 failed dependencies

    Posted 13 days ago
    Hello All

    On the last dependency installed we have:

    rpm -U httpd-2.4.51-1.aix7.1.ppc.rpm apr\-1.7.0\-1.aix6.1.ppc.rpm expat\-2.4.2\-1.aix7.1.ppc.rpm ....etc
    file /opt/freeware/lib/libdb.a from install of db-5.3.28-1.ppc conflicts with file from package db4-4.8.30-1.ppc
    file /opt/freeware/lib/libdb-4.8.so from install of db-5.3.28-1.ppc conflicts with file from package db4-4.8.30-1.ppc
    file /opt/freeware/lib64/libdb-4.8.so from install of db-5.3.28-1.ppc conflicts with file from package db4-4.8.30-1.ppc

    rpm -e db4
    error: Failed dependencies:
    db is needed by (installed) AIX-rpm-7.1.5.31-12.ppc

    oslevel -s
    7100-05-06-2028

    Please assist in how to handle this dependency/conflict before httpd can be installed.

    Thanks so much.

    ------------------------------
    Jan Robinson
    ------------------------------


  • 2.  RE: AIX 7.1: httpd-2.4.51 failed dependencies

    Posted 12 days ago
    Hi Jan,

    Looks like db4 package is installed from some other source. AIX toolbox does not have db4-4.8.30.
    I think what is happening here is db4-4.8.30 (db4)  package name is different than db-5.3.28 (db) and hence conflict is coming.
    If db4 would have been same name (db-4.8.30) then db-5.3.28 would have updated. In your case two different packages (because package names are different db4 and db) are owning same file. Can you please share output of following command.

    # rpm -qa db4

    To install db-5  you will have to remove db4

    ------------------------------
    SANKET RATHI
    ------------------------------



  • 3.  RE: AIX 7.1: httpd-2.4.51 failed dependencies

    Posted 9 days ago
    Hello Sanket

    Thank you for the reply.

    # rpm -qa db4
    db4-4.8.30-1.ppc

    # l db\-5.3.28\-1.aix6.1.ppc.rpm
    -rw-r--r-- 1 root system 8066801 Jan 12 15:14 db-5.3.28-1.aix6.1.ppc.rpm

    # rpm -U db-5.3.28-1.aix6.1.ppc.rpm
    file /opt/freeware/lib/libdb.a from install of db-5.3.28-1.ppc conflicts with file from package db4-4.8.30-1.ppc
    file /opt/freeware/lib/libdb-4.8.so from install of db-5.3.28-1.ppc conflicts with file from package db4-4.8.30-1.ppc
    file /opt/freeware/lib64/libdb-4.8.so from install of db-5.3.28-1.ppc conflicts with file from package db4-4.8.30-1.ppc

    #rpm -e db4-4.8.30-1.ppc
    error: Failed dependencies:
    db is needed by (installed) AIX-rpm-7.1.5.33-14.ppc

    ML updated.
    # oslevel -s
    7100-05-09-2148

    # lslpp -l rpm.rte
    Fileset Level State Description
    ----------------------------------------------------------------------------
    Path: /usr/lib/objrepos
    rpm.rte 4.13.0.11 COMMITTED RPM Package Manager

    Thanks so much.

    ------------------------------
    Jan Robinson
    ------------------------------



  • 4.  RE: AIX 7.1: httpd-2.4.51 failed dependencies

    Posted 9 days ago
    Hi Jan,

    Sorry I asked wrong option in command.
    I need output of 
    # rpm -qi db4​


    ------------------------------
    SANKET RATHI
    ------------------------------



  • 5.  RE: AIX 7.1: httpd-2.4.51 failed dependencies

    Posted 9 days ago
    Hi Sanket

    Nop.

    # rpm -qi db4
    Name : db4
    Version : 4.8.30
    Release : 1
    Architecture: ppc
    Install Date: Sun Dec 17 13:54:09 USAST 2017
    Group : System Environment/Libraries
    Size : 18793571
    License : Sleepycat and BSD
    Signature : (none)
    Source RPM : db4-4.8.30-1.src.rpm
    Build Date : Sat Nov 26 10:11:22 USAST 2016
    Build Host : aix51.perzl.org
    Relocations : (not relocatable)
    URL : http://www.oracle.com/database/berkeley-db/
    Summary : The Berkeley DB database library (version 4) for C
    Description :
    The Berkeley Database (Berkeley DB) is a programmatic toolkit that
    provides embedded database support for both traditional and
    client/server applications. The Berkeley DB includes B+tree, Extended
    Linear Hashing, Fixed and Variable-length record access methods,
    transactions, locking, logging, shared memory caching, and database
    recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
    used by many applications, including Python and Perl, so this should
    be installed on all systems.

    ------------------------------
    Jan Robinson
    ------------------------------



  • 6.  RE: AIX 7.1: httpd-2.4.51 failed dependencies

    Posted 9 days ago
    Edited by SANKET RATHI 9 days ago
    Hi Jan,

    As I thought db4 package is from a different site and hence it is not compatible with AIX toolbox packages.
    To overcome this issue we will have to remove db4 but as db4 is a dependency for AIX-rpm it is tough.
    Actually this should never happen AIX-rpm is a virtual rpm package that is created to provide (resolve dependencies for) AIX native libraries (or libraries/files those are not provided by rpm packages) for rpm packages.

    Please try one thing and see if after that can you remove db4 package.
    Run 'updtvpkg' command (this will rebuild AIX-rpm package and hope it will remove the dependency of db4 if no more needed)
    After successfully completion try to remove db4 again.

    If this does not work then share the output of 
    # rpm -q --whatrequires db4

    ------------------------------
    SANKET RATHI
    ------------------------------



  • 7.  RE: AIX 7.1: httpd-2.4.51 failed dependencies

    Posted 9 days ago
    Hi Sanket

    So strange, I have done the updtvpkg several times before the ML update, not after.
    It all worked now.

    Thanks so much.

    #updtvpkg
    Please wait...
    zabmwkccdev:/export/Apache #rpm -e db4-4.8.30-1.ppc

    # rpm -U httpd-2.4.51-1.aix7.1.ppc.rpm apr\-1.7.0\-1.aix6.1.ppc.rpm expat\-2.4.2\-1.aix7.1.ppc.rpm openldap\-2.........
    3004-686 Group "ldap" does not exist.
    3004-686 Group "apache" does not exist.
    3004-687 User "apache" does not exist.
    This version of httpd has 32bit and 64bit support
    To start 64bit httpd use : /opt/freeware/sbin/apachectl_64 start

    Happiness...

    Best regards.
    ​​

    ------------------------------
    Jan Robinson
    ------------------------------



  • 8.  RE: AIX 7.1: httpd-2.4.51 failed dependencies

    Posted 9 days ago
    Great !! happy to help.

    ------------------------------
    SANKET RATHI
    ------------------------------