AIX Open Source

Expand all | Collapse all

0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

  • 1.  0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

    Posted Mon June 14, 2021 09:54 AM
    Edited by Alain AG gouet Tue June 15, 2021 06:17 AM
    Hello,
    I install bash-5.0.18-1.src.rpm with success.
    Pb when exec :
    Preparing... ################################# [100%]
    Updating / installing...
    1:bash-5.0.18-1 ################################# [100%]

    ## Binary "bash" is available in 32bit and 64bit ##

    Default is 64bit. For 32bit, use /opt/freeware/bin/bash_32

    {db20tsblc01};root;/install/AIX/rpm/bash]bash
    exec(): 0509-036 Cannot load program bash_64 because of the following errors:
    0509-130 Symbol resolution failed for bash_64 because:
    0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from
    dependent module /opt/freeware/lib/libiconv.a[libiconv.so.2].
    0509-136 Symbol _GLOBAL__AIXD_libiconv_so (number 216) is not exported from
    dependent module /opt/freeware/lib/libiconv.a[libiconv.so.2].
    0509-192 Examine .loader section symbols with the
    'dump -Tv' command.
    Can you help me?
    Alain Gouet
    +33621966630

    ------------------------------
    Alain AG gouet
    agouet@devanlay.fr
    ------------------------------


  • 2.  RE: 0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

    Posted Mon June 14, 2021 09:59 AM
    Hi Alain,

    How did you install bash ? 
    Looks like you are having an older libiconv that does not have this symbol or using from wrong location.
    Please update latest libiconv from AIX toolbox that should resolve the issue. 
    Also a newer version of bash 5.1.4 is available on AIX toolbox it has a fix.

    ------------------------------
    SANKET RATHI
    ------------------------------



  • 3.  RE: 0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

    Posted Tue June 15, 2021 05:13 AM
    Hello Sanket,

    Thanks for your reply.
    Can you please give me the link of bash 5.1.4. I have not found it.
    When i  launch i have these messages :
    {db20tsblc01};root;/install/AIX/rpm/bash/libiconv]rpm -Uvh *.rpm  (libiconv-1.16-1.ppc)
    error: Failed dependencies:
    libgcc_s.a(shr.o) is needed by libiconv-1.16-1.ppc

    {db20tsblc01};root;/install/AIX/rpm/bash/libiconv]ls -l
    total 3296
    -rw-r--r-- 1 root system 14564 Jun 15 11:03 libgcc-8-1.aix7.2.ppc.rpm
    -rw-r--r-- 1 root system 1669115 Jun 15 10:03 libiconv-1.16-1.aix6.1.ppc.rpm

    {db20tsblc01};root;/install/AIX/rpm/bash/libiconv]rpm -Uvh *.rpm
    error: Failed dependencies:
    libgcc8 is needed by libgcc-1:8-1.ppc
    libgcc_s.a(shr.o) is needed by libiconv-1.16-1.ppc

    Please can you give me the good libgcc8 in AIXtools.
    Thanks.
    Alain Gouet.

    ------------------------------
    Alain AG gouet
    ------------------------------



  • 4.  RE: 0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

    Posted Tue June 15, 2021 09:57 AM
    Hello,

    I uninstalled bash 5.018 then did the installations below :
    {dbow16tsblc01};root;/install/AIX/rpm/bash/libiconv]ls -l
    total 5248
    -rw-r--r-- 1 root system 14564 Jun 15 11:03 libgcc-8-1.aix7.2.ppc.rpm
    -rw-r--r-- 1 root system 997783 Jun 15 12:07 libgcc8-8.3.0-5.aix7.2.ppc.rpm
    -rw-r--r-- 1 root system 1669115 Jun 15 10:03 libiconv-1.16-1.aix6.1.ppc.rpm
    {dbow16tsblc01};root;/install/AIX/rpm/bash/libiconv]rpm -Uvh libgcc8-8.3.0-5.aix7.2.ppc.rpm
    Preparing... ################################# [100%]
    Updating / installing...
    1:libgcc8-8.3.0-5 ################################# [100%]
    {dbow16tsblc01};root;/install/AIX/rpm/bash/libiconv]rpm -Uvh libgcc-8-1.aix7.2.ppc.rpm
    Preparing... ################################# [100%]
    Updating / installing...
    1:libgcc-1:8-1 ################################# [100%]
    {dbow16tsblc01};root;/install/AIX/rpm/bash/libiconv]rpm -Uvh libiconv-1.16-1.aix6.1.ppc.rpm
    Preparing... ################################# [100%]
    package libiconv-1.16-1.ppc is already installed
    file /opt/freeware/include/iconv.h from install of libiconv-1.16-1.ppc conflicts with file from package libiconv-1.16-1.ppc
    file /opt/freeware/lib/libcharset.a from install of libiconv-1.16-1.ppc conflicts with file from package libiconv-1.16-1.ppc
    file /opt/freeware/lib/libiconv.a from install of libiconv-1.16-1.ppc conflicts with file from package libiconv-1.16-1.ppc
    file /opt/freeware/bin/iconv from install of libiconv-1.16-1.ppc conflicts with file from package libiconv-1.16-1.ppc
    {dbow16tsblc01};root;/install/AIX/rpm/bash/libiconv]cd /install/AIX/rpm/bash/
    {dbow16tsblc01};root;/install/AIX/rpm/bash]ls -l
    total 20064
    -rw-r--r-- 1 root system 2881401 Jun 2 10:14 bash-5.0.18-1.aix6.1.ppc.rpm

    {dbow16tsblc01};root;/install/AIX/rpm/bash]rpm -Uvh bash-5.0.18-1.aix6.1.ppc.rpm
    Preparing... ################################# [100%]
    Updating / installing...
    1:bash-5.0.18-1 ################################# [100%]

    ## Binary "bash" is available in 32bit and 64bit ##

    Default is 64bit. For 32bit, use /opt/freeware/bin/bash_32

    {dbow16tsblc01};root;/install/AIX/rpm/bash]bash
    Could not load program bash_64:
    Symbol resolution failed for bash_64 because:
    Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from dependent
    module /opt/freeware/lib/libiconv.a[libiconv.so.2].
    Symbol _GLOBAL__AIXD_libiconv_so (number 216) is not exported from dependent
    module /opt/freeware/lib/libiconv.a[libiconv.so.2].
    Examine .loader section symbols with the 'dump -Tv' command.
    {dbow16tsblc01};root;/install/AIX/rpm/bash]

    I remain in a dead end. Thank you for your help.

    ------------------------------
    Alain AG gouet
    ------------------------------



  • 5.  RE: 0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

    Posted Tue June 15, 2021 10:06 AM
    Hello,
    I have found and install bash-5.1.4 but have the same problem as you can see :

    {dbow16tsblc01};root;/install/AIX/rpm/bash]

    Preparing... ########################################
    Updating / installing...
    bash-5.1.4-1 ########################################

    ## Binary "bash" is available in 32bit and 64bit ##

    Default is 64bit. For 32bit, use /opt/freeware/bin/bash_32

    Cleaning up / removing...
    bash-5.0.18-1 ########################################
    {dbow16tsblc01};root;/install/AIX/rpm/bash/libiconv]bash
    Could not load program bash_64:
    Symbol resolution failed for bash_64 because:
    Symbol _GLOBAL__AIXI_libiconv_so (number 222) is not exported from dependent
    module /opt/freeware/lib/libiconv.a[libiconv.so.2].
    Symbol _GLOBAL__AIXD_libiconv_so (number 223) is not exported from dependent
    module /opt/freeware/lib/libiconv.a[libiconv.so.2].
    Examine .loader section symbols with the 'dump -Tv' command.
    {dbow16tsblc01};root;/install/AIX/rpm/bash/libiconv]

    ------------------------------
    Alain AG gouet
    ------------------------------



  • 6.  RE: 0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

    Posted Tue June 15, 2021 10:16 AM
    What is the output of "rpm -qi libiconv" ?

    ------------------------------
    Ayappan P
    ------------------------------



  • 7.  RE: 0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

    Posted Tue June 15, 2021 10:29 AM
    Hello,

    {dbow16tsblc01};root;/install/AIX/rpm/bash/libiconv]rpm -qi libiconv
    Name : libiconv
    Version : 1.16
    Release : 1
    Architecture: ppc
    Install Date: Wed Sep 2 15:46:09 2020
    Group : System Environment/Libraries
    Size : 2786858
    License : LGPL
    Signature : (none)
    Source RPM : libiconv-1.16-1.src.rpm
    Build Date : Mon Apr 29 10:18:22 2019
    Build Host : aix51.perzl.org
    Relocations : (not relocatable)
    URL : http://www.gnu.org/software/libiconv/
    Summary : Character set conversion library, portable iconv implementation
    Description :
    GNU libiconv provides an iconv() implementation for use on systems
    which don't have one or whose implementation cannot convert from/to Unicode.
    It supports all the important encodings in use today.

    The library is available as 32-bit and 64-bit.

    If you are compiling a 32-bit program, no special compiler options are
    needed.

    If you are compiling a 64-bit program, you have to compile and link your
    application with "cc_r -q64" or "gcc -maix64".
    {dbow16tsblc01};root;/install/AIX/rpm/bash/libiconv]

    It seems we are not pointing on /opt/freeware/lib

    Regards

    ------------------------------
    Alain AG gouet
    ------------------------------



  • 8.  RE: 0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

    Posted Tue June 15, 2021 11:23 AM
    You are using perzl libiconv rpm that won't work with AIX Toolbox packages. 
    Get it from AIX Toolbox.

    ------------------------------
    Ayappan P
    ------------------------------



  • 9.  RE: 0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

    Posted Tue June 15, 2021 12:38 PM
    Hello,
    I tried to install libiconv (libiconv-1.16-1.aix6.1.ppc.rpm) found in AIXtools without success. What do you suggest to me?

    {dbow16tsblc01};root;/install/AIX/rpm/bash/libiconv]rpm -Uvh libiconv-1.16-1.aix6.1.ppc.rpm
    Preparing... ################################# [100%]
    package libiconv-1.16-1.ppc is already installed
    file /opt/freeware/include/iconv.h from install of libiconv-1.16-1.ppc conflicts with file from package libiconv-1.16-1.ppc
    file /opt/freeware/lib/libcharset.a from install of libiconv-1.16-1.ppc conflicts with file from package libiconv-1.16-1.ppc
    file /opt/freeware/lib/libiconv.a from install of libiconv-1.16-1.ppc conflicts with file from package libiconv-1.16-1.ppc
    file /opt/freeware/bin/iconv from install of libiconv-1.16-1.ppc conflicts with file from package libiconv-1.16-1.ppc
    {dbow16tsblc01};root;/install/AIX/rpm/bash/libiconv]


    ------------------------------
    Alain AG gouet
    ------------------------------



  • 10.  RE: 0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

    Posted Wed June 16, 2021 02:05 AM
    You cannot use "rpm -Uvh .." in this case.
    Use "rpm --reinstall libiconv-1.16-1.aix6.1.ppc.rpm"

    ------------------------------
    Ayappan P
    ------------------------------



  • 11.  RE: 0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

    IBM Select
    Posted 8 days ago

    root@qa-capp01:/root: rpm -qa|grep bash
    bash-5.0.17-2.ppc
    root@qa-capp01:/root: bash
    Could not load program bash_64:
    Symbol resolution failed for bash_64 because:
    Symbol _GLOBAL__AIXI_libiconv_so (number 214) is not exported from dependent
    module /opt/freeware/lib/libiconv.a[libiconv.so.2].
    Symbol _GLOBAL__AIXD_libiconv_so (number 215) is not exported from dependent
    module /opt/freeware/lib/libiconv.a[libiconv.so.2].
    Examine .loader section symbols with the 'dump -Tv' command.
    root@capp01:/root:



    ------------------------------
    Amit Tripathi
    ------------------------------



  • 12.  RE: 0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 215) is not exported from

    Posted 6 days ago
    From where did you install bash ? 
    Can you please share output of "rpm -qi bash"
    Also do you have any LIBPATH set ? If it is then run without setting LIBPATH.

    ------------------------------
    SANKET RATHI
    ------------------------------