AIX Open Source

 View Only
  • 1.  Node issue on AIX 7100-01

    Posted 8 days ago
    I have a AIX7100-01 server where I installed Node 14. 

    # node -v
    exec(): 0509-036 Cannot load program node because of the following errors:
    rtld: 0712-001 Symbol aligned_alloc was referenced
    from module /opt/freeware/lib/pthread/ppc64/libstdc++.a(libstdc++.so.6), but a runtime definition
    of the symbol was not found.
    rtld: 0712-002 fatal error: exiting.

    I have installed 
    libgcc-8.3.0-2
    libstdc++-8.3.0-2

    I have other servers with AIX 7100-04 which are working okay with this setup. Any ideas on what is causing this error with libstdc++


    ------------------------------
    Vandana Sakamuri
    ------------------------------


  • 2.  RE: Node issue on AIX 7100-01

    Posted 7 days ago
    aligned_alloc should be provided by libc. Probably AIX 7.1 TL levels below 3 may not be having it. 
    We use AIX 7.1 TL 03 as our build machine for AIX 7.1Toolbox rpms.

    ------------------------------
    Ayappan P
    ------------------------------



  • 3.  RE: Node issue on AIX 7100-01

    Posted 7 days ago
    I would suggest you to update the TL level.

    ------------------------------
    Ayappan P
    ------------------------------



  • 4.  RE: Node issue on AIX 7100-01

    Posted 6 days ago
    Thanks for the reply. I tried version 6 of libstdc++ and that worked. I will work on updating the TL level.

    ------------------------------
    Vandana Sakamuri
    ------------------------------