AIX Open Source

Expand all | Collapse all

Updating Apache HTTP server on AIX 7.1

  • 1.  Updating Apache HTTP server on AIX 7.1

    Posted 8 days ago
    Hello, 

    I have updated Apache HTTP server on a AIX 7.1 server with the following commands and packages:
    rpm -ivh libgcc-8.3.0-2.aix7.1.ppc.rpm
    rpm -ivh bzip2-1.0.8-2.aix6.1.ppc.rpm --force
    rpm -ivh readline-8.0-2.aix6.1.ppc.rpm --force
    rpm -ivh libstdcplusplus-8.3.0-2.aix7.1.ppc.rpm
    rpm -ivh pcre-8.44-1.aix6.1.ppc.rpm --force
    rpm -ivh expat-2.2.9-2.aix6.1.ppc.rpm
    rpm -ivh httpd-2.4.43-1.aix6.1.ppc.rpm --force
    rpm -ivh mod_ssl-2.4.43-1.aix6.1.ppc.rpm --force

    When I try to attempt to start using the command "/opt/freeware/sbin/apachectl_64 start" the following error occurs:
    Could not load program httpd_64:
    rtld: 0712-001 Symbol _GLOBAL__AIXI_libapr_1_so was referenced
    from module httpd_64(), but a runtime definition
    of the symbol was not found.
    rtld: 0712-001 Symbol _GLOBAL__AIXD_libapr_1_so was referenced
    from module httpd_64(), but a runtime definition
    of the symbol was not found.
    rtld: 0712-001 Symbol apr_os_uuid_get was referenced
    from module httpd_64(), but a runtime definition
    of the symbol was not found.
    rtld: 0712-001 Symbol _GLOBAL__AIXI_libaprutil_1_so was referenced
    from module httpd_64(), but a runtime definition
    of the symbol was not found.
    rtld: 0712-001 Symbol _GLOBAL__AIXD_libaprutil_1_so was referenced
    from module httpd_64(), but a runtime definition
    of the symbol was not found.
    rtld: 0712-002 fatal error: exiting.

    Here is the output of "rpm -qa":
    rsync-3.0.6-1.ppc
    bash-4.2-9.ppc
    AIX-rpm-7.1.3.30-3.ppc
    libiconv-1.15-1.ppc
    readline-7.0-3.ppc
    zlib-1.2.11-1.ppc
    db4-4.8.30-1.ppc
    openldap-2.4.44-0.1.ppc
    apr-util-1.6.1-1.ppc
    bzip2-1.0.8-2.ppc
    libstdc++-8.3.0-2.ppc
    httpd-2.4.43-1.ppc
    mod_ssl-2.4.43-1.ppc
    gettext-0.10.40-8.ppc
    bzip2-1.0.6-1.ppc
    lpar2rrd-agent-6.15-2.ppc
    info-6.4-1.ppc
    pcre-8.41-1.ppc
    expat-2.2.6-1.ppc
    openssl-1.0.2s-1.ppc
    apr-1.6.3-1.ppc
    apr-util-ldap-1.6.1-1.ppc
    libgcc-8.3.0-2.ppc
    readline-8.0-2.ppc
    pcre-8.44-1.ppc
    expat-2.2.9-2.ppc


    ------------------------------
    Hugo Cabaco
    ------------------------------


  • 2.  RE: Updating Apache HTTP server on AIX 7.1

    Posted 8 days ago
    The apr & apr-utils rpms are not from Toolbox. Probably from perzl site.
    Mixing up of rpms from Toolbox & Perzl don't go well because Toolbox uses GCC to compile the packages whereas perzl uses XLC.

    ------------------------------
    Ayappan P
    ------------------------------



  • 3.  RE: Updating Apache HTTP server on AIX 7.1

    Posted 7 days ago
    Please see this link Installation and configuration of Apache Subversion on IBM AIX 7.1 with LDAP and SSL
    IBM Developer remove preview
    Installation and configuration of Apache Subversion on IBM AIX 7.1 with LDAP and SSL
    Apache Subversion installation particularly on IBM AIX can be tricky because of Subversion's dependencies on many other packages. Traditional installation using RPM Package Manager (RPM) packages by resolving dependencies of Subversion on AIX is quite complex. Resolving dependencies also involves installing particular versions of dependent packages.
    View this on IBM Developer >


    ------------------------------
    Bis Matrimony
    Marriage Consultant
    Bis Matrimony
    Ranni
    ------------------------------



  • 4.  RE: Updating Apache HTTP server on AIX 7.1

    Posted 7 days ago
    Wouldn't the XLC compiler take advantage of the multiple threads where the GCC compiler would not?  I would think I want software on AIX compiled with XLC?

    ------------------------------
    Vincenzo Giambalvo
    ------------------------------