AIX Open Source

power-server-operatingsystems.png

Operating Systems

The core of your mission-critical workloads: AIX, IBM i, and Enterprise Linux

power-ISV-Solutions1.png

ISV Solutions

Stay up to date with key capabilities running on POWER such as SAP

Business Continuity

Learn how to keep critical processes running and adapt quickly with PowerHA

power-infrastructure-security.png

Power Security

Protect your most sensitive data anywhere in your hybrid cloud

Virtualization

Check here for virtualization and management needs: HMC & CMC, PowerVC, and PowerVM

Open Source

Join our open source efforts within the IBM Power Systems portfolio

Enterprise Infrastructure as a Service

Achieve business growth with agility and flexibility with our enterprise IaaS in Power Virtual Server

Programming Languages

The hub for Programming Languages

Expand all | Collapse all

CURL Installation Error

  • 1.  CURL Installation Error

    Posted 2 days ago
    We are trying to install the curl package on the AIX. Its throwing the below error. Please advise? 

    root [tmp] /tmp: rpm -ivh "curl-7.76.1-1.aix6.1.ppc (2).rpm"
    error: failed dependencies:
    ca-certificates >= 2020.06.01 is needed by curl-7.76.1-1
    krb5-libs >= 1.18.3 is needed by curl-7.76.1-1
    libcom_err.a(libcom_err.so) is needed by curl-7.76.1-1
    libcom_err.so is needed by curl-7.76.1-1
    libcrypto.a(libcrypto.so.1.0.2) is needed by curl-7.76.1-1
    libgcc >= 8.3.0 is needed by curl-7.76.1-1
    libgssapi_krb5.a(libgssapi_krb5.so) is needed by curl-7.76.1-1
    libgssapi_krb5.so is needed by curl-7.76.1-1
    libk5crypto.a(libk5crypto.so) is needed by curl-7.76.1-1
    libk5crypto.so is needed by curl-7.76.1-1
    libkrb5.a(libkrb5.so) is needed by curl-7.76.1-1
    libkrb5.so is needed by curl-7.76.1-1
    liblber.a(liblber-2.4.so.2) is needed by curl-7.76.1-1
    libldap.a(libldap-2.4.so.2) is needed by curl-7.76.1-1
    libnghttp2 >= 1.41.0 is needed by curl-7.76.1-1
    libssh2 >= 1.9.0 is needed by curl-7.76.1-1
    libssh2.a(libssh2.so.1) is needed by curl-7.76.1-1
    libssl.a(libssl.so.1.0.2) is needed by curl-7.76.1-1
    openldap >= 2.4.56-2 is needed by curl-7.76.1-1
    zlib >= 1.2.11 is needed by curl-7.76.1-1

    ------------------------------
    sewa singh
    ------------------------------


  • 2.  RE: CURL Installation Error

    Posted yesterday
    You will have to install the dependencies to install curl. It is similar to any other rpm based system.
    The best way to resolve dependencies it to use yum or dnf.

    ------------------------------
    SANKET RATHI
    ------------------------------