AIX Open Source

Expand all | Collapse all

python 2.6 or higher on AIX

  • 1.  python 2.6 or higher on AIX

    Posted 8 days ago

    Please on the same server , we need to install python-2.6 or a higher version

    I have download a python and try it to install manually but i was not able because of dependencies 
    please is there a python package that can include all dependencies ?

    #‌rpm -ivh python3-3.7.9-1.aix6.1.ppc.rpm

    error: Failed dependencies:

    bzip2 >= 1.0.8 is needed by python3-3.7.9-1.ppc

    expat >= 2.2.9 is needed by python3-3.7.9-1.ppc

    gdbm >= 1.18.1 is needed by python3-3.7.9-1.ppc

    gettext >= 0.19.8.1 is needed by python3-3.7.9-1.ppc

    libexpat.a(libexpat.so.1) is needed by python3-3.7.9-1.ppc

    libffi >= 3.2.1 is needed by python3-3.7.9-1.ppc

    libffi.a(libffi.so.6) is needed by python3-3.7.9-1.ppc

    libgcc >= 8.3.0 is needed by python3-3.7.9-1.ppc

    libgcc_s.a(shr.o) is needed by python3-3.7.9-1.ppc

    libgdbm.a(libgdbm.so.6) is needed by python3-3.7.9-1.ppc

    liblzma.a(liblzma.so.5) is needed by python3-3.7.9-1.ppc

    libncurses.so is needed by python3-3.7.9-1.ppc

    libpanel.so is needed by python3-3.7.9-1.ppc

    libreadline.a(libreadline.so.8) is needed by python3-3.7.9-1.ppc

    ncurses >= 6.2 is needed by python3-3.7.9-1.ppc

    readline >= 8.0-2 is needed by python3-3.7.9-1.ppc

    sqlite >= 3.32.1 is needed by python3-3.7.9-1.ppc

    xz-libs >= 5.2.4 is needed by python3-3.7.9-1.ppc

    zlib >= 1.2.11 is needed by python3-3.7.9-1.ppc



    Please is there a work around to install python with all dependencies   ?


    Thanks for your help



    ------------------------------
    mostafa BE84
    IBM
    montreal
    ------------------------------


  • 2.  RE: python 2.6 or higher on AIX

    Posted 7 days ago
    Better option is to setup YUM and install packages with YUM.
    Have a look at this article on setting up YUM in AIX.
    https://developer.ibm.com/technologies/systems/articles/configure-yum-on-aix/

    ------------------------------
    SANGAMESH
    ------------------------------



  • 3.  RE: python 2.6 or higher on AIX

    Posted 7 days ago
    Hi, you could also try the following as this will give you the latest rpm & yum packages (yum bundle includes Python plus dependencies).

    Download latest rpm from IBM and place in /var/tmp
    http://ftp.software.ibm.com/aix/freeSoftware/aixtoolbox/INSTALLP/ppc/rpm.rte
    cd /var/tmp
    installp -caYgd /var/tmp rpm.rte rpm.rte

    Then get the latest yum bundle (includes Python) from https://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/ezinstall/ppc/yum_bundle.tar and place in /var/tmp
    tar xvf yum_bundle.tar
    chmod 644 *.rpm
    rpm -Uvh /var.tmp/*.rpm

    Regards, Steve

    ------------------------------
    Steve Munday
    AIX, IBM i, PowerVM
    ------------------------------



  • 4.  RE: python 2.6 or higher on AIX

    Posted 7 days ago
    Hi , 

    Thank you for your replay ,
    this server is an private network , no internet available 
    please in this case do you think that YUM bundle can be the best solution ? 

    Thank you

    ------------------------------
    mostafa BE84
    IBM
    montreal
    ------------------------------



  • 5.  RE: python 2.6 or higher on AIX

    Posted 7 days ago
    Mostafa,

    Hi, you'll need to download to a PC/Laptop first and then transfer to the LPAR before running the installations for rpm and yum.

    Regards, Steve

    ------------------------------
    Steve Munday
    AIX, IBM i, PowerVM
    ------------------------------



  • 6.  RE: python 2.6 or higher on AIX

    Posted 7 days ago
    Mostafa,

    Hi, you'll need to download to a PC/Laptop first and then transfer to the LPAR before running the installations for rpm and yum.

    Regards, Steve

    ------------------------------
    Steve Munday
    AIX, IBM i, PowerVM
    ------------------------------



  • 7.  RE: python 2.6 or higher on AIX

    Posted 7 days ago
    Hi Steve , 

    Thank you for your response , 

    I have started with this option : i downloaded first python with some dependencies and when trying installing i got other required dependencies etc ...
    and the cycle did not stop 

    I'm just wondering if there is a bundle of packages that can be downloaded at the same time ?

    thank you

    ------------------------------
    mostafa BE84
    IBM
    montreal
    ------------------------------



  • 8.  RE: python 2.6 or higher on AIX

    Posted 7 days ago
    Mostafa,

    Hi, you need to download (1) rpm, so you have the latest, and then (2) the yum bundle which includes the necessary dependencies.  It'll be easier than trying to work out what you do/don't need Python dependency wise.

    Regards, Steve

    ------------------------------
    Steve Munday
    AIX, IBM i, PowerVM
    ------------------------------



  • 9.  RE: python 2.6 or higher on AIX

    Posted 7 days ago
    Hi Steve 

    But my server did not have access to internet 
    How can yum bundle will install the python with all dependencies ?

    Thank you

    ------------------------------
    mostafa BE84
    IBM
    montreal
    ------------------------------



  • 10.  RE: python 2.6 or higher on AIX

    Posted 7 days ago
    Mostafa,

    Hi, no problem, just use your browser to pull down the rpm and tym_bundle.tar and then transfer to the LPAR.

    In the yum_bundle you'll have the following, all of which get installed when you run the rpm -Uvh /var.tmp/*.rpm

    ca-certificates-2016.10.7-2.aix6.1.ppc.rpm
    curl-7.52.1-1.aix6.1.ppc.rpm
    db-4.8.24-3.aix6.1.ppc.rpm
    gdbm-1.8.3-5.aix5.2.ppc.rpm
    gettext-0.19.7-1.aix6.1.ppc.rpm
    glib2-2.14.6-2.aix5.2.ppc.rpm
    pysqlite-1.1.7-2.aix6.1.ppc.rpm
    python-2.7.10-1.aix6.1.ppc.rpm
    python-devel-2.7.10-1.aix6.1.ppc.rpm
    python-iniparse-0.4-1.aix6.1.noarch.rpm
    python-pycurl-7.19.3-1.aix6.1.ppc.rpm
    python-tools-2.7.10-1.aix6.1.ppc.rpm
    python-urlgrabber-3.10.1-1.aix6.1.noarch.rpm
    readline-6.1-2.aix6.1.ppc.rpm
    sqlite-3.15.2-1.aix6.1.ppc.rpm
    yum-3.4.3-7.aix6.1.noarch.rpm
    yum-metadata-parser-1.1.4-2.aix6.1.ppc.rpm

    Regards, Steve

    ------------------------------
    Steve Munday
    AIX, IBM i, PowerVM
    ------------------------------



  • 11.  RE: python 2.6 or higher on AIX

    Posted 7 days ago
    Hi Steve ,

    Thank you for your response 

    On one AIX server ( 7.1)  ===> it was installed successfully   

    on an other AIX server (6.1 )  ===> i got this error for rpm.rte :
    Requisite Failures
    ------------------
    SELECTED FILESETS: The following is a list of filesets that you asked to
    install. They cannot be installed until all of their requisite filesets
    are also installed. See subsequent lists for details of requisites.

    rpm.rte 4.15.1.1 # RPM Package Manager

    MISSING REQUISITES: The following filesets are required by one or more
    of the selected filesets listed above. They are not currently installed
    and could not be found on the installation media.

    bos.rte 7.1.0.0 # Base Level Fileset

    << End of Failure Section >>


    and for yum_bundle.tar i got this message :

    # rpm -Uvh /var/tmp/*.rpm
    error: failed dependencies:
    libcrypto.a(libcrypto.so) is needed by curl-7.52.1-1
    libssl.a(libssl.so) is needed by curl-7.52.1-1
    libcrypto.a(libcrypto.so) is needed by python-2.7.10-1
    libssl.a(libssl.so) is needed by python-2.7.10-1
    libcrypto.a(libcrypto.so) is needed by python-pycurl-7.19.3-1


    Thank you 


    ------------------------------
    mostafa BE84
    IBM
    montreal
    ------------------------------



  • 12.  RE: python 2.6 or higher on AIX

    Posted 7 days ago
    Mostafa,

    Hi, I think you might find this URL helpful as it speaks on repo(s) for 6.1.

    https://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/ezinstall/ppc/README-yum

    Regards, Steve

    ------------------------------
    Steve Munday
    AIX, IBM i, PowerVM
    ------------------------------



  • 13.  RE: python 2.6 or higher on AIX

    Posted 6 days ago
    Hi,

    There are two ways to install any package from AIX toolbox. The best way is using yum. Because that is the best way to resolve to rpm dependencies. 
    If you are on a private network then you can configure a local yum repo as it is done for any other rpm based Linux system.
    To configure yum for AIX https://developer.ibm.com/technologies/systems/articles/configure-yum-on-aix/

    If you do not want to configure yum for some reason then you will have to manually download all the dependencies from AIX toolbox and install them.
    As you can see from your output these are primary dependencies for python3 and once you download them and try to install you may discover additional one.
    So download all of the following in a directory and try to install using rpm (rpm -ivh *.rpm)
    bzip2
    expat
    gdbm
    gettext
    libffi
    libgcc
    ncurses
    readline
    sqlite
    xz-libs
    zlib
    bash
    glib2
    info
    libiconv
    libstdc++
    libunistring
    libxml2

    We do not recommend this method and suggest to use yum because it is always tedious to resolve dependencies and update to newer version. For private network you need to setup yum repo locally as mentioned in the article. 





    ------------------------------
    SANKET RATHI
    ------------------------------