AIX Open Source

power-server-operatingsystems.png

Operating Systems

The core of your mission-critical workloads: AIX, IBM i, and Enterprise Linux

power-ISV-Solutions1.png

ISV Solutions

Stay up to date with key capabilities running on POWER such as SAP

Business Continuity

Learn how to keep critical processes running and adapt quickly with PowerHA

power-infrastructure-security.png

Power Security

Protect your most sensitive data anywhere in your hybrid cloud

Virtualization

Check here for virtualization and management needs: HMC & CMC, PowerVC, and PowerVM

Open Source

Join our open source efforts within the IBM Power Systems portfolio

Enterprise Infrastructure as a Service

Achieve business growth with agility and flexibility with our enterprise IaaS in Power Virtual Server

Programming Languages

The hub for Programming Languages

Smaba 4.10 Installation at Issue with libgcc and rpmlib

By Dharma Sanassy posted Thu March 04, 2021 01:51 PM

  
Aix Version: 7100-01-05-1228
Samba Version : samba-4.10.14 packages as the latest version has issues
@ issues
(1) libgcc
root @xxxx: /ws/samba/SMBA $rpm -ivh *.rpm
error: failed dependencies:
libgcc = 8.3.0-1 is needed by libstdc++-8.3.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1 is needed by ncurses-6.2-2
rpmlib(PartialHardlinkSets) <= 4.0.4-1 is needed by perl-5.32.0-6
root @wxxxx: /ws/samba/SMBA $ls -l libgcc*
-rw-r--r-- 1 root system 987871 Mar 03 11:39-8.3. libgcc0-1.aix7.1.ppc.rpm   for libstdc++-8.3.0-1
-rw-r--r-- 1 root system 982782 Mar 03 11:47 libgcc-9.1.0-1.aix7.1.ppc.rpm   for python-2.7.18-1

The only two errors I am having are libgcc and rpmlib(in another blog) .
libgcc = 8.3.0-1 is there already but I am not sure if rpm is blind when
there is a later version of libgcc that is libgcc-9.1.0-1
When I downgraded libgcc and remove libgcc-9.0 ) then I get the following errors:

error: failed dependencies:
libstdc++.a(libstdc++.so.6) is needed by cups-2.3.1-1
libstdc++.a(libstdc++.so.6) is needed by gettext-0.21-1
libstdc++.a(libstdc++.so.6) is needed by gmp-6.2.1-1
libgcc >= 8.4.0 is needed by krb5-libs-1.18.2-1
libgcc8 is needed by libgcc-8-2
libstdc++8 is needed by libstdc++-8-2
libstdc++.a(libstdc++.so.6) is needed by ncurses-6.2-2
rpmlib(PartialHardlinkSets) <= 4.0.4-1 is needed by ncurses-6.2-2
rpmlib(PartialHardlinkSets) <= 4.0.4-1 is needed by perl-5.32.0-6
libgcc >= 8.3.0 is needed by python-2.7.18-1
libstdc++ >= 8.3.0 is needed by python-2.7.18-1

If anyone has encountered this situation, please share your solution
Thanks
Dharma

The Package list:
/ws/samba/SMBA $ls -1
bash-5.0.17-2.aix6.1.ppc.rpm
bzip2-1.0.8-2.aix6.1.ppc.rpm
compat-getifaddrs-1.1-1.aix6.1.ppc.rpm
compat-getopt-1.2-1.aix6.1.ppc.rpm
cups-2.3.1-1.aix6.1.ppc.rpm
cups-client-2.3.1-1.aix6.1.ppc.rpm
cups-filesystem-2.3.1-1.aix6.1.noarch.rpm
cups-ipptool-2.3.1-1.aix6.1.ppc.rpm
cups-libs-2.3.1-1.aix6.1.ppc.rpm
cyrus-sasl-2.1.27-3.aix6.1.ppc.rpm
expat-2.2.10-1.aix6.1.ppc.rpm
gdbm-1.19-1.aix7.1.ppc.rpm
gdbm-libs-1.19-1.aix7.1.ppc.rpm
gettext-0.21-1.aix7.1.ppc.rpm
gmp-6.2.1-1.aix7.1.ppc.rpm
gnutls-3.6.14-1.aix6.1.ppc.rpm
info-6.7-4.aix6.1.ppc.rpm
krb5-libs-1.18.2-1.aix6.1.ppc.rpm
libarchive-3.4.2-1.aix6.1.ppc.rpm
libffi-3.2.1-2.aix6.1.ppc.rpm
libgcc-8.3.0-1.aix7.1.ppc.rpm
libgcc-9.1.0-1.aix7.1.ppc.rpm
libgcrypt-1.8.6-2.aix6.1.ppc.rpm
libgpg-error-1.37-2.aix6.1.ppc.rpm
libiconv-1.16-5.aix6.1.ppc.rpm
libsmbclient-4.10.14-2.aix6.1.ppc.rpm
libsmbclient-devel-4.10.14-2.aix6.1.ppc.rpm
libstdc++-8.3.0-1.aix7.1.ppc.rpm
libtasn1-4.16.0-1.aix6.1.ppc.rpm
libtextstyle-0.21-1.aix7.1.ppc.rpm
libunistring-0.9.10-1.aix6.1.ppc.rpm
libxml2-2.9.10-1.aix6.1.ppc.rpm
ncurses-6.2-2.aix6.1.ppc.rpm
nettle-3.5.1-1.aix6.1.ppc.rpm
openldap-2.4.57-1.aix7.1.ppc.rpm
p11-kit-0.23.21-2.aix6.1.ppc.rpm
perl-5.32.0-6.aix6.1.ppc.rpm
popt-1.16-4.aix6.1.ppc.rpm
popt-1.18-1.aix6.1.ppc.rpm
popt-1.7-2.aix5.1.ppc.rpm
python-2.7.18-1.aix6.1.ppc.rpm
readline-8.0.4-1.aix6.1.ppc.rpm
samba-4.10.14-2.aix6.1.ppc.rpm
samba-all-4.10.14-2.aix6.1.ppc.rpm
samba-client-4.10.14-2.aix6.1.ppc.rpm
samba-common-4.10.14-2.aix6.1.ppc.rpm
samba-devel-4.10.14-2.aix6.1.ppc.rpm
samba-libs-4.10.14-2.aix6.1.ppc.rpm
samba-pidl-4.10.14-2.aix6.1.ppc.rpm
samba-python-4.10.14-2.aix6.1.ppc.rpm
samba-winbind-4.10.14-2.aix6.1.ppc.rpm
samba-winbind-clients-4.10.14-2.aix6.1.ppc.rpm
samba-winbind-devel-4.10.14-2.aix6.1.ppc.rpm
samba-winbind-krb5-locator-4.10.14-2.aix6.1.ppc.rpm
sqlite-3.33.0-1.aix6.1.ppc.rpm
sqlite-libs-3.33.0-1.aix6.1.ppc.rpm
xz-5.2.5-1.aix6.1.ppc.rpm
xz-libs-5.2.5-1.aix6.1.ppc.rpm
zlib-1.2.11-5.aix6.1.ppc.rpm

Any help will appreciate
0 comments
31 views

Permalink