MQ

Expand all | Collapse all

how to make 2 version of MQ (mq9.1. and mq9.0) in same WIN without any issue

  • 1.  how to make 2 version of MQ (mq9.1. and mq9.0) in same WIN without any issue

    Posted Mon November 30, 2020 08:34 AM
    ​Hello everybody here!

    I've upgraded Win machine from MQ 9.0.0.6 to MQ 9.1.0.6 , I've installed the new version in parallel with old one ,When I've finished
    I won't uninstall the old version because I'm trying to follow the best practice that recommended by IBM, and I 'll uninstall it after being verified that every thing is ok, I set the MQ 9.1 as primary and I stopped the old installation services and set it to be run manually

    the problem that we're facing that the application can't be running and getting the below error

    ======================================================================================

    2020-11-26 09:29:01 336 005 Log:  MQ:: QMGR XMBI21WT & Queue FXMS_Sync_Exch_Rate_EXIM_Int_Req

    2020-11-26 09:29:01 336 005 Log:  Conection String  Use******** loaded successfuly ...

    2020-11-26 09:29:01 336 005 Log:  ... Parameters Initiliasation Completed ...

    2020-11-26 09:29:01 336 005 Message:   ---- RunMain Job Started ----

    2020-11-26 09:29:01 399 005 FatalError:  Exception at RunMain Could not load file or assembly 'amqmdnet, Version=8.0.0.9, Culture=neutral, PublicKeyToken=dd3cb1c9aae9ec97' or one of its dependencies. The system cannot find the file specified.

    ========================================================================================

    It seems  the application is looking for files from the MQ old version library 32, I changed the path for environment variables to make lib64 above the lib32
    C:\Program Files (x86)\IBM\WebSphere MQ\java\lib64
    C:\Program Files (x86)\IBM\WebSphere MQ\java\lib

    but this can't solve the issue , could you please advise what I missed here ??

    ------------------------------
    alaa fahad
    ------------------------------


  • 2.  RE: how to make 2 version of MQ (mq9.1. and mq9.0) in same WIN without any issue

    Posted Tue December 01, 2020 08:20 AM
    Edited by FJ Brandelik Tue December 01, 2020 08:20 AM
    It looks that your application is a 32 bit application. This is not fatal. You just need to set the environment correctly for 32 bits before running it.
    Look at the different options of running setmqenv and more specifically the -x [32 | 64] one...

    ------------------------------
    F.J.




  • 3.  RE: how to make 2 version of MQ (mq9.1. and mq9.0) in same WIN without any issue

    Posted Tue December 01, 2020 08:38 AM

    Existing applications that are compiled with Microsoft.NET Framework V3.5 can be run without recompiling by adding the following tag in the app.config file of the application:
    <configuration>
     <startup>
        <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5.1"/>
     </startup>
    </configuration>

    Please can you try by adding the above in the application's App.config file.

    ------------------------------
    Ram Subba Rao Chalamalasetti
    ------------------------------



  • 4.  RE: how to make 2 version of MQ (mq9.1. and mq9.0) in same WIN without any issue

    Posted Tue December 01, 2020 05:18 PM
    .Net loads amqmdnet.dll from the Windows Global Assembly Cache. Try registering the MQ DLLs in the GAC by running amqiregisterdotnet.cmd (in the MQ bin directory). To check if amqmdnet (& the other .Net MQ DLLs) are in GAC, use Windows Explorer to open C:\Windows\Assembly\GAC_MSIL

    HTH,

    ------------------------------
    Glenn Baddeley
    Senior Middleware Software Engineer
    Coles Supermarkets Australia Pty Ltd
    ------------------------------