Maximo Anywhere

Expand all | Collapse all

Maximo Anywhere 7.6.4 - Problem with Installation Manager

  • 1.  Maximo Anywhere 7.6.4 - Problem with Installation Manager

    Posted Thu March 05, 2020 01:48 PM
    I would like to share with you the problem that we found today and ask for help.

    I was trying to install "IBM Maximo Asset Management required components" but unfortunately during the  prerequisite validation I received this error message (please see the details below).

    Log file and information from process explorer were attached.

    First idea that I had was that I need to upgrade IBM Installation Manager. I did it and the current version is 1.9.1001.20191112_1525 but it didn't help.

    Of course set environment property CTG_BYPASS_PREREQ_CHECK to True is not a solution because the problem is with missing class.

    Do you have any hints for us how to solve this problem?



    Error in log:

    <entry num='166' time='1583417492506' elapsed='00:09.30' level='ERROR' thread='ModalContext'>

    <logger>com.ibm.cic.common.core.model.internal.SelectionExpression</logger>

    <class>com.ibm.cic.common.core.model.internal.SelectionExpression.WithBundle</class>

    <method>evaluate</method>

    <message>Exception caught while evaluating expression in bundle "com.ibm.tivoli.tpae.madt.install.AnywhereOSLCPrereqChk".</message>

    <exception>

      java.lang.NoClassDefFoundError: org.osgi.framework.Version

      <stack>com.ibm.tivoli.tpae.madt.install.anywhereoslcprereqchk.AnywhereOSLCPrereqChk.performPrerequisiteCheck(Unknown Source)</stack>

      <stack>com.ibm.tivoli.tpae.madt.install.anywhereoslcprereqchk.AnywhereOSLCPrereqChk.evaluate(Unknown Source)</stack>

      <stack>com.ibm.cic.common.core.model.internal.SelectionExpression$WithBundle.evaluate(SelectionExpression.java:249)</stack>

      <stack>com.ibm.cic.common.core.model.internal.AbstractFeatureBase.evaluateApplicability(AbstractFeatureBase.java:134)</stack>

      <stack>com.ibm.cic.common.core.model.internal.Feature.evaluateApplicability(Feature.java:1)</stack>

      <stack>com.ibm.cic.agent.core.Agent.checkPrerequisite(Agent.java:1425)</stack>

      <stack>com.ibm.cic.agent.core.sharedUI.PrerequisiteCheckerUtils.collectStatus(PrerequisiteCheckerUtils.java:194)</stack>

      <stack>com.ibm.cic.agent.core.sharedUI.PrerequisiteCheckerUtils.validateOfferingFeaturesAndFeatureGroups(PrerequisiteCheckerUtils.java:171)</stack>

      <stack>com.ibm.cic.agent.core.sharedUI.PrerequisiteCheckerUtils.validateFeatures(PrerequisiteCheckerUtils.java:115)</stack>

      <stack>com.ibm.cic.agent.internal.ui.wizards.ConditionalInstallPage$5.run(ConditionalInstallPage.java:765)</stack>

      <stack>com.ibm.cic.common.ui.internal.dialogs.SocketMonitorRunnableWithProgress$3.run(SocketMonitorRunnableWithProgress.java:238)</stack>

      <stack>org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)</stack>

      <stack>Caused by:java.lang.ClassNotFoundException: org.osgi.framework.Version cannot be found by com.ibm.tivoli.tpae.madt.install.AnywhereOSLCPrereqChk_2.0.1.202002191156</stack>

      <stack>org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:469)</stack>

      <stack>org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:380)</stack>

      <stack>org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:372)</stack>

      <stack>org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)</stack>

      <stack>java.lang.ClassLoader.loadClass(ClassLoader.java:863)</stack>

      <stack>com.ibm.tivoli.tpae.madt.install.anywhereoslcprereqchk.AnywhereOSLCPrereqChk.performPrerequisiteCheck(Unknown Source)</stack>

      <stack>com.ibm.tivoli.tpae.madt.install.anywhereoslcprereqchk.AnywhereOSLCPrereqChk.evaluate(Unknown Source)</stack>

      <stack>com.ibm.cic.common.core.model.internal.SelectionExpression$WithBundle.evaluate(SelectionExpression.java:249)</stack>

      <stack>com.ibm.cic.common.core.model.internal.AbstractFeatureBase.evaluateApplicability(AbstractFeatureBase.java:134)</stack>

      <stack>com.ibm.cic.common.core.model.internal.Feature.evaluateApplicability(Feature.java:1)</stack>

      <stack>com.ibm.cic.agent.core.Agent.checkPrerequisite(Agent.java:1425)</stack>

      <stack>com.ibm.cic.agent.core.sharedUI.PrerequisiteCheckerUtils.collectStatus(PrerequisiteCheckerUtils.java:194)</stack>

      <stack>com.ibm.cic.agent.core.sharedUI.PrerequisiteCheckerUtils.validateOfferingFeaturesAndFeatureGroups(PrerequisiteCheckerUtils.java:171)</stack>

      <stack>com.ibm.cic.agent.core.sharedUI.PrerequisiteCheckerUtils.validateFeatures(PrerequisiteCheckerUtils.java:115)</stack>

      <stack>com.ibm.cic.agent.internal.ui.wizards.ConditionalInstallPage$5.run(ConditionalInstallPage.java:765)</stack>

      <stack>com.ibm.cic.common.ui.internal.dialogs.SocketMonitorRunnableWithProgress$3.run(SocketMonitorRunnableWithProgress.java:238)</stack>

    </exception>

    </entry>



    ------------------------------
    Piotr Ozaist
    ------------------------------


  • 2.  RE: Maximo Anywhere 7.6.4 - Problem with Installation Manager

    Posted Thu March 05, 2020 04:54 PM
    Edited by Shane Howard Thu March 05, 2020 05:18 PM
    Hi, 

    What version of Maximo are you installing on and does it contain any existing versions of Anywhere?  We have seen this in the past with other industry solutions and the Installation Manager and generally the option is as you suggested to bypass the check. 

    Also make sure you are running the IM as Administrator.

    If this isn't working I would suggest opening a case so we can get on a call and troubleshoot it via webex.

    ------------------------------
    Shane Howard
    ------------------------------



  • 3.  RE: Maximo Anywhere 7.6.4 - Problem with Installation Manager

    Posted Fri March 06, 2020 03:26 AM
    Have you installed all FixPacks and maybe on the latest IFIX?

    ------------------------------
    Craig Kokay,
    Lead Senior Maximo/IoT Consultant
    ISW
    Sydney, NSW, Australia
    Ph: 0411-682-040
    ------------------------------



  • 4.  RE: Maximo Anywhere 7.6.4 - Problem with Installation Manager

    Posted Tue March 17, 2020 03:13 AM
    If you are on Linux, please ensure that the Binary libraries are installed "yum -install bc"

    ------------------------------
    Craig Kokay,
    Lead Senior Maximo/IoT Consultant
    ISW
    Sydney, NSW, Australia
    Ph: 0411-682-040
    ------------------------------



  • 5.  RE: Maximo Anywhere 7.6.4 - Problem with Installation Manager

    Posted Mon March 09, 2020 10:10 AM
    We were on latest ifix (7.6.3.1 IFIX001).

    ------------------------------
    Piotr Ozaist
    ------------------------------



  • 6.  RE: Maximo Anywhere 7.6.4 - Problem with Installation Manager

    Posted Sun March 15, 2020 04:03 PM
    We run into the same error, have you got that resolved?
    "Exception caught while evaluating expression in bundle "com.ibm.tivoli.tpae.madt.install.AnywhereOSLCPrereqChk"."

    Thanks,

    ------------------------------
    Daxu Cao
    Associate/Analyst
    Portland General Electric
    Portland OR
    (503) 464-2204
    ------------------------------



  • 7.  RE: Maximo Anywhere 7.6.4 - Problem with Installation Manager

    Posted Mon March 16, 2020 01:41 AM
    We didn't solve this problem but we found that you can do this installation without any problems when you use silent installation. So it's like workaround that you can use it.
    See the steps below:
    "under "samples" directory of the unzipped 764 image, update response_install_Anywhere_Enablement.xml 

    (probably just the following lines:

    <repository location='C:\Launchpad\Max_Anywhere_V764\Install\AnywhereEnablementInstallerRepository.zip '/>
    <profile id='IBM Tivoli&apos;s process automation suite' installLocation='C:\IBM\SMP'>
    <data key='user.userId,com.ibm.tivoli.tpae.IS.AnywhereEnablement' value='maxadmin'/>

    )

    and then from IM's installed location's tools directory, run

    imcl -input <unzipImageLocation>\samples\response_install_Anywhere_Enablement.xml -acceptLicense"


    Bartosz Marchewka





  • 8.  RE: Maximo Anywhere 7.6.4 - Problem with Installation Manager

    Posted Mon March 16, 2020 03:50 AM
    Hi Bartosz, Looks like this is an upgrade of Anywhere from 7631 IFIX 1 to 764.  
    Which operating system and version are you using?
    Have you tried updating IBM Installation Manager to version 1.9.1.1?
    https://www.ibm.com/support/pages/installation-manager-and-packaging-utility-download-documents


    Regards,
    May

    ------------------------------
    May On
    Support Software Engineer
    IBM
    61754921886
    ------------------------------



  • 9.  RE: Maximo Anywhere 7.6.4 - Problem with Installation Manager

    Posted Wed March 18, 2020 07:20 PM
    We updated the IM to 1.9.1.1, and the issue is resolved.

    ------------------------------
    Daxu Cao
    Associate/Analyst
    Portland General Electric
    Portland OR
    (503) 464-2204
    ------------------------------



  • 10.  RE: Maximo Anywhere 7.6.4 - Problem with Installation Manager

    Posted 27 days ago
    We are also facing same Anywhere installation issue after upgrading IM to 1.9.1.6 on Windows Server.

    ------------------------------
    Srini
    ------------------------------



  • 11.  RE: Maximo Anywhere 7.6.4 - Problem with Installation Manager

    Posted Fri September 17, 2021 02:36 PM
    We have Installation Manager 1.9.1.6 and still having the same issue

    ------------------------------
    Hardev Bal
    ------------------------------