View Entry

Prerequisites and Maintenance for IBM DB2 Analytics Accelerator for z/OS, V5.1 

Mon December 10, 2018 11:35 AM

https://www-01.ibm.com/support/docview.wss?uid=swg27046305&myns=swgimgmt&mynp=OCSS4LQ8&mync=E&cm_sp=swgimgmt-_-OCSS4LQ8-_-E

Detailed System Requirements


Abstract

Hardware and software requirements for installing IBM® DB2® Analytics Accelerator for z/OS®, V5.1.0

Content


IBM DB2 Analytics Accelerator for z/OS - maintenance level


Minimum space settings in SMP/E for the installation of IBM DB2 Analytics Accelerator V5.1.0
and its prerequisites PTFs

1. Temporary data set SYSUT1, SYSUT2, SYSUT3, SYSUT4 in the target, distribution and global zones: SPACE=(TRK,(2000,1000))
2. Work data set SYSWRK1, SYSWRK2, SYSWRK3, SYSWRK4, SYSWRK5, SYSWRK6 in the target and distribution zones: SPACE=(TRK,(1000,1000,450))

Reserve enough storage space for the installation of IBM DB2 Analytics Accelerator for z/OS. The table "Total DASD space required by IBM DB2 Analytics Accelerator for z/OS V5.1.0" shows the space requirements for a basic installation.
Total DASD space required by IBM DB2 Analytics Accelerator for z/OS V5.1.0
Library type Total space required on a DASD 3390
Target 1865 tracks for DB2 Analytics Accelerator
854 tracks for InfoSphere Data Replication
Distribution 79865 tracks for DB2 Analytics Accelerator
1632 tracks for InfoSphere Data Replication
File system(s) 105000 tracks for /usr/lpp/IBM/aqt/v5r1m0
750 tracks for /usr/lpp/chc/V10R2M1

Total DASD space required by optional feature "in-database analytics"
Library type Total Space required on a DASD 3390
File system(s) 22000 tracks for /usr/lpp/IBM/aqt/v5r1m0


Information for IBM service personnel

Before shipping any hardware or software, make sure that you fill in the system assurance confirmation form.
 

Hardware requirements

The following table shows the minimum hardware requirements that must be met to successfully install IBM DB2 Analytics Accelerator for z/OS.

Networking
For the data network between IBM z Systems and PureData System for Analytics N1001 (N2001, N3001), a dedicated physical network is required.

Minimum network configuration
The minimum network configuration is for test and development scenarios, but does not satisfy high availability requirements. Hence this configuration should not be used in a production environment. The minimum network configuration requires the following components:

Heads up:
For longer 10GbE SR connections with distances around 300 meters, OM3 fiber optic cables are required. Other types support only shorter distances.

Quantity Product Location P/N
1 OSA-Express3 10GbE (dual port) IBM zEnterprise System (*)
OSA-Express4S 10GbE (single port) zEnterprise 196 or zEnterprise 114 (*)
OSA-Express5S 10GbE zEnterprise EC12 or zEnterprise BC12  
AND
1 10GbE SFP + Switch
Lenovo RackSwitch G8264
Lenovo RackSwitch G8124E
Network (**)
3 Optical fiber cables Network  
(*) IBM/BNT® 10Gb SFP + Optical Transceiver Switch (*)
1
Note: only needed for
IBM PureData System for Analytics
N3001-001
1 GbE RJ45 Switch
Lenovo RackSwitch G7028
Network  
2
Note: only needed for
IBM PureData System for Analytics
N3001-001
RJ45 cable Network  

(*) For details about supported OSA-Express 10GbE cards and the required type and number of transceivers see:
  Network requirements for System z
(**) If you want to know why a direct network connection does not provide automatic fail-over support and hence at least one switch is needed, see:
Network Configurations for IBM DB2 Analytics Accelerator for z/OS

Recommended network configuration
The following components are required for a fully redundant (high availability) network between IBM z Systems and the PureData System for Analytics N1001 (N2002, N3001).

Quantity Product Location P/N
2 OSA-Express3 10GbE (dual port) IBM zEnterprise System (*)
OSA-Express4S 10GbE (single port) zEnterprise 196 or zEnterprise 114 (*)
OSA-Express5S 10GbE zEnterprise EC12 or zEnterprise BC12  
8 Optical fiber cables Network  
2 10GbE SFP + Switch
Lenovo RackSwitch G8264
Lenovo RackSwitch G8124E
Network (**)
(*) IBM/BNT® 10Gb SFP + Optical Transceiver Switch (*)
1
Note: only needed for
IBM PureData System for Analytics
N3001-001
1 GbE RJ45 Switch
Lenovo RackSwitch G7028
Network  
2
Note: only needed for
IBM PureData System for Analytics
N3001-001
RJ45 cable Network  

Software requirements
Operating systems
Operating system Required features and PTFs Program number
z/OS V2R1 XML Toolkit for z/OS, V1.10.0
APAR OA51592, PTF UA83613
5655-J51
IBM Ported Tools for z/OS V1.3.0 or later
(OpenSSH server with AllowTcpForwarding or
OpenSSH client + OpenSSH server) 1
5655-M23
Data Facility System Managed Storage Base
(DFSMSdfp)
5695-DF1
Communication Server IP HIP61D0
z/OS V2R2 XML Toolkit for z/OS, V1.10.0
APAR OA51592, PTF UA83613
5655-J51
z/OS OpenSSH
Use the following link for information
to plan your changes to the system
Accommodate the OpenSSH ported level
integrated in z/OS V2R2
Data Facility System Managed Storage Base
(DFSMSdfp)
5695-DF1
Communication Server IP HIP61D0
z/OS V2R3 XML Toolkit for z/OS, V1.10.0
APAR OA51592, PTF UA83613
5655-J51
z/OS OpenSSH
Use the following link for information
to plan your changes to the system
Accommodate the OpenSSH ported level
integrated in z/OS V2R3
Data Facility System Managed Storage Base (DFSMSdfp) 5695-DF1
Communication Server IP HIP61D0

( 1 ) For ordering contact IBM with keywords "Withdrawn Order Process".


Database management software

Use one of the supported database management systems on your System z server (DB2 10 for z/OS, or later). Make sure that required program temporary fixes (PTFs) and features are installed. Optional features are marked as such.

Database management system
Database management system Required features and PTFs Program number
DB2 10 for z/OS 1
New Function Mode (NFM)
MLC
or
Value Unit Edition
5605-DB2

5697-P31
DB2 Utilities Suite for z/OS version 10.1 5655-V41
A number of Db2-supplied stored procedures must be configured. See the Installation Guide, SH12-7062, for details.  
DB2 11 for z/OS
New Function Mode (NFM),
Conversion Mode (CM)
MLC
or
Value Unit Edition
5615-DB2

5697-P43
DB2 Utilities Suite for z/OS version 11.1 5655-W87
A number of Db2-supplied stored procedures must be configured. See the Installation Guide, SH12-7079, for details.  
DB2 12 for z/OS 2 MLC
or
Value Unit Edition
5650-DB2

5770-AF3
DB2 Utilities Suite for z/OS version 12.1 5770-AF4
A number of Db2-supplied stored procedures must be configured. See the Installation Guide, SH12-7079, for details.  

( 1 ) Withdrawn from programming service on September 30, 2017.
( 2 ) For known issues concerning support of DB2 12 for z/OS read here.

Recommended minimum level of JDBC driver
You can check the version of your JDBC driver by using the following command: java com.ibm.db2.jcc.DB2Jcc -version
IBM DB2 Analytics Accelerator Minimum Level for Type 2 Connectivity Minimum Level for Type 4 Connectivity
IBM DB2 JDBC Universal Driver (db2jcc.jar) 3.63.141
for DB2 10 for z/OS
3.64.111
PM65007 for DB2 10 for z/OS
IBM Data Server Driver for JDBC and SQLJ (db2jcc4.jar) 4.13.145
PM65004 for DB2 10 for z/OS
4.14.119
PM65003 for DB2 10 for z/OS
IBM Data Server Driver for JDBC and SQLJ V10.1 Fix Pack 2 IP23387-IP23396
Depending on the platform. This is sometimes required if you need to specify Db2 for z/OS special registers as part of the connection URL.
 

Required ODBC driver level
Depending on your Linux, UNIX, or Windows operating system,the minimum level for DB2 Connect Version 10.5 is fix pack 4 and the minimum level for DB2 Connect Version 10.1 is fix pack 4. To enable the special registers for query acceleration,see Enabling query acceleration with IBM DB2 Analytics Accelerator for ODBC and JDBC applications without modifying the applications. Older versions of the driver might allow connections to Db2 for z/OS, but might fail to return results if timestamp columns are defined in a certain way.


Mandatory DB2-PTFs


Recommended DB2-PTFs

We recommend to have PUT-level 1609 installed for your Db2 environment. To determine all (DB2-)PTFs recommended for use with IBM DB2 Analytics Accelerator for z/OS V5.1.0, use the SMP/E REPORT MISSINGFIX command in conjunction with FIXCAT HOLDDATA as follows:

 

  1. Acquire and RECEIVE the latest HOLDDATA file onto your z/OS system. Use your normal service acquisition portal or download
    the two (2) year HOLDDATA files here: Enhanced HOLDDATA for z/OS.
    Ensure you select 'FULL' from the Download NOW column (last 730 days) to receive the FIXCAT HOLDDATA, as the other files do not contain FIXCAT HOLDDATA.
  2. Run the SMP/E REPORT MISSINGFIX command on your z/OS systems and specify Fix Category FIXCAT (IBM.DB2.AnalyticsAccelerator.V5R1) . The report will identify missing PTFs associated with that category on that system. For more information about the SMP/E REPORT MISSINGFIX command, see here.
  3. Periodically acquire the latest HOLDDATA file and rerun the REPORT MISSINGFIX command to determine if there are new recommended (DB2-)PTFs for IBM DB2 Analytics Accelerator for z/OS V5.1.0

Netezza database management software

Use the following certified Netezza Platform Software (NPS) version on your PureData System for Analytics as indicated in the following table. If more than one NPS version is certified, upgrade to the highest version.

 
IBM PureData System
for Analytics families
Applicable with
IBM DB2 Analytics Accelerator
for z/OS V5.1.0 maintenance level
NPS version
N1001
N2001
N2002
N3001
GA 7.2.1.0
PTF-1 7.2.1.0,
7.2.1.1
PTF-2 7.2.1.1,
7.2.1.2
PTF-3 7.2.1.2
PTF-4 7.2.1.2,
7.2.1.3-P3
PTF-5 7.2.1.3-P3, 7.2.1.4-P1
PTF-6 7.2.1.4-P1, 7.2.1.4-P3, 7.2.1.5-P1-IF1


Netezza Host Platform (HPF) and Netezza Firmware (FDT)

The table below shows the recommended versions of Netezza Host Platform (HPF) and Netezza Firmware (FDT) for your PureData System for Analytics. Recommended in this content means: these versions have been certified during development and test of IBM DB2 Analytics Accelerator Version 5.

The minimum versions of HPF and FDT supported are listed in the release notes of the specific NPS version. These can be found on Fix Central.

You can check the current HPF and FDT versions using IBM DB2 Analytics Accelerator Studio Version 4 or later. To display the current versions, open the About section in the Accelerator view. If an update is required, open a service request against IBM DB2 Analytics Accelerator.


 
Netezza Platform Software Netezza model Certified HPF versions Certified FDT versions
7.2.1.0
7.2.1.1
7.2.1.2
7.2.1.3-P3
7.2.1.4-P1
7.2.1.4-P3
7.2.1.5-P1-IF1
N1001
N2001
N2002
N3001
N3001-001
5.3
5.4
5.4.1
5.6.0.1 (recommended)
4.3.1.2
4.3.1.3 (recommended)

For download of HPF or FDT start on Fix Central. Proceed with 'Select product' and select 'Product Group' > Information Management,
'Select from Information Management' > IBM NetezzaPlatform, 'Installed Version' > {required HPF or FDT version}


Incremental update function

IBM InfoSphere Change Data Capture for z/OS (CDC) is included in the IBM DB2 Analytics Accelerator product package. Please find information about the recommended CDC PTFs here.

IBM DB2 Analytics Accelerator Studio

IBM DB2 Analytics Accelerator Studio is the graphical administration interface for the product and can be downloaded from:
IBM developerworks:
developerWorks/downloads/im/data
IBM Fix Central:
Information Management/DB2 Analytics Accelerator Studio
The Full Image for initial installation, including DataStudio, is available here:
DB2 Analytics Accelerator Studio Full Image

It consists of a set of Eclipse plug-ins that are added to IBM Data Studio V4.1, V4.1.0.1, V4.1.1, V4.1.2, or V4.1.3.
IBM DB2 Analytics Accelerator Studio (client) must be at the same or a higher interface level than the IBM DB2 Analytics Accelerator software (server). Upgrade the client first.

IBM DB2 Analytics Accelerator
for z/OS
V5.1.0 maintenance level
IBM DB2 Analytics Accelerator Studio (client) required minimum version
Refresh-Pack name as appearing
on Fix Central
Version string in About section
of IBM Data Studio
GA 5.1.0.0-Information Management-IDAA
Studio-Multiplatform-20151112-1939
5.1.0.0.201511121939
PTF-1 5.1.0.1-Information Management-IDAA
Studio-Multiplatform-20151211-1549
5.1.0.1.201512111549
PTF-2
PTF-3
5.1.0.2-Information Management-IDAA
Studio-Multiplatform-20160318-1327
5.1.0.2.201603181305
PTF-4 6.1.0.0-Information Management-IDAA
Studio-Multiplatform-20161111-0819
6.1.0.201611110815
PTF-5 6.1.0.3-Information Management-IDAA
Studio-Multiplatform-20170628-2249
6.1.3.201706282249
PTF-6 6.1.0.4-Information Management-IDAA
Studio-Multiplatform-20170901-1139
6.1.4.201709011133
 

The latest version of IBM DB2 Analytics Accelerator Studio, 7.1.4-Information_Management-IDAA_Studio-Multiplatform-20181015-2031 is recommended to be used with all versions of the accelerator server software. To download the corresponding IBM Installation Manager repository for upgrades use the following link: Fix Central
You can also add the plug-ins to an existing installation of IBM Data Studio or to products that are based on IBM Data Studio.
Recommendation: If you use IBM DB2 Analytics Accelerator Studio with an older version of IBM Data Studio, consider moving to IBM Data Studio 4.1.2.

The following versions are supported:

  1. IBM Data Studio 4.1
  2. IBM Data Studio 4.1.0.1
  3. IBM Data Studio 4.1.1
  4. IBM Data Studio 4.1.2
  5. IBM Data Studio 4.1.3 (only supported using DB2 Analytics Accelerator Studio 7.1.0.1)

The plug-ins and fixes for IBM DB2 Analytics Accelerator Studio are available from the following download sites:

  1. Installation Manager repository for IBM Data Studio: 4.1, 4.1.0.1, 4.1.1, 4.1.2, and 4.1.3
  2. Eclipse update site for IBM Data Studio: 4.1, 4.1.0.1, 4.1.1, 4.1.2, and 4.1.3

 

The upgrade of these products is described in the IBM DB2 Analytics Accelerator for z/OS Version 5.1.0 Installation Guide, chapter "Installing updates -> Updating IBM DB2 Analytics Accelerator Studio".

For silent installations, see Silent installation of IBM Installation Manager, IBM Data Studio and IBM DB2 Analytics Accelerator Studio on Windows.

Running IBM DB2 Analytics Accelerator Studio on Linux

IBM DB2 Analytics Accelerator Studio uses the Eclipse SWT Browser Control for a number of software update dialogs. To run IBM DB2 Analytics Accelerator Studio on Linux, you must therefore install a compatible version of Mozilla/XulRunner.

IBM Data Studio 4.1, IBM Data Studio 4.1.0.1, and IBM Data Studio 4.1.1 support:

Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.x and 3.6.x (but not 2.x), WebKitGTK+ 1.2.x

Read the Eclipse FAQ entry for Eclipse 4.2.2

IBM Data Studio 4.1.2 supports:

Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.x, 3.6.x, 10.x and 24.x (but not 2.x nor other unlisted versions), WebKitGTK+ 1.2.x and newer (Note: Eclipse 4.4 and newer uses GTK 3 by default and XULRunner cannot be used in this case as it is not ported to GTK 3 yet)

Read the Eclipse FAQ entry for Eclipse 4.4


In-database analytics

To exploit the new in-database analytics function, download IBM Netezza Analytics for System z from here.

IBM DB2 Analytics Accelerator for z/OS V5.1.0 maintenance level Required version of
in-database analytics
Required version of NPS
5.1.0 GA 3.2.1.0-IM-Netezza-ANALYTICS-IDAA-fp105780
(dwa-inza-3.2.1-20151217-2301)
7.2.1.0
5.1.0 PTF-1 3.2.1.0-IM-Netezza-ANALYTICS-IDAA-fp105780
(dwa-inza-3.2.1-20151217-2301)
7.2.1.0
or
7.2.1.1
5.1.0 PTF-2 3.2.2.0-IM-Netezza-ANALYTICS-IDAA-fp110852
(dwa-inza-3.2.2-20160404-0100)
7.2.1.1
or
7.2.1.2
5.1.0 PTF-3 3.2.2.0-IM-Netezza-ANALYTICS-IDAA-fp110852
(dwa-inza-3.2.2-20160414-0100)
7.2.1.2
5.1.0 PTF-4 3.2.4.0-IM-Netezza-ANALYTICS-IDAA-fp116948
(dwa-inza-3.2.4-20170128_0000)
7.2.1.3-P3
5.1.0 PTF-5 3.2.4.0-IM-Netezza-ANALYTICS-IDAA-fp116948
(dwa-inza-3.2.4-20170128_0000)
7.2.1.4-P1
5.1.0 PTF-6 3.2.4.0-IM-Netezza-ANALYTICS-IDAA-fp116948
(dwa-inza-3.2.4-20170128_0000)
7.2.1.4-P3
or
7.2.1.5-P1-IF1

Encryption of data in motion

Encryption of data in motion is a new optional feature. It is only supported for IBM PureData System for Analytics N2001, N2002, and N3001.
Before setting up encryption in motion, open a service request to get the libreswan module on your accelerator updated to version 3.23 or higher.

Product Required version Location
Red Hat Enterprise Linux (RHEL)
Note: the installation has to be done by IBM support
6.6 or higher IBM PureData System for Analytics
Host management
Note:
  • The installation has to be done by IBM support
  • The Host Management Kit includes the libreswan package
5.4.1.0 or higher IBM PureData System for Analytics
z/OS Communications Server 1.13 or higher z/OS

Prerequisites and Maintenance for IBM DB2 Analytics Accelerator for z/OS, V5.1

Migration scenarios

You can upgrade IBM DB2 Analytics Accelerator for z/OS as indicated in the following diagram.
For further information, refer to the IBM DB2 Analytics Accelerator for z/OS Version 5.1.0 Installation Guide.

 

Original Publication Date

2016-01-08

Product Alias/Synonym

IDAA

https://www-01.ibm.com/support/docview.wss?uid=swg27046305&myns=swgimgmt&mynp=OCSS4LQ8&mync=E&cm_sp=swgimgmt-_-OCSS4LQ8-_-E


#DataWarehouse
#IDAA
#PureDataSystemforAnalytics
#Netezza

Statistics

0 Favorited
3 Views
0 Files
0 Shares
0 Downloads