List of Contributions

John Rummell

Contact Details

My Content

1 to 5 of 5 total
Posted By John Rummell May 18, 2021 11:11 AM
Found In Egroup: Db2 Connect
\ view thread
That helps, although the FAQ answer could include more information. In order to set an environment variable in an Azure web app, you actually have to add an Application Setting under the Configuration tab. The following setting fixed this for me: Name: DB2_COMMON_APP_DATA_PATH Value: D:\home\site\ww ...
Posted By John Rummell May 12, 2021 3:04 PM
Found In Egroup: Db2 Connect
\ view thread
I'm getting the following error when opening a connection DB2Connection. I'm using IBM.Data.DB2.Core 3.1.0.400 in a netcoreapp3.1 web app in Azure. We finally figured out how to tunnel connections from a web app in Azure to an on-prem iSeries AS/400 server. Now I'm getting this. It works on my machine ...
Posted By John Rummell May 4, 2021 9:18 AM
Found In Egroup: Db2 Connect
\ view thread
Thanks, Hosathota! Do you have a timeline for the upcoming release? We're trying to move a number of scheduled tasks off of VMs and into Azure functions, and Db2 Connect is a big part of that plan. ------------------------------ John Rummell ------------------------------
Posted By John Rummell Apr 27, 2021 3:21 PM
Found In Egroup: Db2 Connect
\ view thread
I'm trying to use IBM.Data.DB2.Core.DB2Connection (3.1.0.400) in an azure function, but it's throwing an exception in the constructor when setting the connection string. This works fine outside of azure, but I get this error when testing locally with the azure functions runtime and in azure. How can ...
Posted By John Rummell Apr 27, 2021 3:21 PM
Found In Egroup: Db2 Connect
\ view thread
Have you tried using the x64 runtime in the webjobs web app? BadImageFormatException usually means a mismatch between the runtime and the assembly (x86 vs x64). ------------------------------ John Rummell ------------------------------