Topic Thread

Expand all | Collapse all

Logging performance metrics not showing values properly

  • 1.  Logging performance metrics not showing values properly

    Posted 15 days ago

    Hi DMC team

    First of all,  congratulation for the lates DMC 3.1.4 release...   The product is evolving nicely.  

    ------- 

    Under Monitoring -> IO ->  Logging Performance page..   The values for a few metrics are not being showed if the value is bellow 1.0   I guess.  

    • Average Log Write time (ms) 
    • Average log read time (ms) 
    • Average commit time(ms)

    The values are not real 0.00000   , they are something like 0.123,  or  o.0378     ,  but they are being shown as 0.000  , some bad formatting. 


    Regards and once again .. Congratulation for this new release ! 







    ------------------------------
    Samuel Pizarro
    ------------------------------



  • 2.  RE: Logging performance metrics not showing values properly

    Posted 13 days ago
    Hi Samuel,

    Thank you for your feedback and I am very honored to have your comment.

    The values of these three columns is working as design. The actual value of Average log write time(ms) is 0.1934.., it means about 0.19ms; But the smallest unit we show is ms, and the formatted display is h:m:s.ms, the '.' in 0.000 is a delimiter instead of a decimal point.  So this page works by design. 

    Still sorry that you have any doubts about it. We will discuss and optimize this.


    ------------------------------
    Rui Li
    ------------------------------



  • 3.  RE: Logging performance metrics not showing values properly

    Posted 13 days ago
    Edited by Samuel Pizarro 13 days ago

    hum... 

    well,   these metrics are IO latency..  (how long an  IO operation takes ) ,   Normally they are in ms, range..  so,  formatting a small value like this  with hours, minutes.  or even seconds..  seems too much in my opinion... 
    In most of the environments,  the value will be shown as zero, like mine..  if you ever have an IO taking 1min to respond back to the app..  everything else would be so slow,  that no one would need DMC to track these kind of issues..  hehehehe 

    Besides that.  the format used ,  conflicts with the unit shown in the column header..  

    The column header says..   Average Log Write time (ms) and it presents a value  in  X.yyy  format.   So everybody would expect that X is ms,  and yyy are decimals of that unit. 

    So,  formatting time  needs to take the expected range of values into consideration..  if the expected range of values are ms,   it does not makes any sense to format them in hours, minutes ... 

    If you don't want to make it hardcoded.  then try to use a smarter formatting, depending on the values..  In that case,  the unit must be shown as well.  if you use different units for different columns/rows. 

    Thanks

    ------------------------------
    Samuel Pizarro
    ------------------------------



  • 4.  RE: Logging performance metrics not showing values properly

    Posted 9 days ago
    Thank you for your comment and suggestion. Now we use this same formatting rule for all of our time values.

    We will discuss the optimization of time rules with other colleagues. And it would be great if you could open an RFE to track this request on the IBM Aha page :https://ibm-data-and-ai.ideas.aha.io/, other users can also vote on it.

    ------------------------------
    Rui Li
    ------------------------------



  • 5.  RE: Logging performance metrics not showing values properly

    Posted 8 days ago
    Hi Rui

    Here is the idea posted.. 

    https://hybridcloudunit-internal.ideas.aha.io/ideas/DSM-I-409 

    as I am IBMer,  the idea goes as private by default (Can only be seen/voted by other IBMers) . 
    I have no power to make it public.   :-(  I don't understand why.

    ------------------------------
    Samuel Pizarro
    ------------------------------



  • 6.  RE: Logging performance metrics not showing values properly

    Posted an hour ago
    Hi Samuel, I adjusted the visibility setting for the Idea. It should now be visible by all users. Can you please check?

    ------------------------------
    MARYIA RAKINA
    Db2 Product Manager
    IBM
    ------------------------------