Informix

nested-group-icon.png

DB2

Expand all | Collapse all

14.10.FC4W1 Windows installation problem

  • 1.  14.10.FC4W1 Windows installation problem

    Posted 15 days ago

    Any experience here with 14.10.FC4W1 on Windows - before I contact support.
    I have developer installation media (ofc) and I put e_edition.jar (express installer) file on the same media.
    After installation onstat -V shows IBM Informix Dynamic Server Version 14.10.FC4W1DE
    Next I modified PATH and set JAVA_HOME:
    set PATH=C:\Informix\jvm\jre\bin;%PATH%
    set JAVA_HOME=C:\Informix\jvm
    and I removed C:\Informix\etc\.ids_license
    Then I started java -jar e_edition.jar and license installation worked as usual
    onstat -V again IBM Informix Dynamic Server Version 14.10.FC4W1DE
    Again I removed .ids_install and I tried with innovator installer:
    java -jar ie_edition.jar - again installation finished as usual, but
    onstat -V again IBM Informix Dynamic Server Version 14.10.FC4W1DE
    Removed .ids_license and I tried with Enterprise installer (ee_install.jar) but the same result.

    Anybody using 14.10.FC4W1 on Windows (other that Developer :) )
    Hrvoje



    ------------------------------
    Hrvoje Zokovic
    ------------------------------


  • 2.  RE: 14.10.FC4W1 Windows installation problem

    Posted 14 days ago

    I tested 14.10.FC3 and it is working as expected.
    Installed without license file -> 14.10.FC3DE
    installed express license file -> 14.10.FC3E
    installed innovator license file -> 14.10.FC3IE
    installed enterprise license file -> 14.10.FC3

    I already opened PMR
    Hrvoje



    ------------------------------
    Hrvoje Zokovic
    ------------------------------



  • 3.  RE: 14.10.FC4W1 Windows installation problem

    Posted 12 days ago
    Hello Hrvoje,

    For this I have a PMR - TS004159305.
    The problem is a bug IT33566. But there is a simple workaround.

    I have seen the problem with new installations of 14.10.FC4W1 on Windows 2019 on 2 different machines.

    Please check the folder %INFORMIXDIR%/lib

    If you found a directory called libisi.dll.1
    Please delete this directory and copy the libisi_gsk.dll.1.2 to the name libisi.dll.1

    Then:

    onstat -V correctly shows your Edition.

    I hope this helps
    Andreas

    ------------------------------
    Andreas Seifert
    CURSOR Software AG
    http://www.admin-scout.com
    ------------------------------



  • 4.  RE: 14.10.FC4W1 Windows installation problem

    Posted 12 days ago

    Hi Andreas,
    thank you for your suggestion.
    I did this:
    - uninstalled everything
    - installed DEV ed
    - replace dir libisi.dll.1 with file libisi_gsk.dll.1.2 
    - installed express license
    and unfortunately onstat -V still shows DE
    I'll try to install express license with IDS and post here what happened.
    Regards
    Hrvoje



    ------------------------------
    Hrvoje Zokovic
    ------------------------------



  • 5.  RE: 14.10.FC4W1 Windows installation problem

    Posted 9 days ago
    Hi, Hrvoje
    I have exact the same problem
    I try install IDS with de express edition and te problem persist
    Didi you fina a solution?
    thanks

    ------------------------------
    Pablo Higuimaran
    ------------------------------



  • 6.  RE: 14.10.FC4W1 Windows installation problem

    Posted 9 days ago
    Hi, Hrvoje
    I have exact the same problem
    I try install IDS with de express edition and te problem persist
    Didi you fina a solution?
    thanks

    ------------------------------
    Pablo Higuimaran
    ------------------------------



  • 7.  RE: 14.10.FC4W1 Windows installation problem

    Posted 9 days ago
    Hi, Hrvoje
    I have exact the same problem
    I try install IDS with de express edition and te problem persist
    Didi you fina a solution?
    thanks

    ------------------------------
    Pablo Higuimaran
    ------------------------------



  • 8.  RE: 14.10.FC4W1 Windows installation problem

    Posted 9 days ago
    Hi Pablo,
    yes, JJ Ritson (IBM support) helped me. It is either Documentation or Installation defect.
    Workaround is: clean install (uninstall Informix and remove all files - or better on clean Win installation) and before installing Informix you have to modify PATH variable (it is better to modify for all users) and add:

    C:\Program Files\IBM\gsk8\bin
    C:\Program Files\IBM\gsk8\lib64

    After that run installation and it should work as expected.
    HTH
    Hrvoje



    ------------------------------
    Hrvoje Zokovic
    ------------------------------



  • 9.  RE: 14.10.FC4W1 Windows installation problem

    Posted 9 days ago
    thanks a lot!!!
    that did the trick
    i've been days trying to do that

    realy thanks
    ------ A/S Pablo Higuimar??n Jefe de IT Casarone Agroindustrial S.A.
    El 22/10/2020 a las 15:41, Hrvoje Zokovic via IBM Community escribi??:
    01000175519d5aa5-dcc5217f-fe7d-4c46-8597-6313891e4b43-000000@email.amazonses.com">
    Hi Pablo, yes, JJ Ritson (IBM support) helped me. It is either Documentation or Installation defect. Workaround is: clean install (uninstall... -posted to the "Informix" group
    IBM Community

    Informix

    Post New Message
    Re: 14.10.FC4W1 Windows installation problem
    Reply to Group Reply to Sender
    Hrvoje Zokovic
    Oct 22, 2020 2:39 PM
    Hrvoje Zokovic
    Hi Pablo,
    yes, JJ Ritson (IBM support) helped me. It is either Documentation or Installation defect.
    Workaround is: clean install (uninstall Informix and remove all files - or better on clean Win installation) and before installing Informix you have to modify PATH variable (it is better to modify for all users) and add:

    C:\Program Files\IBM\gsk8\bin
    C:\Program Files\IBM\gsk8\lib64

    After that run installation and it should work as expected.
    HTH
    Hrvoje



    ------------------------------
    Hrvoje Zokovic
    ------------------------------
    ?? Reply to Group Online ?? View Thread ?? Recommend ?? Forward ??




    ??
    You are receiving this notification because you followed the '14.10.FC4W1 Windows installation problem' message thread. If you do not wish to follow this, please click here.

    Update your email preferences to choose the types of email you receive

    Unsubscribe from all participation emails

    Cyber Security Awareness



    Original Message:
    Sent: 10/22/2020 2:39:00 PM
    From: Hrvoje Zokovic
    Subject: RE: 14.10.FC4W1 Windows installation problem

    Hi Pablo,
    yes, JJ Ritson (IBM support) helped me. It is either Documentation or Installation defect.
    Workaround is: clean install (uninstall Informix and remove all files - or better on clean Win installation) and before installing Informix you have to modify PATH variable (it is better to modify for all users) and add:

    C:\Program Files\IBM\gsk8\bin
    C:\Program Files\IBM\gsk8\lib64

    After that run installation and it should work as expected.
    HTH
    Hrvoje



    ------------------------------
    Hrvoje Zokovic
    ------------------------------

    Original Message:
    Sent: Thu October 22, 2020 09:41 AM
    From: Pablo Higuimaran
    Subject: 14.10.FC4W1 Windows installation problem

    Hi, Hrvoje
    I have exact the same problem
    I try install IDS with de express edition and te problem persist
    Didi you fina a solution?
    thanks

    ------------------------------
    Pablo Higuimaran

    Original Message:
    Sent: Mon October 19, 2020 08:28 AM
    From: Hrvoje Zokovic
    Subject: 14.10.FC4W1 Windows installation problem

    Hi Andreas,
    thank you for your suggestion.
    I did this:
    - uninstalled everything
    - installed DEV ed
    - replace dir libisi.dll.1 with file libisi_gsk.dll.1.2 
    - installed express license
    and unfortunately onstat -V still shows DE
    I'll try to install express license with IDS and post here what happened.
    Regards
    Hrvoje



    ------------------------------
    Hrvoje Zokovic

    Original Message:
    Sent: Mon October 19, 2020 04:11 AM
    From: Andreas Seifert
    Subject: 14.10.FC4W1 Windows installation problem

    Hello Hrvoje,

    For this I have a PMR - TS004159305.
    The problem is a bug IT33566. But there is a simple workaround.

    I have seen the problem with new installations of 14.10.FC4W1 on Windows 2019 on 2 different machines.

    Please check the folder %INFORMIXDIR%/lib

    If you found a directory called libisi.dll.1
    Please delete this directory and copy the libisi_gsk.dll.1.2 to the name libisi.dll.1

    Then:

    onstat -V correctly shows your Edition.

    I hope this helps
    Andreas

    ------------------------------
    Andreas Seifert
    CURSOR Software AG
    http://www.admin-scout.com

    Original Message:
    Sent: Fri October 16, 2020 12:46 PM
    From: Hrvoje Zokovic
    Subject: 14.10.FC4W1 Windows installation problem

    Any experience here with 14.10.FC4W1 on Windows - before I contact support.
    I have developer installation media (ofc) and I put e_edition.jar (express installer) file on the same media.
    After installation onstat -V shows IBM Informix Dynamic Server Version 14.10.FC4W1DE
    Next I modified PATH and set JAVA_HOME:
    set PATH=C:\Informix\jvm\jre\bin;%PATH%
    set JAVA_HOME=C:\Informix\jvm
    and I removed C:\Informix\etc\.ids_license
    Then I started java -jar e_edition.jar and license installation worked as usual
    onstat -V again IBM Informix Dynamic Server Version 14.10.FC4W1DE
    Again I removed .ids_install and I tried with innovator installer:
    java -jar ie_edition.jar - again installation finished as usual, but
    onstat -V again IBM Informix Dynamic Server Version 14.10.FC4W1DE
    Removed .ids_license and I tried with Enterprise installer (ee_install.jar) but the same result.

    Anybody using 14.10.FC4W1 on Windows (other that Developer :) )
    Hrvoje



    ------------------------------
    Hrvoje Zokovic
    ------------------------------