IBM Db2 Data Management Console

nested-group-icon.png

DB2

Expand all | Collapse all

Custom Alerts not firering

  • 1.  Custom Alerts not firering

    Posted Tue December 01, 2020 12:00 PM

    DMC 3.1.3

    I have created and scheduled a new "Custom Alert"  on DMC.  everything seems ok when setting it up, no errors are reported. 

    I have created it yesterday,  and It was supposed to be executed today but there is no execution shown in the History view. 


    No error is reported anywhere in the console. 

    What is missing?  

    Regards
       


    ------------------------------
    Samuel Pizarro
    ------------------------------


  • 2.  RE: Custom Alerts not firering

    Posted Wed December 02, 2020 04:48 PM
    Hello Samuel,

    From the second picture.  It looks like the SQL script has started on Monday, November 20, 2020 12:05 PM.  But it does not have any output.  Do you know if the SQL is running for long time?  

    It is good if you can open case and we can see the SQL that you used in the custom alert.  Thanks.

    ------------------------------
    Jason Sizto
    ------------------------------



  • 3.  RE: Custom Alerts not firering

    Posted Thu December 03, 2020 07:12 AM

    Hi @Jason Sizto

    I believe you miss understood the picture.

    The Start there (Monday Nov 20th) is the schedule start...  It should have been the 1st scheduled execution.

    It's not telling the start of a particular execution job.  As you can see, in the same picture,  the history execution grid bellow is totally empty. 



    ------------------------------
    Samuel Pizarro
    ------------------------------



  • 4.  RE: Custom Alerts not firering

    Posted 15 days ago
    Hi Folks!

    I got a similar problem. After defining and saving the custom alert there comes a message up that it is saved.
    But when I recall the custom alert panel, there is no entry.
    before saving

    and after saving it

    Message after saving custom alertand then calling the custom alert panel again


    any ideas?

    regards
    Joerg




    ------------------------------
    Jörg Burdorf
    ------------------------------



  • 5.  RE: Custom Alerts not firering

    Posted 11 days ago
    Hi Jorg Burdorf - Thanks for your message. Once you define a Custom alert and save it by clicking on FINISH, you are supposed to save the Monitoring Profile too. Could you please confirm that you saved the Monitoring Profile too along with the Custom alert? Thanks.

    ------------------------------
    Abhinandan Kelgere Ramesh
    ------------------------------



  • 6.  RE: Custom Alerts not firering

    Posted 10 days ago
    Hi Abhinandan Kelgere Ramesh !

    Yes, I push the Save Button for the Profile.

    regards
    Joerg


    ------------------------------
    Jörg Burdorf
    ------------------------------



  • 7.  RE: Custom Alerts not firering

    Posted 10 days ago
    Hi Joerg,

    Thanks for the response. I have a couple of more questions.

    Do you still see the issue where you cannot define and save a custom alert?  Saving and scheduling the Custom alert is internally dependent on Job Scheduler. So the job scheduler could have been temporarily offline at that moment and hence you were not able to save the custom alert.

    If you still the issue where you cannot define a custom alert, could you please confirm if the Job Scheduler is up and running by clicking on the Jobs tab and scheduling a Job to run? Thanks.

    ------------------------------
    Abhinandan Kelgere Ramesh
    ------------------------------



  • 8.  RE: Custom Alerts not firering

    Posted 9 days ago
    Hi!

    When I click the Job button I get the following error message:

    SQLDriverConnect: { } [IBM][CLI Driver] SQL5005C The operation failed because the database manager failed to access either the database manager configuration file or the database configuration file. {08001} [IBM][CLI Driver] SQL30082N Security processing failed with reason "17" ("UNSUPPORTED FUNCTION"). SQLSTATE=08001

    Any idea what went wrong?

    regards
    Joerg

    ------------------------------
    Jörg Burdorf
    ------------------------------



  • 9.  RE: Custom Alerts not firering

    Posted 8 days ago
    Hi Folks!

    I detected a Service running on my Windows server who hosts the DMC Service called job-server´.exe. This service runs
    under the userid that starts the DMC on this server.

    This userid has no connect rigth and is not conform to the Db2 User Naming conventions. Maybe this is the problem that causes the error message
    described above.

    regards
    Joerg

    ------------------------------
    Jörg Burdorf
    ------------------------------



  • 10.  RE: Custom Alerts not firering

    Posted 8 days ago
    Hi Joerg,

    For the error: SQL30082N Security processing failed with reason "17" ("UNSUPPORTED FUNCTION"). SQLSTATE=08001

    Are you using the SSL connection in DMC repository?  If so, you need to add parameter: SSLServerCertificate to point to the Db2 cert in metadb_override.properties file.  More details can be found here: https://www.ibm.com/support/knowledgecenter/en/SS5Q8A_3.1.x/com.ibm.datatools.dsweb.ots.troubleshooting.doc/topics/job_ssl.html

    If your repository db2 uses encrypted AUTHENTICATION , e.g. SERVER_ENCRYPT, please also change the Security type in repository profile to match the Db2 AUTHENTICATION setting, e.g. Encrypted user and password.  (Restart DMC afterwards)

    Thank you for sharing the tip on connect privilege for user who starts DMC.  Please let us know if you can resolve the connection issue for UDA / Jobs.  


    ------------------------------
    Jason Sizto
    ------------------------------



  • 11.  RE: Custom Alerts not firering

    Posted 3 days ago
    Hi Jason!

    Thank's a lot!

    After looking in the Job Sceduler Logfile I see that the connect was performed with authentication server. But we need authentication server_encrypt.

    So I changed the security mechanism for the repository database. The question is now, why do the connection for monitoring their work but not the Job Sceduler? Answer : when no authentication parameter is set, the default is server_encrypt. So I think that the connection to the databases that will be monitored is without that parameter and the Jobsceduler uses this parmeter.

    But now it's up and running and the custom alert are fiering!

    regards
    Joerg

    ------------------------------
    Jörg Burdorf
    ------------------------------



  • 12.  RE: Custom Alerts not firering

    Posted 3 days ago
    Hi Joerg,

    Thank you for confirming that the job scheduler can work after matching the security type for repository connection profile with server_encrypt.  We will follow up and check any optimization can be made to avoid this issue.

    ------------------------------
    Jason Sizto
    ------------------------------