Informix

 View Only
Expand all | Collapse all

Replication of Informix

  • 1.  Replication of Informix

    Posted Fri September 30, 2022 09:22 AM
    Hi Team,

    I am setting up HA for Informix. I am getting issue with trusting both Primary + Secondary Servers.

    The errors are as follow:

    Primary
    DR: new type = primary, secondary server name = labsoc
    DR: Cannot connect to secondary server
    DR: Turned off on primary server

    Secondary
    DR: new type = secondary, primary server name = ol_norwayso
    DR: Trying to connect to primary server = ol_norwaysoc
    DR: Cannot connect to primary server
    DR: Turned off on secondary server

    I tried both the /etc/hosts.equiv and REMOTE_SERVER_CFG in the onconfig file but they are not working.

    Telnet is working

    $ telnet 192.168.1.61 16001
    Trying...
    Connected to 192.168.1.61.
    Escape character is '^]'.

    The new primary server is online however the new secondary is still on -- Fast Recovery (Sec) -- Up.

    Kindly share your inputs.

    Thanks
    Regards
    Khemraj


    ------------------------------
    koonjul khemraj
    ------------------------------


  • 2.  RE: Replication of Informix

    IBM Champion
    Posted Fri September 30, 2022 09:25 AM
    Please post your SQLHOSTS settings from both servers' hosts for both servers.

    Art

    ------------------------------
    Art S. Kagel, President and Principal Consultant
    ASK Database Management Corp.
    www.askdbmgt.com
    ------------------------------



  • 3.  RE: Replication of Informix

    Posted Fri September 30, 2022 10:01 AM
    Hi Art,

    The SQLHOSTS details are:-

    PRIMARY
    lab onipcshm AIXSANTO 16000
    labsoc onsoctcp AIXSANTO sqlexec

    #HDR Server
    ol_norwaysoc onsoctcp tiger4S sqlexec


    SECONDARY
    ol_norway onipcshm tiger4S 16000
    ol_norwaysoc onsoctcp tiger4S sqlexec

    #HDR Server
    labsoc onsoctcp AIXSANTO sqlexec


    SERVICES
    sqlexec 16001/tcp #HDR

    hosts.equiv
    + informix

    HDRtrust
    ##Trusted Host ##Trusted User
    AIXSANTO informix
    tiger4S informix

    I put some additional configs above.

    Thanks
    Khemraj

    ------------------------------
    koonjul khemraj
    ------------------------------



  • 4.  RE: Replication of Informix

    InnerCircle
    Posted Fri September 30, 2022 10:19 AM
    Not seeing any sign for a trust problem being in your way - how would you know it's about trust?

    You might be confusing primary and secondary, or which command to run where ...

    Apparently you're running 'onmode -d primary labsoc'  on one side - which one?
    And 'onmode -d secondary ol_norwayso[c?]' on the other side?

    But your sqlhosts details seem to indicate labsoc is your primary and ol_norwaysoc the secondary.

    So the commands should be:
    • on AIXSANTO (primary box):   onmode -d primary ol_norwaysoc
    • on tiger4s (secondary box): onmode -d secondary labsoc
    The names you provide in these commands should be the opposite side's Informix server.

    Does this help?

     Andreas

    ------------------------------
    Andreas Legner
    ------------------------------



  • 5.  RE: Replication of Informix

    IBM Champion
    Posted Fri September 30, 2022 12:13 PM
    OK, in the SQLHOSTS the comments say that labsoc is the primary and ol_norwaysoc is the HDR secondary, however, the error messages on the primary say that it thinks that the secondary is labsoc and the primary is ol_norwaysoc. Which is correct?

    If the SQLHOSTS entries are correct then you onmode -d commands are backwards!

    On the primary you should be running:

    onmode -d primary ol_norwaysoc

    And on the secondary it should be:

    onmode -d secondary labsoc

    You have to tell the primary that it is primary to what secondary and on the secondary you have to tell it the name of the primary.

    Art

    ------------------------------
    Art S. Kagel, President and Principal Consultant
    ASK Database Management Corp.
    www.askdbmgt.com
    ------------------------------



  • 6.  RE: Replication of Informix

    Posted Mon October 03, 2022 06:30 AM
    Thanks Andreas/Art,

    I have tested the below commands as requested, but both servers cannot connect.

    PRIMARY - AIXSANTO
    onmode -d primary ol_norwaysoc

    -- On-Line (Prim)

    Log_Primary
    DR: Primary to Primary
    DR: new type = primary, secondary server name = ol_norwaysoc
    DR: Cannot connect to secondary server


    SECONDARY - tiger4S
    onmode -d secondary labsoc

    -- Fast Recovery (Sec)

    Log_Secondary
    DR: Secondary to Secondary
    DR: new type = secondary, primary server name = labsoc
    DR: Trying to connect to primary server = labsoc
    DR: Cannot connect to primary server

    The replication is not working automatically.




    ------------------------------
    koonjul khemraj
    ------------------------------