IBM webMethods Hybrid Integration

IBM webMethods Hybrid Integration

Join this online group to communicate across IBM product users and experts by sharing advice and best practices with peers and staying up to date regarding product enhancements.



#Automation


#Applicationintegration
#webMethods
#Integration
 View Only
  • 1.  Which OS parameter limits XML work threads?

    Posted 01/17/05 04:02 PM

    Hello,

    I am not able to increase the XML work threads parameter for one Tamino database. What happens is the following: since XML work threads is not a dynamic property, database needs a restart after modifying its original value but the restart fails with the following error message:

    1. Insufficient system resources to create thread: error returned by thread create function

    2. Internal error: location xthini.cpp SMP_THRCREATE. Server stopped.

    So before I can change the XWT, I need to change some other parameter in my OS. Does anyone know which one is that parameter.

    My OS: Redhat Advanced Server 2.1
    Tamino Version: 4.2.1.5

    By the way, what is the optimal value for XWT on a very bulky database with high query loads involving several join operations (but few users)?

    Thanks and regards,
    Gopal.

    [This message was edited by Gopal on 17 January 2005 at 15:40.]


    #Tamino
    #API-Management
    #webMethods


  • 2.  RE: Which OS parameter limits XML work threads?

    Posted 01/28/05 01:21 PM

    Hello Gopal,

    I never heard from this error before.
    Could you please contact your Software AG Customer Support Center for further assistance.

    Thanks and kind regards,

    Thomas


    #API-Management
    #Tamino
    #webMethods


  • 3.  RE: Which OS parameter limits XML work threads?

    Posted 02/24/05 05:20 PM

    Hi,

    the maximum number of threads can be found in
    /proc/sys/kernel/threads-max and can be changed there or in
    /etc/sysctl.conf

    Parameters such as stacksize and max user processes can be changed via ulimit. That would have to be done in the start scripts for the System Management Hub demons

    For more information see

    man bash


    #API-Management
    #webMethods
    #Tamino