Informix

Informix

Connect with Db2, Informix, Netezza, open source, and other data experts to gain value from your data, share insights, and solve problems.

 View Only
  • 1.  Errors found in tcb queue.

    Posted 03/09/20 02:41 PM
    Hi Folks.

    This looks like corruption in the internal tcb structures:
    $ onstat -g bth

    IBM Informix Dynamic Server Version 12.10.FC12 -- On-Line (Prim) -- Up 5 days 07:57:11 -- 186675748 Kbytes

    This command attempts to identify any blocking threads.
    Errors found in tcb queue.
    May be caused by changing data structures.

    What does even mean?  If some internal queue or structure is corrupt does that mean a crash is imminent?  Well, if it is, it's been imminent for about 4 hours already.  So I don't think anything serious is about to happen but it does kinda get in the way of a writing a new scripts (w/o SQL anyway.)

    How would I go about investigating the cause of this message?

    Thanks.

    ------------------------------
    Jacob Salomon
    ---
    Nobody goes there anymore, it's too crowded.  --Attr: Yogi Berra
    ------------------------------

    #Informix


  • 2.  RE: Errors found in tcb queue.

    Posted 03/09/20 03:15 PM
    Jacob:

    The important part of the message is the note that the error "May be caused by changing data structures." It most likely means that the memory structures were changing too quickly for onstat to follow the memory link change before it changes causing the search to go off into Never-Never land or begin to cycle because of sessions joining and exiting.

    Try again at a quieter time is the usual solution, though in this case, since you are attempting to track a live session, that's not practical. You could just try again and hope to get the report completed before the structures change too much.

    Art

    Art S. Kagel, President and Principal Consultant
    ASK Database Management


    Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference.  Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves.





    ------Original Message------

    Hi Folks.

    This looks like corruption in the internal tcb structures:
    $ onstat -g bth

    IBM Informix Dynamic Server Version 12.10.FC12 -- On-Line (Prim) -- Up 5 days 07:57:11 -- 186675748 Kbytes

    This command attempts to identify any blocking threads.
    Errors found in tcb queue.
    May be caused by changing data structures.

    What does even mean?  If some internal queue or structure is corrupt does that mean a crash is imminent?  Well, if it is, it's been imminent for about 4 hours already.  So I don't think anything serious is about to happen but it does kinda get in the way of a writing a new scripts (w/o SQL anyway.)

    How would I go about investigating the cause of this message?

    Thanks.

    ------------------------------
    Jacob Salomon
    ---
    Nobody goes there anymore, it's too crowded.  --Attr: Yogi Berra
    ------------------------------

    #Informix


  • 3.  RE: Errors found in tcb queue.

    Posted 03/09/20 04:38 PM
    Art and Paul.

    Thanks for the reassurance that the structures are [probably] not corrupted.  I suppose a more reassuring message might be helpful, like "Structures changing to rapidly to obtain a consistent result".  But this will have to do for now.

    Thanks!

    ------------------------------
    Jacob Salomon
    ---
    Nobody goes there anymore, it's too crowded.  --Attr: Yogi Berra
    ------------------------------



  • 4.  RE: Errors found in tcb queue.

    Posted 03/09/20 03:20 PM
    changing data structures is (probably) the key. Try again but on a very
    busy system you might still get it.

    Try hanging the engine and grabbing an onstat -o AFAIK a hung system
    shouldn't see these, but in prod ........


    > Hi Folks.
    >
    > This looks like corruption in the internal tcb structures:
    > $ onstat -g bth
    >
    > IBM Informix Dynamic Server Version 12.10.FC12 -- On-Line (Prim) -- Up 5
    > days 07:57:11 -- 186675748 Kbytes
    >
    > This command attempts to identify any blocking threads.
    > Errors found in tcb queue.
    > May be caused by changing data structures.
    >
    > What does even mean? If some internal queue or structure is corrupt does
    > that mean a crash is imminent? Well, if it is, it's been imminent for
    > about 4 hours already. So I don't think anything serious is about to
    > happen but it does kinda get in the way of a writing a new scripts (w/o
    > SQL anyway.)
    >
    > How would I go about investigating the cause of this message?
    >
    > Thanks.
    >
    > ------------------------------
    > Jacob Salomon
    > ---
    > Nobody goes there anymore, it's too crowded. --Attr: Yogi Berra
    > ------------------------------
    >
    >
    > Reply to Sender :
    > https://community.ibm.com/eGroups/PostReply/?GroupId=4147&SenderKey=f6230cfe-c95a-4ecb-be81-fe5ee54380ae&MID=46215&MDATE=757545845%253e&UserKey=29a6c229-a98c-46da-9248-4df042a4a263&sKey=KeyRemoved
    >
    > Reply to Discussion :
    > https://community.ibm.com/eGroups/PostReply/?GroupId=4147&MID=46215&MDATE=757545845%253e&UserKey=29a6c229-a98c-46da-9248-4df042a4a263&sKey=KeyRemoved
    >
    >
    >
    > You are subscribed to "Informix" as paul@oninit.com. To change your
    > subscriptions, go to
    > http://community.ibm.com/community/user/preferences?section=Subscriptions&MDATE=757545845%253e&UserKey=29a6c229-a98c-46da-9248-4df042a4a263&sKey=KeyRemoved.
    > To unsubscribe from this community discussion, go to
    > http://community.ibm.com/HigherLogic/eGroups/Unsubscribe.aspx?UserKey=29a6c229-a98c-46da-9248-4df042a4a263&sKey=KeyRemoved&GroupKey=60eb97a2-57c0-4130-9b6d-57174f97d5a8.


    --
    Paul Watson
    Tel: +1 913-674-0360
    Mob: +1 913-387-7529
    Web: www.oninit.com

    Oninit? is a registered trademark of Oninit LLC

    Failure is not as frightening as regret.
    If you want to improve, be content to be thought foolish and stupid.
    What this country needs are more unemployed politicians

    ------Original Message------

    Hi Folks.

    This looks like corruption in the internal tcb structures:
    $ onstat -g bth

    IBM Informix Dynamic Server Version 12.10.FC12 -- On-Line (Prim) -- Up 5 days 07:57:11 -- 186675748 Kbytes

    This command attempts to identify any blocking threads.
    Errors found in tcb queue.
    May be caused by changing data structures.

    What does even mean?  If some internal queue or structure is corrupt does that mean a crash is imminent?  Well, if it is, it's been imminent for about 4 hours already.  So I don't think anything serious is about to happen but it does kinda get in the way of a writing a new scripts (w/o SQL anyway.)

    How would I go about investigating the cause of this message?

    Thanks.

    ------------------------------
    Jacob Salomon
    ---
    Nobody goes there anymore, it's too crowded.  --Attr: Yogi Berra
    ------------------------------

    #Informix