Cloud Pak for Data

 View Only
Expand all | Collapse all

Watson Machine Learning Model Deployment (Creation) Failed

  • 1.  Watson Machine Learning Model Deployment (Creation) Failed

    Posted Tue November 30, 2021 04:06 PM

    Hi, we upgraded from CP4D 3.5 to 4.0. The notebook that used to work in CP4D 3.5 with python 3.7 legacy is failing now. The model building was successful, but deployment failed. It uses XGBClassifier and sklearn, and the model was built successfully with python 3.7. Can you please tell me how to fix the issue?



    ------------------------------
    Yichong Yu
    IBM
    ------------------------------


  • 2.  RE: Watson Machine Learning Model Deployment (Creation) Failed

    Posted Thu December 02, 2021 08:48 AM

    Hello Yichong - Please review the information in this topic: https://www.ibm.com/docs/en/cloud-paks/cp-data/4.0?topic=assets-updating-following-upgrade and see if that addresses the upgrade problem you are experiencing.



    ------------------------------
    Julianne Forgo
    ------------------------------



  • 3.  RE: Watson Machine Learning Model Deployment (Creation) Failed

    Posted Wed December 08, 2021 10:04 AM
    One of my coworker tried in his CP4D environment and it worked for him. He exported his project and I imported it, but it failed for me again. We have same version of CP4D (4.0.2), same environment (Larger Python 3.8), it showed the following error message without much information regarding the root cause. How can I find out more information about the failure? Is there WML log somewhere I can check? Can I direct CP4D/WML log to my logDNA?
    WMLClientError: Deployment creation failed for deployment id: 175fb73b-cae8-4653-8406-1d8d3a4bc27e. Error: failed


    ------------------------------
    Yichong Yu
    IBM
    ------------------------------