Cloud Pak for Data

Expand all | Collapse all

installing Cloudpak for Data 2.5 failed

  • 1.  installing Cloudpak for Data 2.5 failed

    Posted 10 days ago
    During the "Setting up your Cloud Pak for Data environment"  procedure of the installation of ICP4D version 2.5 I get an error:

    ./bin/cpd-linux adm --repo repo.yaml --assembly lite --namespace icp4d

    [INFO] [2019-11-26 11:34:35-0735] Arch override not found. Assuming default architecture x86_64

    [INFO] [2019-11-26 11:34:35-0739] Parsing custom YAML file repo.yaml

    [INFO] [2019-11-26 11:34:35-0740] Overwritten default download settings using repo.yaml

    [INFO] [2019-11-26 11:34:35-0741] 1 file servers and 1 registries detected from current configuration.

    [INFO] [2019-11-26 11:34:35-0743] Server configure files validated

     

    *** Validating assembly version on all fileservers ***

     

    [ERROR] [2019-11-26 11:34:36-0389] Unable to retrieve assembly version file from all servers, exiting

    [ERROR] [2019-11-26 11:34:36-0390] Exiting due to error. Please check /root/cpd/bin/cpd-linux-workspace/Logs/CPD-2019-11-26T11-34-35.log for details


    Looking in the detail log:

    cat /root/cpd/bin/cpd-linux-workspace/Logs/CPD-2019-11-26T11-34-35.log
    CPD Install Log[INFO] [2019-11-26 11:34:35-0734] Arch override not found. Assuming default architecture x86_64
    [v] [2019-11-26 11:34:35-0735] Path is verified: /root/cpd/bin/cpd-linux-workspace
    [v] [2019-11-26 11:34:35-0737] {CustomYaml:repo.yaml ClusterRegistry:{Mode:0 PullPrefix: PullUsername: PullKey: PushPrefix: PushUsername: PushKey: PushCert:} assembly:{assembly:lite version: arch:x86_64 downloadPath:/root/cpd/bin/cpd-linux-workspace namespace:icp4d StorageClass: loadPath:} verbose:false admApplyRun:false askPushRegistryPassword:false askPullRegistryPassword:false chartOnly:false transferImage:false insecureTLS:false cpdinstallImage:cpdoperator:v2.5.0.0-29 cpdinitImage:cpd-operator-init:v1 tillerImage:cp4d-tiller:v2.14.3 baseRegistry:base-registry globalOverridePath: fileServerCert: monochrome:false silentInstall:false uninstallDryRun:false scaleSize: platform:oc}

    [INFO] [2019-11-26 11:34:35-0738] Parsing custom YAML file repo.yaml
    [INFO] [2019-11-26 11:34:35-0739] Overwritten default download settings using repo.yaml
    [INFO] [2019-11-26 11:34:35-0740] 1 file servers and 1 registries detected from current configuration.
    [v] [2019-11-26 11:34:35-0741] Sensored config: {Registries:[{Name: Postfix: URL: Username: Cred:********}] Fileservers:[{URL:https://ibm-open-platform.ibm.com/cpd Key:********}]}
    [INFO] [2019-11-26 11:34:35-0742] Server configure files validated

    *** Validating assembly version on all fileservers ***

    [v] [2019-11-26 11:34:35-0744] The directory /root/cpd/bin/cpd-linux-workspace/assembly/lite/x86_64 does not exist, creating ...
    [v] [2019-11-26 11:34:35-0745] Obtaining assembly version information from server https://ibm-open-platform.ibm.com/cpd
    [v] [2019-11-26 11:34:35-0747] Downloading from: https://ibm-open-platform.ibm.com/cpd/assembly/lite/x86_64/versions.yaml
    [v] [2019-11-26 11:34:35-0748] Downloading to: /root/cpd/bin/cpd-linux-workspace/assembly/lite/x86_64/versions.yaml
    [v] [2019-11-26 11:34:35-0749] Downloading https://ibm-open-platform.ibm.com/cpd/assembly/lite/x86_64/versions.yaml ...
    [v] [2019-11-26 11:34:36-0385] Received error during download of file /root/cpd/bin/cpd-linux-workspace/assembly/lite/x86_64/versions.yaml from https://ibm-open-platform.ibm.com/cpd/assembly/lite/x86_64/versions.yaml- server returned 404 Not Found
    [v] [2019-11-26 11:34:36-0387] Version file for assembly lite failed to download on https://ibm-open-platform.ibm.com/cpd. Skipping
    [ERROR] [2019-11-26 11:34:36-0388] Unable to retrieve assembly version file from all servers, exiting
    [ERROR] [2019-11-26 11:34:36-0389] Exiting due to error. Please check /root/cpd/bin/cpd-linux-workspace/Logs/CPD-2019-11-26T11-34-35.log for details
    It looks like the software isn't available at https://ibm-open-platform.ibm.com/cpd/assembly/lite/x86_64

    has anybody seen this behaviour before?



    ------------------------------
    Joris Weijters
    ------------------------------


  • 2.  RE: installing Cloudpak for Data 2.5 failed

    Posted 9 days ago
    Where did you get the repo.yaml from?
    Do you have a working nfs server in the cluster?
    Is it internal IBM or external deployment?

    https://www.ibm.com/support/knowledgecenter/en/SSQNUZ_2.5.0/cpd/install/installation-files.html
    http://158.85.173.111/repos/zen/cp4d-builds/2.5.0.0/production/installer/63/cpd-linux
    https://ibm-open-platform.ibm.com/repos/beta/cpd/2.5.0/BETA%20-%20Installing%20IBM%20Cloud%20Pak%20for%20Data%202.5.pdf

    ------------------------------
    ADAM NOWOTARSKI
    ------------------------------



  • 3.  RE: installing Cloudpak for Data 2.5 failed

    Posted 9 days ago
    Hi,

    To start with your last question, this is an external deployment, I am working at a business partner. I want to start a POC with the ICP4D at an on-premises Openshift platform.
    I do have an NFS server in the same VLAN as the Openshift cluster.  I implemented this server as described in the kubernetes documentation where the CP4D install documentation is pointing at.

    The repo.yaml came from the tarball: cloudpak4data-cne-v2.5.0.0.tgz
    # tar tvf cloudpak4data-cne-v2.5.0.0.tgz |grep repo
    -rw-r--r-- root/root 124 2019-11-22 20:52 repo.yaml

    # tar xvf cloudpak4data-cne-v2.5.0.0.tgz |grep repo
    repo.yaml
    [root@rhocp-master cpd]# cat repo.yaml
    registry:
    - url: cp.icr.io/cp
    username: cp
    apikey:
    fileservers:
    - url: https://ibm-open-platform.ibm.com/cpd


    Kind regards,

    Joris Weijters





    ------------------------------
    Joris Weijters
    ------------------------------



  • 4.  RE: installing Cloudpak for Data 2.5 failed

    Posted 9 days ago
    Customers need to get the entitlement license API key from My IBM as per knowledge center:
    https://www.ibm.com/support/knowledgecenter/en/SSQNUZ_2.5.0/cpd/install/installation-files.html


    ------------------------------
    ADAM NOWOTARSKI
    ------------------------------



  • 5.  RE: installing Cloudpak for Data 2.5 failed

    Posted 9 days ago
    Hi  have a key at https://myibm.ibm.com/dashboard/
    --> container software library
    --> IBM SOFTWARE ACCESS 1 YEAR 
    is this the correct one?

    Kind regards,

    Joris Weijters

    ------------------------------
    Joris Weijters
    ------------------------------



  • 6.  RE: installing Cloudpak for Data 2.5 failed

    Posted 9 days ago
    The internal repo.yaml does have a key
    http://icpfs1.svl.ibm.com/zen/cp4d-builds/2.5.0.0/production/internal/repo.yaml

    ------------------------------
    ADAM NOWOTARSKI
    ------------------------------



  • 7.  RE: installing Cloudpak for Data 2.5 failed

    Posted 18 hours ago
    I succeeded installing Cloud Pak 4 Data.
    The community edition I downloaded, contains another repo URL than then the Cloud Pak 4 Data Enterprise edition.

    - url: https://raw.github.com/IBM/cloud-pak/master/repo/cpd



    ------------------------------
    Joris Weijters
    ------------------------------