Cloud Pak for Data Group

Expand all | Collapse all

Unable to install CP4D 3.0.1 through web client

  • 1.  Unable to install CP4D 3.0.1 through web client

    Posted Tue July 07, 2020 11:03 PM
    When I am trying to install Cloud pak for data v3.0.1 on the Redhat OpenShift Cluster v4.3.23_1527, I am getting an authentication error. I tried installing CP4D v2.5.0 on the Redhat OpenShift Cluster v3.11.219_1554 in the same manner and it works. Has there been any change in the procedure for installing CP4D on the Redhat OpenShift Cluster using web client. I am attaching the error log below. Kindly help me out . Thanks!
    2020/07/07 23:21:18 Terraform apply | null_resource.script (local-exec): [ERROR] [2020-07-07 23:21:10-0458] Error verifying current oauth token - Error from server (NotFound): oauthaccesstokens.oauth.openshift.io "eyJhbGciOiJSUzI1NiIsImtpZCI6InBLVl95TDQwa2g0TURVVjQtZWwtclQzSnFReUJMQVJTX2tQWFk2bTdXQTAifQ.eyJpc3MiOiJrdWJlcm5ldGVzL3NlcnZpY2VhY2NvdW50Iiwia3ViZXJuZXRlcy5pby9zZXJ2aWNlYWNjb3VudC9uYW1lc3BhY2UiOiJ3b3Jrc2hvcC1hc3NldHMiLCJrdWJlcm5ldGVzLmlvL3NlcnZpY2VhY2NvdW50L3NlY3JldC5uYW1lIjoiY3BkaW5zdGFsbC10b2tlbi05d2d0bSIsImt1YmVybmV0ZXMuaW8vc2VydmljZWFjY291bnQvc2VydmljZS1hY2NvdW50Lm5hbWUiOiJjcGRpbnN0YWxsIiwia3ViZXJuZXRlcy5pby9zZXJ2aWNlYWNjb3VudC9zZXJ2aWNlLWFjY291bnQudWlkIjoiOGI2NTQwNjAtZWJjNy00MGY3LTgzMmEtNTAyYmIzOGQ3MTNmIiwic3ViIjoic3lzdGVtOnNlcnZpY2VhY2NvdW50OndvcmtzaG9wLWFzc2V0czpjcGRpbnN0YWxsIn0.bM-rC0w1tr__KzmSET7bPJcLRI6dqCxvFe2Ru7yKSw6Gv4ebwmoHUQJYwJkrfADFcbu468J4p6JA5v6laNNk5C0WmGMeRqP1m7fFZVa9TCjK_4Hr20b_hAUvMTksScUDvGqeDfOfUcUc4YYClCttGLNurjpaf-PZj0w3TO7OoLBqsquCrmzbNDyKxuhkln0nH0eMejYonRTwSrkWjEEh6S6Wm9sqAOinJUAHuFIirG7tHoYYpAiFP11cum81NVeCjuSuVVXC_X-dG-uJ6rSTT3wTUtbsqNNR4TqFc3Afut8-J6G_l3wzrqQV8NlSnGYXffj1hoXTqvzAiKbPAaykQQ" not found
     2020/07/07 23:21:18 Terraform apply | 
     2020/07/07 23:21:18 Terraform apply | null_resource.script (local-exec): [INFO] [2020-07-07 23:21:10-0459] cpd cannot verify token expiry time due to above error.​


    ------------------------------
    Shivam Solanki
    ------------------------------


  • 2.  RE: Unable to install CP4D 3.0.1 through web client

    Posted Wed July 08, 2020 03:59 AM
    Hi,

    This is a new feature in 3.0.1. which checks the token validity by doing `oc get oauthaccesstoken` - maybe your user doesn't have the permission to see the data.
    This should however not stop you from installing - its only a warning.

    Thanks

    ------------------------------
    TOMASZ HANUSIAK
    ------------------------------



  • 3.  RE: Unable to install CP4D 3.0.1 through web client

    Posted Wed July 08, 2020 01:58 PM

    Hi Tomasz,

    The scope of the user is "full" and I have verified this by running the command `oc get oauthaccesstoken`. Since I own the cluster and I have admin access to it, I believed that there should not be any permission restrictions. This is the last log that I am seeing:

     2020/07/07 23:29:27 Terraform apply | *** Transferring all required images ***
     2020/07/07 23:29:27 Terraform apply | 
     2020/07/07 23:29:27 Terraform apply | [INFO] [2020-07-07 23:23:44-0237] Transferring image zen-meta-couchdb:v3.0.1.0-x86_64-45 from repository base-registry (1/17)
     2020/07/07 23:29:27 Terraform apply | Getting image source signatures
     2020/07/07 23:29:27 Terraform apply | [INFO] [2020-07-07 23:23:45-0140] Failed. Retrying in 5 seconds...
     2020/07/07 23:29:27 Terraform apply | Getting image source signatures
     2020/07/07 23:29:27 Terraform apply | [INFO] [2020-07-07 23:23:50-0975] Failed. Retrying in 5 seconds...
     2020/07/07 23:29:27 Terraform apply | Getting image source signatures
     2020/07/07 23:29:27 Terraform apply | [INFO] [2020-07-07 23:23:56-0987] Failed. Retrying in 5 seconds...
     2020/07/07 23:29:27 Terraform apply | Getting image source signatures
     2020/07/07 23:29:27 Terraform apply | [INFO] [2020-07-07 23:24:02-0871] Failed. Retrying in 5 seconds...
     2020/07/07 23:29:27 Terraform apply | Getting image source signatures
     2020/07/07 23:29:27 Terraform apply | [INFO] [2020-07-07 23:24:08-0682] Failed. Retrying in 5 seconds...
     2020/07/07 23:29:27 Terraform apply | [ERROR] [2020-07-07 23:24:13-0684] Error trying to reuse blob sha256:b26afdf22be4e9c30220796780a297b91549a3b3041b6fdcbda71bf48a6912e7 at destination: error pinging docker registry image-registry-openshift-image-registry.cp4d-workshop-cluster-v4-2bef1f4b4097001da9502000c44fc2b2-0000.us-south.containers.appdomain.cloud: invalid status code from registry 503 (Service Unavailable)
     2020/07/07 23:29:27 Terraform apply | [ERROR] [2020-07-07 23:24:13-0685] Error in handling image request regarding zen-meta-couchdb:v3.0.1.0-x86_64-45 from registry docker://cp.icr.io/cp/cpd/zen-meta-couchdb:v3.0.1.0-x86_64-45 after 4 retries. Abort
     2020/07/07 23:29:27 Terraform apply | [ERROR] [2020-07-07 23:24:13-0686] Exiting due to error. Please check cpd-linux-workspace/Logs/CPD-2020-07-07T23-23-38.log for details
     2020/07/07 23:29:27 Terraform apply | Installation of assembly lite is not successful
     2020/07/07 23:29:27 Terraform apply |  The Services installed successfully from the chosen services :  
     2020/07/07 23:29:27 Terraform apply |  The Services failed to install from the chosen services: + +lite 
     2020/07/07 23:29:27 Terraform apply | error: expected 'exec (POD | TYPE/NAME) COMMAND [ARG1] [ARG2] ... [ARGN]'.
     2020/07/07 23:29:27 Terraform apply | POD or TYPE/NAME and COMMAND are required arguments for the exec command
     2020/07/07 23:29:27 Terraform apply | See 'oc exec -h' for help and examples
     2020/07/07 23:29:27 Terraform apply | Installation not successful
     2020/07/07 23:29:27 Terraform apply | error: expected 'exec POD_NAME COMMAND [ARG1] [ARG2] ... [ARGN]'.
     2020/07/07 23:29:27 Terraform apply | POD_NAME and COMMAND are required arguments for the exec command
     2020/07/07 23:29:27 Terraform apply | See 'oc exec -h' for help and examples.
     2020/07/07 23:29:27 Terraform apply | 
     2020/07/07 23:29:27 Terraform apply | 
     2020/07/07 23:29:27 Terraform apply | 
     2020/07/07 23:29:27 Terraform APPLY error: Terraform APPLY errorexit status 1
     2020/07/07 23:29:27 Could not execute action


    ------------------------------
    Shivam Solanki
    ------------------------------



  • 4.  RE: Unable to install CP4D 3.0.1 through web client

    Posted Wed July 08, 2020 02:38 PM
    What procedure are you following to install CP4D ?

    ------------------------------
    TOMASZ HANUSIAK
    ------------------------------



  • 5.  RE: Unable to install CP4D 3.0.1 through web client

    Posted Wed July 08, 2020 02:59 PM
    I am installing it through UI. 


    ------------------------------
    Shivam Solanki
    ------------------------------



  • 6.  RE: Unable to install CP4D 3.0.1 through web client

    Posted Thu July 09, 2020 03:18 AM

    Hi,

    I've reviewed the errors again, and please note:

    error pinging docker registry image-registry-openshift-image-registry.cp4d-workshop-cluster-v4-2bef1f4b4097001da9502000c44fc2b2-0000.us-south.containers.appdomain.cloud: invalid status code from registry 503 (Service Unavailable)

    which suggest that your image registry is having issues.
    Can you check if you can access the registry with docker/podman ?

    Thanks



    ------------------------------
    TOMASZ HANUSIAK
    ------------------------------



  • 7.  RE: Unable to install CP4D 3.0.1 through web client

    Posted 30 days ago
    Have you found a way to fix this problem? I was trying to install CP4D v3.0.1 and v3.5 in an OCP cluster 4.6.6 through cpd-cli and faced this same error message. The installations are working fine in OCP 4.5.x and 4.4.x, but on this OCP cluster 4.6.6 I always got this error message:

    Server Version: 4.6.6
    Kubernetes Version: v1.19.0+43983cd

    [ERROR] [2020-12-15 13:18:11-0008] Error verifying current oauth token - Error from server (NotFound): oauthaccesstokens.oauth.openshift.io "sha256~bkFZqnWoLgfXOl0tESzKPldbDWLHO3Q_D0y6y0v03Hk" not found

    [INFO] [2020-12-15 13:18:11-0010] cpd cannot verify token expiry time due to above error

    ------------------------------
    Jean Carlos Ribeiro Goncalves
    ------------------------------



  • 8.  RE: Unable to install CP4D 3.0.1 through web client

    Posted 11 days ago
    I'm experiencing the same problem. Have you found the solution?

    ------------------------------
    Stanisław Bartkowski
    ------------------------------



  • 9.  RE: Unable to install CP4D 3.0.1 through web client

    Posted 7 days ago
    Hi,  

    I was also encountering the same error after I installed CP4D v3.0.1 and trying to upgrade it with v3.5 on OCP cluster 4.6.6 using command line. I was using the below upgrade command.

    ./cpd-cli adm --repo repo-300.yaml --assembly wkc --namespace wkc --apply --accept-all-licenses

    ./cpd-cli upgrade -r ./repo-300.yaml -a wkc -n wkc -c portworx-shared-gp3 --transfer-image-to=$REGISTRY/wkc --target-registry-username kubeadmin --target-registry-password $(oc whoami -t) --insecure-skip-tls-verify --cluster-pull-prefix image-registry.openshift-image-registry.svc:5000/wkc --version 3.5.2

    Solution:   As a workaround I added to bypass this issue, I added "--silent-install".

    ./cpd-cli upgrade -r ./repo-300.yaml -a wkc -n wkc -c portworx-shared-gp3 --transfer-image-to=$REGISTRY/wkc --target-registry-username kubeadmin --target-registry-password $(oc whoami -t) --insecure-skip-tls-verify --cluster-pull-prefix image-registry.openshift-image-registry.svc:5000/wkc --version 3.5.2   --silent-install




    ------------------------------
    Srinivas MANGI
    ------------------------------