Planning Analytics

Expand all | Collapse all

PAW Unable to Connect to TM1 Database

  • 1.  PAW Unable to Connect to TM1 Database

    Posted Tue May 28, 2019 09:30 AM
    Hi, 

     I am using the Planning Sample TM1 database to test the installation process of Planning Analytics Workspace. I can connect to the Welcome Page of PAW.  The issue is when I try to create a New Book, instead of seeing  the TM1 database, I get the following error: 

    "Path not exist" 

    I also navigated to the "Administer" page where I could pick up the Planning Sample TM1 database. I can see the TM1 server that is running but it also shows an error message: 

    "Cannot display resource information. Unable to connect to server."

    This is my first time installing Planning Analytics Workspace so please forgive me if I have missed out any information that might help in this instance. PAW is installed on the below environment: 

    - Hyper-V Virtual Machine
    - Windows Server 2016 Standard Edition OS
    - Docker EE version 18.09.6
    - Docker-Compose version 1.24.0
    - PAW version 2.0.41
    - TM1 version PA 2.0.6

    I even turned off Firewalls (Both Windows and ESET) and I still get the same error on both the server and on a separate client machine.

    ------------------------------
    Siyabulela Mayeza
    ------------------------------


  • 2.  RE: PAW Unable to Connect to TM1 Database

    Posted Wed May 29, 2019 11:38 AM
    Hi,

    Is Planning Analytics Sample setup with the same security that you are using to authenticate to Workspace?  If you set up workspace to authenticate using CAM, have you switched the sample to use security more 4 or 5?
    If you are using the non CAM method (security mode 1), is the Planning Analytics Sample the main tm1 server Workspace is authenticating to?    If not, do both the primary tm1 instance and the planning analytics sample have the same account set up in both with the same user name and password?  Also make sure that you have a password in both cases, PAW does not handle blank passwords gracefully.

    Let me know if this helps.

    ------------------------------
    Luck,
    Scott Brown
    ------------------------------



  • 3.  RE: PAW Unable to Connect to TM1 Database

    Posted Wed June 05, 2019 05:57 AM
    Hi,

    An update:

    After re-installing PAW AND adding the TM1 PortNumber onto the Inbound Firewall Rules, I can now access the TM1 Server via PAW. The following changes were made:

    1. updated the tm1s.cfg file.
    - IPAddress=T
    - IPVersion=ipv4

    2. Added TM1 PortNumber, AdminServer Ports, and HTTPPortNumber onto the Inbound Firewall Rules.

    The above seemed to take care of the "Path Not Exist" error. I am still unable to see the TM1 Server resource info on the administration tab, but that is a secondary issue at this point. If I crack that as well, I'll be sure to update this thread.

    ------------------------------
    Siyabulela Mayeza
    ------------------------------



  • 4.  RE: PAW Unable to Connect to TM1 Database

    Posted Wed June 05, 2019 11:25 AM
    Hi,

    It looks like PA Administration Agent uses port 9012.

    https://www.ibm.com/support/knowledgecenter/en/SSD29G_2.0.0/com.ibm.swg.ba.cognos.tm1_inst.2.0.0.doc/c_tm1_install_paa.html
    Ibm remove preview
    View this on Ibm >


    ------------------------------
    Good Luck,
    Scott Brown
    ------------------------------



  • 5.  RE: PAW Unable to Connect to TM1 Database

    Posted Thu June 06, 2019 04:44 AM
    Eureka!!

    That solved the problem. Thanks Scott. So in summary, one needs to create a firewall rule for:
    - PA Admin Agent Port - 9012
    - PA Admin Server Port - 5495,5498
    - PA Instance PortNumber - defined in tm1s.cfg
    - PA Workspace Admin Tool URI Ports - defined in PAW administration tool

    I wish the person documenting the installation guide would have highlighted this.

    ------------------------------
    Siyabulela Mayeza
    ------------------------------



  • 6.  RE: PAW Unable to Connect to TM1 Database

    Posted 4 days ago
    Hi Siyabulela,

    Can you please tell me if I should create an inbound or an outbound rule? Also please help me understand how you created the firewall rules for:
    - PA Admin Agent Port - 9012
    - PA Admin Server Port - 5495,5498
    - PA Instance PortNumber - defined in tm1s.cfg
    - PA Workspace Admin Tool URI Ports - defined in PAW administration tool


    ------------------------------
    satnam singh
    ------------------------------



  • 7.  RE: PAW Unable to Connect to TM1 Database

    Posted 4 days ago
    Hi,

    It needs to be an Inbound Firewall Rule. Make sure that all ports listed below are on this rule (seperate these using a comma).  Follow the below steps to set up the firewall rules:

    1. Start -> Administrative Tools -> Windows Firewall With Advanced Security
    2. Click on Inbound Rules on left pane
    3. Click New Rule… on the Right Pane
    4. Select Rule Type -> Port and click Next
    5. Select TCP
    6. Specify all the ports used by TM1, separated by comma and then click Next
    7. Select Allow the connection radio button and then click Next
    8. Ensure all Checkboxes are ticked and then Click Next
    9. Give the new Rule a name e.g. TM1 Ports and then click Finish


    ------------------------------
    Siyabulela Mayeza
    ------------------------------