Cognos Analytics

Expand all | Collapse all

Problems with the link to a report in the recent list of the home page when there is a new version of that report

  • 1.  Problems with the link to a report in the recent list of the home page when there is a new version of that report

    Posted Mon July 22, 2019 05:56 AM
    Hello every cognos expert,

    At this moment we have cognos analytics version 11.0.12.
    The users of us are used to use the recent link to open the report.
    But if a new version of that report comes,  is the old version replaced and the name of the report remains the samen.
    At that time the old recent link to the report does not work any more because the report get another id now.
    The users dont't know what to do when they get error message.
    They have to go to the correct map to find the report instead of using the recent link.

    This problem has happened many time already and it is really inconvinent and it brengs negative image about our department.

    Does someone know the solution or have suggestion about this problem?

    Thanks a lot in advance!
    Best regards,
    Sisi


    ------------------------------
    Sisi Wu
    ------------------------------


  • 2.  RE: Problems with the link to a report in the recent list of the home page when there is a new version of that report

    Posted Mon July 22, 2019 08:50 AM
    Hey Sisi
    If i run copy the link from "share" under report options i get the same error as you.

    But if i send the report link to myself and use the link from there it dosnt give me problems. The link you get from cognos uses the object ID instead of direct URL. This link works nomatter how many times i update the report, it always shows the last output. 

    I use cognos 11.0.11. 

    IBM Documentation:
    For more info check here

    ------------------------------
    Morten Frandsen
    ------------------------------