Cognos Analytics

Expand all | Collapse all

Getting error "UDA-SQL-0432" in cognos FM while connecting to a datasource

  • 1.  Getting error "UDA-SQL-0432" in cognos FM while connecting to a datasource

    Posted 2 days ago
    Hi,
    I am trying to connect cognos FM to a datasource and I am getting the following error in the process:
    ------------------------------------------------------
    QE-DEF-0285 The logon failed.
    QE-DEF-0325 The logon failed for the following reason:
    RQP-DEF-0068 Unable to connect to at least one database during a multi-database attach to 1 database(s) in:
     TEST

    UDA-SQL-0432 Unable to locate the gateway "cogudaor".
    ------------------------------------------------------
    This datasource is working fine from cognos connection and I am able to create data modules and reports based on this.
    I am creating the model using DQM in cognos FM ,but I am still getting this error.
    I have installed Cognos FM (V1.1.7) on 09June2021 and there are no existing models.
    Can you please help me with this issue.

    Could it be a FM configuration issue?

    Thanks


    ------------------------------
    tushar gaurav
    ------------------------------


  • 2.  RE: Getting error "UDA-SQL-0432" in cognos FM while connecting to a datasource

    Posted 2 days ago

    Hi,

    do you use an Orace DB with a CQM FM model? In this case it sounds that you haven't defined the TNS_ADMIN env variable or you haven't installed the Oracle client on your local machine where FM is installed:
    https://www.ibm.com/support/pages/uda-sql-0432-unable-locate-gateway-cogudaor-when-running-standard-report-or-testing-data-source



    ------------------------------
    Robert Dostal
    Team Leader BI
    GEMÜ
    Ingelfingen
    ------------------------------