Cognos Analytics

Expand all | Collapse all

11.1.7 FP1 Causing Errors in Dashboards and Stories

Jump to Best Answer
  • 1.  11.1.7 FP1 Causing Errors in Dashboards and Stories

    Posted 19 days ago
    Hi all,

    Since applying 11.1.7 FP1 our dashboards and stories are producing various errors, such as:
    • undefined is not an object (evaluating 'e.getFeature("Visualization").getSlots')
    • The data for this data set is not available. Refresh the data set or contact your administrator for access to the source.
    • Unable to load requested view.

    Some visualizations do load. And I have refreshed and relinked the data set successfully but that does not resolve the problems. Also, I can create a new dashboard with that same data set. But I do not want to recreate all of the dashboards and stories.

    While I wait for a response from support, I wonder if anyone else has experienced this?


    Thanks,
    Jeremy

    ------------------------------
    Jeremy Aude
    ------------------------------


  • 2.  RE: 11.1.7 FP1 Causing Errors in Dashboards and Stories

    Posted 17 days ago
    Hi Jeremy,

    I just upgraded our test environment to CA 11.1.7 FP1 and I don't detect any problems with the Dashboard.

    Regards,

    Xavier

    ------------------------------
    Xavier Votion
    ------------------------------



  • 3.  RE: 11.1.7 FP1 Causing Errors in Dashboards and Stories

    Posted 17 days ago
    Most times this issue is browser cache. The caching time for cognos content is to high so people run into not uptodate content in their browser.

    ------------------------------
    Sven Jansen
    ------------------------------



  • 4.  RE: 11.1.7 FP1 Causing Errors in Dashboards and Stories

    Posted 17 days ago
    Hi all,

    Quick update: I had a WebEx with support and there does seem to be a problem where the dashboard is referencing ids for a data set that no longer exist. Luckily for me this only impacts a few dashboards. I can fix by deleting the problem widget and data source, add it back and recreate the visualization. I provided the json file to the support rep so they can investigate with the IBM development team.




  • 5.  RE: 11.1.7 FP1 Causing Errors in Dashboards and Stories

    Posted 15 days ago
    Hi, Jeremy!

    I'm facing some issues with 11.1.7 IF002 and I'm planning to install Fix Pack 1.

    But, I have 7k users that have 100k reports and dashboards. Your point is concerning me.

    When this issue occurs? When you have a dashboard uses datasets as source directly, i.e., not linked by a data module?

    Thanks!

    ------------------------------
    JEAM COELHO
    Cognos Solution Architect

    LinkedIn: https://www.linkedin.com/in/jeamcoelho/
    ------------------------------



  • 6.  RE: 11.1.7 FP1 Causing Errors in Dashboards and Stories

    Posted 15 days ago
    Hi Jeam,

    Yes the problem is occurring using a data set. Data set is built from a data module. I’ll let you know when I hear more from support!




  • 7.  RE: 11.1.7 FP1 Causing Errors in Dashboards and Stories
    Best Answer

    Posted 11 days ago
    FYI @JEAM COELHO

    Support was able to find the cause. Following the steps outlined in this support link resolved my problem: https://www.ibm.com/support/pages/node/6349499


    ------------------------------
    Jeremy Aude
    ------------------------------



  • 8.  RE: 11.1.7 FP1 Causing Errors in Dashboards and Stories

    Posted 9 days ago
    Hi, Jeremy!

    Thank you very much!




    ------------------------------
    JEAM COELHO
    Cognos Solution Architect

    LinkedIn: https://www.linkedin.com/in/jeamcoelho/
    ------------------------------