Robotic Process Automation

Expand all | Collapse all

Get Vault Item

  • 1.  Get Vault Item

    Posted 7 days ago
    I am having an interesting issue.

    In the Portal I have added a new Credential Demo and set a username and password.
    I have not done anything with the Credential Pool

    In my Script I use the GetVaultItem the name is Demo and system is turned on.
    After the call the boolean vaultSuccess variable is false in the log

    Now in another test if I set up another Vault Credential and set it in the Vault I can get it no problem
    using GetValutItem and of course not setting system.

    I would rather get them from the system as they are Service User Accounts

    Any idea what I might be doing wrong?

    ------------------------------
    Troy DesBarres
    ------------------------------


  • 2.  RE: Get Vault Item

    Posted 7 days ago

    Hi,

    To get credential the system (turn on), You must create the credential here (Credentials > Credentials)


    In Configuration > Credential, you create a credential for the user (RDA) to use IBM Vault in the machine.



    ------------------------------
    Angelo Alves
    ------------------------------



  • 3.  RE: Get Vault Item

    Posted 7 days ago
    Hi Troy!

    In order to use "the system vault" I think you also need to set your tenant credentials in your tenant configuration - generate public-private keys and upload the public key and configure the path for the client folder to store the private key. This is to enforce the security for the credentials you store as "system" credentials.



    ------------------------------
    Jukka Juselius
    Senior Solution Architect - IBM EMEA
    WDG Automation Program Lead for EMEA
    IBM Technology - Business Automation
    ------------------------------



  • 4.  RE: Get Vault Item

    Posted 7 days ago
    Good morning teams I think we are on to something here. I do have the credential setup correctly but I do not have the public private keys setup.

    Jukka I assume that when you say "generate public-private keys" that I do not do this task in WDG that I do this in Windows, correct?

    Thanks so much
    Troy


    ------------------------------
    Troy DesBarres
    ------------------------------



  • 5.  RE: Get Vault Item

    Posted 7 days ago
    Yep, you first need to generate the keys, then upload the public key to your tenant and also configure where the private key should be found in your agent (runtime) computer.

    ------------------------------
    Jukka Juselius
    Senior Solution Architect - IBM EMEA
    WDG Automation Program Lead for EMEA
    IBM Technology - Business Automation
    ------------------------------



  • 6.  RE: Get Vault Item

    Posted 5 days ago
    Ok I have used PuttyGen to create a public and private key. I then went into the Portal -> Tenant Configuration -> Credentials.

    Under Public I browsed to my Public.pem file.

    Under Private Key I selected File Type: PEM File Path: <Path to Private Key>\Private.ppk

    I have also tried PCKS

    I click on 'Yes' to the Are you Sure Primpt 

    And then I see An Error Occurred, Try Again

    I should also note that I did not password protect my private key as there was a message on the Portal not to do that.

    ------------------------------
    Troy DesBarres
    ------------------------------