WebSphere Application Server & Liberty

  • 1.  not possibile to run an app on webshere 8.5

    Posted Mon September 20, 2021 07:20 AM
    Hi all I new with Websphere and I tried to do the following example:
    https://developer.ibm.com/recipes/tutorials/deploying-vaadin-8-8-2-on-websphere-application-server-8-5-5-15-traditional/#r_overview

    But I get:


    I've checked that the vm in the eclipse.ini file is from IBM and it is 8 , checked that the VM used to compile with maven is the same, but eclipse still tell me that the server use SDK 7;

    Could please some one help me?? really thanks;
    I attacched some other screen shot in order to see the SDK used in other process of development:
    1. Maven




    2.run time enviroment


    Is something I'm wrong?? 
    really thanks 
    Francesco






      



    ------------------------------
    francesco Viscomi
    ------------------------------


  • 2.  RE: not possibile to run an app on webshere 8.5
    Best Answer

    Posted Tue September 21, 2021 02:49 AM
    Hello Francesco,
    which version of WAS v8.5 are you running? Did you install any fixes on top of the (outdated) WAS v8.5? As the error message says it sounds like your WAS is running on Java 7. Please can you run the followng command from the <profileHome>/bin directory to check with JDK is enabled in your installation:
    ./managesdk.sh -listEnabledProfileAll​

    and the please run the following to list the available SDKs:

    ./managesdk.sh -listAvailable

    to see of a JRE 8 is available at all (if I remember correctly Java8 support was added to WAS v8.5 only at a later time via a fix pack).

    If you don't have a good reason to use WAS v8.5 I'd however recommed to use WAS v9 instead (makes you life easier :) ).

    Hope that helps - Hermann



    ------------------------------
    Hermann Huebler
    2innovate IT Consulting GmbH
    Vienna
    Austria

    #IBMChampion
    ------------------------------



  • 3.  RE: not possibile to run an app on webshere 8.5

    Posted Tue September 21, 2021 08:46 AM
    Francesco

    As Hermann noted the error message indicates that you're using JDK 7 for tWAS, so please update to JDK 8. I'd also encourage your to update to the latest fixpack as well.

    That said, I'm going to suggest that you not update to tWAS v9.x, unless you have need for Java 7 EE.
    This because both tWAS v8.5.5 and v 9.05 are supported until 2030, 

    https://www.ibm.com/cloud/blog/announcements/ibm-websphere-2030-support-announcement 
    and one of the primary reasons for extending support for both versions was so that clients didn't have to invest in migration from v8.5.5 to v9.05 in order to continue to be supported.
    Instead we're recommending that clients invest their time and effort in migration from tWAS to Liberty since Liberty is a cloud appropriate application server and it provides additional API's, e.g. Java 8 EE/Jakarata 8 EE, which aren't available in tWAS, as well as support for Java 11 SE (as well as later versions of Java SE). Anticipating the obvious question, there are no plans to deliver Java 8 EE in tWAS, this because Java 8 EE (as well as Java9 EE) is focused on microservices, and it doesn't make sense to run a microservice application in a monolithic application server such as tWAS.
    Additional there are no plans to update the Java SE level in tWAS beyond Java 8 SE, this because of architectural differences in Java 9 SE and above, which are incompatible with the tWAS architecture.



    ------------------------------
    Tom Alcott
    Senior Technical Staff Member
    IBM
    ------------------------------



  • 4.  RE: not possibile to run an app on webshere 8.5

    Posted Tue September 21, 2021 12:36 PM
    Thanks for the information, it's good to know that the support is still valid for 8.5.5, even if I think my boss is thinking to pass to microservices :)

    ------------------------------
    francesco Viscomi
    ------------------------------



  • 5.  RE: not possibile to run an app on webshere 8.5

    Posted Wed September 22, 2021 12:05 AM
    Good morning Francesco, sure tWAS v85 is still supported for several years but nevertheless you should keep it current by applying the latest fixpacks. See https://www.ibm.com/support/pages/recommended-updates-websphere-application-server for the latest available fixpacks per version.

    Well, I think the plan to migrate to a microservices based topology is in line with IBMs intention to extens tWAS support to give customers time to migrate to Liberty based architectures. Btw, have you heart about IBM's Mono2Micro approacht? See https://www.ibm.com/cloud/blog/announcements/ibm-mono2micro - maybe that helps in transforming your application faster?

    ------------------------------
    Hermann Huebler
    2innovate IT Consulting GmbH
    Vienna
    Austria

    #IBMChampion
    ------------------------------