IBM Security MaaS360

Expand all | Collapse all

'Last Reported' not updating after migrating from Android DA to AE

  • 1.  'Last Reported' not updating after migrating from Android DA to AE

    Posted 14 days ago
    Hi!

    I am in the process of migrating a customer's Samsung phones from Device Admin to Android Enterprise. After a successful migration, the 'Last Reported' timestamp for the device is apparently no longer automatically updated. In order for 'Last Reported' to be updated I must execute a 'Request Data Refresh' operation against the device. The 'Last Device Attestation Result' timestamp however appears to be automatically updated.

    Any ideas?

    ------------------------------
    Arne Halsteinslid
    ------------------------------


  • 2.  RE: 'Last Reported' not updating after migrating from Android DA to AE

    Posted 13 days ago

    Hi Arne,

    From what you've seen so far would you say that the devices go 24 hours or longer without checking in automatically once the migration is complete?



    ------------------------------
    Matt Shaver
    System Architect
    IBM
    mshaver@us.ibm.com
    ------------------------------



  • 3.  RE: 'Last Reported' not updating after migrating from Android DA to AE

    Posted 12 days ago
    Hi Matt,

    Correct!

    It looks like the 'Last Reported' timestamp for the device is not updated unless:
    a) A 'Request Data Refresh' operation is issued against the device, or
    b) The user of the device executes the 'Update Device Data' operation

    Migrated devices are therefore accumulating in the 'Long Inactivity' report of the Home view.

    ------------------------------
    Arne Halsteinslid
    ------------------------------



  • 4.  RE: 'Last Reported' not updating after migrating from Android DA to AE

    Posted 9 days ago
    Would you mind pulling logs from a device that hasn't checked in for 24+ hours (if possible) and opening a ticket via ibm.com/mysupport?  We're going to need dev to look in to this.  Barring any network issues (which doesn't seem to be the case since they can check in) I can't think of anything portal side that would cause this behavior.

    ------------------------------
    Matt Shaver
    System Architect
    IBM
    mshaver@us.ibm.com
    ------------------------------



  • 5.  RE: 'Last Reported' not updating after migrating from Android DA to AE

    Posted 8 days ago
    I have had to use my Samsung test device in several MDM solutions lately, enrolling it and subsequently removing the work profile, hence I currently have no logs.

    Today I enrolled it in the same MaaS360 solution where the problem was observed, will update this thread once I see how it goes.

    ------------------------------
    Arne Halsteinslid
    ------------------------------